General TC > General TC Talk

[Solved] grub cannot read usb drive's ext4 partition

(1/7) > >>

I followed Juanito's wonderful instructions on how to create a device that will boot with either BIOS or (U)EFI here:,19364.0.html

I have an old laptop with legacy BIOS, with frugal TCL installation on SSD. Thanks to Juanito's directions, my SSD can now boot in any laptop--I can continue to boot it in my old laptop, or I can transfer the SSD to a newer laptop that only supports UEFI. Tested and working! :)

I followed the same instructions to try to create a bootable USB stick with TCL on it (for rescue operations) but, surprisingly, I cannot get the stick to boot. My old laptop is able to find grub in the EFI partition, menu entries in grub.cfg are shown, but kernel cannot be found because grub claims the root filesystem is unknown.

Please see the attached screenshot. As you can see, grub is able to recognize an ext4 filesystem (hd1,gpt1) on my SSD just fine, but it cannot recognize an ext4 filesystem (at hd0,gpt1) on the USB drive. The filesystem is definitely ext4:

--- Code: ---$ blkid /dev/sdb1
/dev/sdb1: UUID="7283ed99-3225-4add-be42-3d3031e5eb7b" BLOCK_SIZE="4096" TYPE="ext4" PARTLABEL="Linux filesystem" PARTUUID="fdf388fb-54af-4d3c-97c5-bc17455a527f"

--- End code ---

I already tried
--- Code: ---insmod linux
--- End code ---
at the grub prompt and it didn't help. I also deleted all partitions from the USB stick and did everything again from the beginning, with same results.

Any idea why grub is unable to access the ext4 partition on /dev/sdb1 (which it sees as hd0,gpt1)?

The partitioning scheme of the USB drive is shown in the attached screenshot.

/mnt/sdb3/EFI/BOOT/grub/grub.cfg is also attached (I tried to include it here but got a server error).

Hi GNUser!
May old laptop be confused by GPT?

Hi jazzbiker! I don't think that's it. Same exact strategy is currently being used on this laptop's SSD, and I can boot the SSD just fine.

EDIT: I'll try to boot this USB stick on the fancy new UEFI-only laptop, to confirm that the problem is with the USB stick.

I think you missing the gpt drivers, try to load them into grub.cfg

--- Code: ---insmod part_gpt
insmod part_msdos

--- End code ---


[0] Message Index

[#] Next page

Go to full version