Tiny Core Base > Micro Core

cfdisk missing

(1/2) > >>

Hello to all,

I'm new here for TinyCore and trying to install it on a VM from ISO loaded via Virtual CD-ROM

I allocated 25GB virtual-disk, and via GUI and CLI trying to install CFdisk so I can partition the new HD in order to install TC permanently but for the life of me I cannot find a way to load CFdisk!! PLEASE HELP  ;) ;) ;)

I tried:
tce-load -w -i cfdisk
tce-load -w -i util-linux-dev.tcz
tce-load -w -i util-linux.tcz
tce-load -w -i fdisk.tcz
and more and more and more...... Cannot run fdisk -l

can someone please give me some direction on what else I can do.

My appologies for the rookie question and many thanks in advance


Hi Yuval711
Welcome to the forum.

When you run:

--- Code: ---tce-load -w -i util-linux.tcz
--- End code ---
Does it succeed or report an error?

If it succeeded:
Sometimes the terminal you are working in doesn't realize
an extension added new commands. When this happens, you
can either run:

--- Code: ---hash -r
--- End code ---
or open a new terminal.

Hey Rich,

Thanks for getting back to me. I now realize that the util-linux is indeed install as I can run 'fdisk -l' and it does list a bunch of virtual mount points. I am running it on an ESX or VMware but not able to use the mouse at all. I'm forced to use the terminal through the GUI only.

However the Virtual HD is never being discovered. I try to run cfdisk /dev/sda. I keep getting the error

cfdisk: cannot open /dev/sda/: No such device or address.

Do you know why i get this message?

Hi Yuval711
I've never used ESX or VMware. I run on bare metal.
I played with Qemu a couple of times:

Maybe some of the information in those 2 threads applies to ESX or VMware.

@Yuval711: When setting up the virtual machine, be sure to configure the hard drive as IDE instead of SCSI - this makes life a lot easier for ESXi, TinyCore and for you.  As for the mouse, that should work right out of the box.  When setting up, choose LINUX - OTHER and be sure to enable USB2.0.  (Bare in mind, I have not done ESX and TC together for some time; memories may be a little rusty!)


[0] Message Index

[#] Next page

Go to full version