WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Blank screen after grub but TC loads ok  (Read 948 times)

Offline jason_raasify

  • Newbie
  • *
  • Posts: 2
Blank screen after grub but TC loads ok
« on: October 02, 2023, 05:50:53 PM »
Hi,

I'm having display issues with my custom build based off TinyCorePure64-13.1.iso

The grub screen looks fine, then when the kernel loads, the screen goes blank. At this point, if I hit the up/down arrow on the keyboard I get beeps.

I know TC is loaded ok because I installed ssh server on this image and I can ssh in ok.

I looked for the "Above 4G decoding" setting in the bios but it doesn't have it.

I've tested it on 2 different hosts with the same issue. They are both those little NUC boxes you can get off Aliexpress (such as https://www.aliexpress.us/item/3256804116114245.html)

I use TinyCore as a USB installer OS, so I have a Packer built custom Ubuntu raw image embedded into the Tinycore image which I then "dd" to the NVME disk on the NUC.
This process works fine via ssh and then the custom Ubuntu loads ok, and the keyboard/display work no problem with the custom Ubuntu.

I also tried the stock TinyCorePure64-13.1.iso flashed to USB (Etcher) and I get the same issue. Just no display after the grub menu and beeps on arrow up/down.

Am I missing some drivers for this little NUC device that I need to add to my custom TC image? Any idea how to debug further?

Cheers,

Jason

======

# grub.cfg

loadfont unicode
set gfxmode=1024x768
set gfxpayload=1024x768
set gfxterm_font=unicode
terminal_output gfxterm

menuentry "core" {
  linux /boot/vmlinuz64
  initrd /boot/corepure64.gz
}

set timeout=1
« Last Edit: October 02, 2023, 05:53:12 PM by jason_raasify »

Online Rich

  • Administrator
  • Hero Member
  • *****
  • Posts: 11220
Re: Blank screen after grub but TC loads ok
« Reply #1 on: October 02, 2023, 06:36:10 PM »
Hi jason_raasify
Welcome to the forum.

... The grub screen looks fine, then when the kernel loads, the screen goes blank. At this point, if I hit the up/down arrow on the keyboard I get beeps. ...
If you hit the  Enter  key a couple of times, do you get a command prompt?

Go to this search page:
https://forum.tinycorelinux.net/index.php?action=search

Set the search parameters as follows
Search for: intel nuc
By user: pdp-8

pdp-8 did a bunch of write-ups on the intel nuc.

Offline jason_raasify

  • Newbie
  • *
  • Posts: 2
Re: Blank screen after grub but TC loads ok
« Reply #2 on: October 02, 2023, 09:15:03 PM »
Hi Rich,

I ended up just needing to install "xf86-video-intel". And then add "modprobe i915" to bootlocal.sh
   
Cheers,

Jason


Offline gadget42

  • Hero Member
  • *****
  • Posts: 662
Re: Blank screen after grub but TC loads ok
« Reply #3 on: October 02, 2023, 10:15:16 PM »
thanks for letting us know your solution!
The fluctuation theorem has long been known for a sudden switch of the Hamiltonian of a classical system Z54 . For a quantum system with a Hamiltonian changing from... https://forum.tinycorelinux.net/index.php/topic,25972.msg166580.html#msg166580