WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Is the repo server down?  (Read 3033 times)

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 14572
Re: Is the repo server down?
« Reply #15 on: September 03, 2023, 01:22:12 PM »
You also need dtoverlay=vc4-kms-v3d-pi4
« Last Edit: September 04, 2023, 01:27:21 AM by Juanito »

aus9

  • Guest
Re: Is the repo server down?
« Reply #16 on: September 03, 2023, 07:40:26 PM »
meo, from a younger man to older one...you may like to learn from my mistakes.
The boot order in your boot list such as onboot.lst needs this order

Quote
graphics-KERNEL.tcz
Xorg-3d.tcz
blah blah.tcz

You may like to look at Paul_123's get-chromium-browser as it plays mp4 out-of-the-box and plays sound if you are only using alsa. I am sure it would also play sound if you set up pulseaudio too.

He is too poiltie to recommend it, but it is more recent than FF built in 2020. Someone may be attempting to make a get-firefox TCE but until then....I recommend you try out chromium.

https://imgur.com/haC3JYJ

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 14572
Re: Is the repo server down?
« Reply #17 on: September 04, 2023, 02:24:38 AM »
After thinking about it I guess that I have to make a new installation from the beginning. // meo

There’s no need to make a new installation, you just need to substitute Xorg-3d for Xorg when loading extensions.

Offline meo

  • Hero Member
  • *****
  • Posts: 651
Re: Is the repo server down?
« Reply #18 on: September 04, 2023, 04:48:23 AM »
Thanks guys! It took a while but with your help it worked. Typing this from the Chromium-browser. Thanks again! // meo
"All that is very well," answered Candide, "but let us cultivate our garden." - Francois-Marie Arouet Voltaire

Offline meo

  • Hero Member
  • *****
  • Posts: 651
Re: Is the repo server down?
« Reply #19 on: September 04, 2023, 05:13:12 AM »
The installation has a snag though.  :( When rebooting I get the error message "failed in waitforX". Apparently I have to make an entry in a configuration file to get x to start automatically. Getting the error message I was left with a command prompt and had to startx manually. I remember that this sometimes had to be done when booting from an usb drive. Don't remember though where the waitforX should be inserted. // meo


PS I feel bad bugging you guys all the time but my memory isn't what it should be. DS
"All that is very well," answered Candide, "but let us cultivate our garden." - Francois-Marie Arouet Voltaire

Online Rich

  • Administrator
  • Hero Member
  • *****
  • Posts: 11256
Re: Is the repo server down?
« Reply #20 on: September 04, 2023, 05:34:22 AM »
Hi meo
I have a laptop that behaves the same way. I inserted a sleep
command in the .xsession file in my home directory like this:
Code: [Select]
tc@E310:~$ cat .xsession
sleep 3
/usr/local/bin/Xorg -nolisten tcp &
export XPID=$!
waitforX || ! echo failed in waitforX || exit
 ----- Snip -----

That got rid of the  failed in waitforX  error.

Offline Paul_123

  • Administrator
  • Hero Member
  • *****
  • Posts: 1089
Re: Is the repo server down?
« Reply #21 on: September 04, 2023, 06:07:07 AM »
You may have to go higher with the sleep time.  It happens because the graphics system takes a little time to initialize.

Offline meo

  • Hero Member
  • *****
  • Posts: 651
Re: Is the repo server down?
« Reply #22 on: September 04, 2023, 06:13:46 AM »
Thanks Rich! I was just about to say that I had to put it to sleep 10 then it starts. Thanks again! // meo
"All that is very well," answered Candide, "but let us cultivate our garden." - Francois-Marie Arouet Voltaire

Online Rich

  • Administrator
  • Hero Member
  • *****
  • Posts: 11256
Re: Is the repo server down?
« Reply #23 on: September 04, 2023, 06:55:07 AM »
Hi meo
What Paul_123 just said jogged my memory. When I switched the
laptop from Xorg to Xorg-3d, I changed from sleep to this:
Code: [Select]
Timeout=60
while [ $Timeout -gt 0 ]
do
        [ -e /dev/dri/card0 ] && break
        Timeout=$(($Timeout - 1))
        sleep 0.25
done

/usr/local/bin/Xorg -nolisten tcp &
export XPID=$!
waitforX || ! echo failed in waitforX || exit
 ----- Snip -----
That waits for 15 seconds or until /dev/dri/card0 shows up, whichever
comes first. The laptop usually continues after 8 seconds.

I found the issue was  /dev/dri/card0  by searching  /var/log/Xorg.0.log
for errors after  failed in waitforX  occurred.

Offline meo

  • Hero Member
  • *****
  • Posts: 651
Re: Is the repo server down?
« Reply #24 on: September 04, 2023, 11:24:17 AM »
Hi again guys! Thank you both (well everyone that has helped me out)! I have to ge with the first suggestion since the latter didn't fix the problem. Now the GUI starts automatically. Thanks again! // meo
"All that is very well," answered Candide, "but let us cultivate our garden." - Francois-Marie Arouet Voltaire

Online Rich

  • Administrator
  • Hero Member
  • *****
  • Posts: 11256
Re: Is the repo server down?
« Reply #25 on: September 04, 2023, 12:44:53 PM »
Hi meo
Did you search  /var/log/Xorg.0.log for errors after  failed in waitforX  occurred?
It might not be called  /dev/dri/card0  in piCore.

Offline meo

  • Hero Member
  • *****
  • Posts: 651
Re: Is the repo server down?
« Reply #26 on: September 08, 2023, 08:32:33 AM »
Hi Rich!

No I just mean that I use the first suggestion with the sleep command. That works for me. Thanks a lot!

// meo
"All that is very well," answered Candide, "but let us cultivate our garden." - Francois-Marie Arouet Voltaire