WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: [Solved] 14.x arm7 enchant needs pcre in dep please  (Read 899 times)

aus9

  • Guest
[Solved] 14.x arm7 enchant needs pcre in dep please
« on: August 31, 2023, 05:54:34 AM »
Hi

Not checked arm8 but
Code: [Select]
/tmp/tcloop/enchant/usr/local/bin$ readelf -d * | grep pcre
 0x00000001 (NEEDED)                     Shared library: [libpcre.so.1]
 0x00000001 (NEEDED)                     Shared library: [libpcre.so.1]
« Last Edit: September 27, 2023, 07:24:41 AM by Rich »

Online Rich

  • Administrator
  • Hero Member
  • *****
  • Posts: 11330
Re: 14.x arm7 enchant needs pcre in dep please
« Reply #1 on: August 31, 2023, 10:33:01 AM »
Hi aus9
This appears to be caused by an update to glib2.tcz which now depends
on pcre2.tcz instead of pcre.tcz. Dependency files for enchant.tcz have
been updated for armv6, armv7, and armv7l.

aus9

  • Guest
Re: 14.x arm7 enchant needs pcre in dep please
« Reply #2 on: September 27, 2023, 01:03:21 AM »
@Rich

Please mark as solved

Online Rich

  • Administrator
  • Hero Member
  • *****
  • Posts: 11330
Re: [Solved] 14.x arm7 enchant needs pcre in dep please
« Reply #3 on: September 27, 2023, 07:25:32 AM »
Hi aus9
Marked.