WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Xorg-7.7-3d.tcz...i965_dri.so  (Read 1194 times)

Offline gwalther

  • Full Member
  • ***
  • Posts: 139
Xorg-7.7-3d.tcz...i965_dri.so
« on: May 03, 2023, 10:41:53 AM »
i965_dri.so is included in Xorg-7.7-3d extension in the tc13 repo but is not included in the Xorg-7.7-3d tc14 repo...(64bit).  Is there a reason why?  Could I just copy over the i965_dri.so from my tc13 installation to my  tc14 installation.../usr/local/lib/dri/ ?

Offline Rich

  • Administrator
  • Hero Member
  • *****
  • Posts: 11220
Re: Xorg-7.7-3d.tcz...i965_dri.so
« Reply #1 on: May 03, 2023, 12:17:00 PM »
Hi gwalther
Quote
i965_dri.so was removed from Mesa 22.0 and replaced by crocus_dri.so or iris_dri.so (depending on the chipset) which should load right away.
Found here:
https://forums.gentoo.org/viewtopic-p-8713763.html?sid=1766cd995b223483a411e00649110da2

Offline gwalther

  • Full Member
  • ***
  • Posts: 139
Re: Xorg-7.7-3d.tcz...i965_dri.so
« Reply #2 on: May 04, 2023, 06:34:26 AM »
The reason I was looking for i965_dri.so was because of two error messages in  Xorg.0.log saying it could not load i965_dri.so and swrast_dri.so.  For some reason crocus or iris dri's do not get loaded.  My graphics are reported as Intel HD Graphics 530 in a Dell Optiplex 7040.  Glxinfo does not report direct rendering as yes.

Ok so I tried copying i965_dri.so and swrast_dri.so from my tc13 installation over to my tc14 installation in/usr/local/lib/dri/ and restarted from prompt....and it seems to work with no error messages in Xorg.0.log.  Glxinfo now reports ...direct rendering as yes.  All seems to work....strange.

Offline Rich

  • Administrator
  • Hero Member
  • *****
  • Posts: 11220
Re: Xorg-7.7-3d.tcz...i965_dri.so
« Reply #3 on: May 04, 2023, 07:10:07 AM »
Hi gwalther
... For some reason crocus or iris dri's do not get loaded. ...
Does  Xorg.0.log  make any references to  crocus  or  iris  like here:
https://forums.gentoo.org/viewtopic-p-8714138.html?sid=72ba8cab363d833017c814ea87f82700#8714138

If it does, try creating a  /etc/X11/xorg.conf.d/20-intel.conf  similar to this:
https://forums.gentoo.org/viewtopic-p-8716748.html?sid=72ba8cab363d833017c814ea87f82700#8716748

Offline gwalther

  • Full Member
  • ***
  • Posts: 139
Re: Xorg-7.7-3d.tcz...i965_dri.so
« Reply #4 on: May 05, 2023, 03:48:12 AM »
Thanks Rich....I put  20-intel.conf in /usr/local/share/X11/xorg.conf.d/ and restarted  at the prompt and the Xorg.0.log now show iris was used with other no error messages.