WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: meson,build:84:0: ERROR: Dependency "libkmod" not found  (Read 4410 times)

Offline qingquan

  • Newbie
  • *
  • Posts: 35
Re: meson,build:84:0: ERROR: Dependency "libkmod" not found
« Reply #15 on: January 05, 2023, 12:42:16 AM »
The first thing you do:
And there are no mistakes

cd open-isns-0.102
sudo./configure
make install
Still appear :meson.build:184:0: ERROR: C shared or static library 'isns' not found



Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 14636
Re: meson,build:84:0: ERROR: Dependency "libkmod" not found
« Reply #16 on: January 05, 2023, 04:12:32 AM »
Did you try building isns with meson instead of autotools (configure, make)?

Offline qingquan

  • Newbie
  • *
  • Posts: 35
Re: meson,build:84:0: ERROR: Dependency "libkmod" not found
« Reply #17 on: January 05, 2023, 04:40:28 AM »
Start over with the original TinyCorePure64-12.0

tce-load -iw compiletc.tcz
tce-load -iw tpm2-tss-dev.tcz
tce-load -iw curl-dev.tcz
tce-load -iw meson.tcz
tce-load -iw cmake.tcz
tce-load -iw kmod-dev.tcz
tce-load -iw util-linux-dev.tcz
tce-load -iw elogind-dev.tcz
tce-load -iw bash.tcz

tar -xvf open-isns-0.102.tar.gz
cd open-isns-0.102
sudo ./configure
sudo meson.build

Library slp found:NO

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 14636
Re: meson,build:84:0: ERROR: Dependency "libkmod" not found
« Reply #18 on: January 05, 2023, 05:13:30 AM »
You have to either use configure or meson, you should not use both.

Also, only use sudo with make install.

It looks like you might need to compile openslp.
« Last Edit: January 05, 2023, 05:18:15 AM by Juanito »

Offline qingquan

  • Newbie
  • *
  • Posts: 35
Re: meson,build:84:0: ERROR: Dependency "libkmod" not found
« Reply #19 on: January 05, 2023, 05:43:31 AM »
Start over with the original TinyCorePure64-12.0

tce-load -iw compiletc.tcz
tce-load -iw tpm2-tss-dev.tcz
tce-load -iw curl-dev.tcz
tce-load -iw meson.tcz
tce-load -iw cmake.tcz
tce-load -iw kmod-dev.tcz
tce-load -iw util-linux-dev.tcz
tce-load -iw elogind-dev.tcz
tce-load -iw bash.tcz

tar -xvf open-isns-0.102.tar.gz
cd open-isns-0.102
sudo ./configure
sudo meson.build

Library slp found:NO
---------------------------------
Start over with the original TinyCorePure64-12.0

tce-load -iw compiletc.tcz
tce-load -iw tpm2-tss-dev.tcz
tce-load -iw curl-dev.tcz
tce-load -iw meson.tcz
tce-load -iw cmake.tcz
tce-load -iw kmod-dev.tcz
tce-load -iw util-linux-dev.tcz
tce-load -iw elogind-dev.tcz
tce-load -iw bash.tcz

tar -xvf open-isns-0.102.tar.gz
cd open-isns-0.102
sudo./configure
sudo make install

no Error ,but "open-iscsi" meson.build:184:0: ERROR: C shared or static library 'isns' not found

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 14636
Re: meson,build:84:0: ERROR: Dependency "libkmod" not found
« Reply #20 on: January 05, 2023, 06:29:21 AM »
You need to compile this: https://sourceforge.net/projects/openslp/ - openslp-2.0.0

Note that when configuring open-isns with meson, it completes successfully, but does not create a Makefile, so use configure instead.

Offline qingquan

  • Newbie
  • *
  • Posts: 35
Re: meson,build:84:0: ERROR: Dependency "libkmod" not found
« Reply #21 on: January 05, 2023, 01:15:15 PM »
TinyCorePure64-12.0:
https://github.com/open-iscsi/open-isns/releases
https://github.com/open-iscsi/open-iscsi/releases

tce-load -iw compiletc.tcz
tce-load -iw tpm2-tss-dev.tcz
tce-load -iw curl-dev.tcz
tce-load -iw meson.tcz
tce-load -iw cmake.tcz
tce-load -iw kmod-dev.tcz
tce-load -iw util-linux-dev.tcz
tce-load -iw elogind-dev.tcz
tce-load -iw bash.tcz
tce-load -iw perl5.tcz

compile open-isns-0.102:
tar -xvf open-isns-0.102.tar.gz
cd open-isns-0.102
sudo meson  build
sudo ninja -C build
sudo ninja -C build install

compile open-iscsi-2.1.8:
tar -xvf open-iscsi-2.1.8.tar.gz
cd open-iscsi-2.1.8
sudo meson builddir
sudo ninja -C builddir
sudo ninja -C builddir install
-------------------pass--------------
Thank you very much Rich,Juanito

Hi Rich
ERROR:Library "slp" found:NO
need to install that tcz?


« Last Edit: January 05, 2023, 01:24:13 PM by qingquan »