WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Totem  (Read 2044 times)

Offline vinceASPECT

  • Hero Member
  • *****
  • Posts: 749
Totem
« on: October 16, 2022, 08:52:42 AM »
Hello forum,

Is Totem in the repo of this TCL build?

if so, can it play streaming media's of the type "https"?   (vids or internet radio)

thanks
C

http://tinycorelinux.net/4.x/x86/archive/4.3.1/

Online Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 14638
Re: Totem
« Reply #1 on: October 16, 2022, 09:30:59 AM »
All versions of tc-4 use the 4.x repo, so you can easily check.

Offline vinceASPECT

  • Hero Member
  • *****
  • Posts: 749
Re: Totem
« Reply #2 on: October 16, 2022, 04:21:44 PM »
Hello,

Totem is present in 4.3.1

so does it stream "https" movies and internet radio?.... i wonder?

i could try it , but i just wondered if you knew off the bat?


thx
C

Offline vinceASPECT

  • Hero Member
  • *****
  • Posts: 749
Re: Totem
« Reply #3 on: October 19, 2022, 08:39:57 AM »
it loaded TOTEM on 4.3.1 up to even a desktop icon

however clicking the icon did nothing

Online Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 14638
Re: Totem
« Reply #4 on: October 19, 2022, 10:04:49 AM »
What happens when you start totem from a terminal window?

Offline vinceASPECT

  • Hero Member
  • *****
  • Posts: 749
Re: Totem
« Reply #5 on: October 19, 2022, 10:54:09 AM »
Sir,

i tried starting it with "Totem" or "totem" or  "Movie Player" etc
at the terminal......... and even tried it with root  prefixes such as sudo


nothing happened......not known
« Last Edit: October 19, 2022, 10:58:00 AM by vinceASPECT »

Online Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 14638
Re: Totem
« Reply #6 on: October 19, 2022, 12:08:25 PM »
Is /usr/local/bin/totem present?

Offline vinceASPECT

  • Hero Member
  • *****
  • Posts: 749
Re: Totem
« Reply #7 on: October 19, 2022, 12:17:19 PM »
Hello Sir,

a qualified path

i can check it.

thx

........it could be i never loaded the extra tcz files listed alongside "totem.tcz" when listing the results of doing a 4.3.1 repo search on "totem"

Online Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 14638
Re: Totem
« Reply #8 on: October 20, 2022, 02:27:52 AM »
I downloaded and mounted the 4.x totem extension using 13.x - the extension looks OK, as long as you loaded totem and all of its dependencies it should work or, failing that, give you an error message when started from a terminal window.
« Last Edit: October 20, 2022, 03:35:49 AM by Juanito »

Offline vinceASPECT

  • Hero Member
  • *****
  • Posts: 749
Re: Totem
« Reply #9 on: October 20, 2022, 04:07:29 AM »
Sir,

i will try it again. on 4.3.1  repo.

it's for a very old PC and there isn't any drives on it just it's HDD which is a bit
dodgy. 

i could boot a new TCL from pendrive but i only own one PenD and
it already has stuff on it

thx
C


Offline vinceASPECT

  • Hero Member
  • *****
  • Posts: 749
Re: Totem
« Reply #10 on: October 20, 2022, 04:45:03 AM »
sir

does it perhaps require  SSE2   cpu?

Online Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 14638
Re: Totem
« Reply #11 on: October 20, 2022, 05:01:28 AM »
I don't know.

Boot tc-4.3.1 to a gui, open a terminal window and use tce-load to load the totem extension and then run it - if it doesn't run, you should get some kind of error message.

Note that you might need Xorg-7.6 instead of Xvesa.

Offline vinceASPECT

  • Hero Member
  • *****
  • Posts: 749
Re: Totem
« Reply #12 on: October 20, 2022, 02:49:49 PM »
Sir,

The 4.3.1 TCL i am booting to has framebuffer graphics.......so is that an issue?

thx

C

Online Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 14638
Re: Totem
« Reply #13 on: October 21, 2022, 12:58:33 AM »
I don’t know, but when you run totem you will almost certainly get an error message if there’s a problem.

Online Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 14638
Re: Totem
« Reply #14 on: October 21, 2022, 04:31:39 AM »
I booted tc-4.7.7 in qemu.

libiconv is missing from totem or one of its deps, but once libiconv is loaded totem starts without further errors.

This was using Xvesa.