WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: VLC3 does not run in TC13  (Read 1469 times)

Offline AlejandroPadrino

  • Full Member
  • ***
  • Posts: 143
VLC3 does not run in TC13
« on: September 23, 2022, 06:14:00 PM »
Hello, I tried to load VLC player and it does not start.  Errors are:

can not load libarchive_plugin.so (can not open shared object libarchive.so.13)

can not load liblua_plugin.so (can not open shared object liblua.so.5.3.5); it haves liblua.so.5.3.6 from TC13 repository.

can not load libnotify_plugin.so (can not open shared object libnotify.so.4)

can not load libsecret_plugin.so (can not open shared object libsecret-1.so.0)

failed to initialize xrandr.
xkeyboard extension not present on the x server.
failed to open swrast.

libarchive.so.13 does not exist.
liblua.so.5.3.5 does not exist.
libnotify.so.4 does not exist.
libsecret-1.so.0 does not exist.
swrast_dri.so does not exist.


anyone can help?

thank you.  :-)

Offline AlejandroPadrino

  • Full Member
  • ***
  • Posts: 143
Re: VLC3 does not run in TC13
« Reply #1 on: September 24, 2022, 05:19:34 AM »
Update:  Loading libarchive3.tcz, libnotify.tcz and libsecret.tcz files, new error is present requesting for libgtk-3.so.0 file.  Request for liblua.so.5.3.5 remains active.

Offline AlejandroPadrino

  • Full Member
  • ***
  • Posts: 143
Re: VLC3 does not run in TC13
« Reply #2 on: September 24, 2022, 08:02:38 AM »
Another update, not writed in first post:

Another error found was QT5 can not load extensions module.  Loading all QT5 packages, except for QT5-dev, does not solve this.  :-(

Online Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 14641
Re: VLC3 does not run in TC13
« Reply #3 on: September 24, 2022, 09:47:52 AM »
Using Xorg-3d and pulseaudio/pavucontrol, I downloaded and installed vlc3, which played a video without problems:
Code: [Select]
vlc
VLC media player 3.0.11.1 Vetinari (revision 3.0.11.1-0-g52483f3ca2)
[0981f270] main libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/runtime-tc'
[098942c0] qt interface error: Unable to load extensions module
[099517d0] main playlist: playlist is empty
libva info: VA-API version 1.13.0
libva info: Trying to open /usr/local/lib/dri/iHD_drv_video.so
libva info: va_openDriver() returns -1
libva info: Trying to open /usr/local/lib/dri/i965_drv_video.so
libva info: Found init function __vaDriverInit_1_12
libva info: va_openDriver() returns 0
[9c684250] avcodec decoder: Using Intel i965 driver for Intel(R) Haswell Mobile - 2.4.1 for hardware decoding

I did not load any other extensions

Online Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 14641
Re: VLC3 does not run in TC13
« Reply #4 on: September 24, 2022, 09:58:15 AM »
There is a problem with the desktop icon - I will fix it

The info file mentions that libsecret is optional.

I see the error "qt interface error: Unable to load extensions module", but a video still plays.

The optional lua plugin does indeed depend on an earlier version of lua-lib.

I didn't check all of the other plugins, but most (if not all) of them look to depend on current extensions.