WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: pppd or wvdial  (Read 3453 times)

Offline patrikg

  • Wiki Author
  • Hero Member
  • *****
  • Posts: 673
Re: pppd or wvdial
« Reply #15 on: May 11, 2022, 06:47:12 AM »
I think you need to use more advanced tools to find the Segmentation fault problem.
You can try to use strace command line utility to see if you see some more what's going wrong.

Offline andyb1973

  • Newbie
  • *
  • Posts: 16
Re: pppd or wvdial
« Reply #16 on: May 13, 2022, 08:13:57 AM »
about ppp i'm using:

rasp3 is ok (i used versione 6)
rap 0 if i run ppp (thesame sdcard): pppd: Please load the ppp_generic kernel module.

what am i missing?
i developed with rasp3 with core 6... is it correct?

thx


Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 14534
Re: pppd or wvdial
« Reply #17 on: May 13, 2022, 08:31:59 AM »
Do you mean that you are using armv6 extensions or that you are using piCore-6.0?

The current version is piCore-13.1

Did you try “sudo modprobe ppp_generic”

The RPi0 does not use the same ppp kernel modules extension as the RPi3.
« Last Edit: May 13, 2022, 08:36:24 AM by Juanito »

Offline andyb1973

  • Newbie
  • *
  • Posts: 16
Re: pppd or wvdial
« Reply #18 on: May 13, 2022, 09:58:37 AM »
ppp kernel correct yes, perfect

thx