dCore Import Debian Packages to Mountable SCE extensions > dCore x86_64

jack with realtime


User tc starts jack but Cannot lock down {number removed} byte memory area (Cannot allocate memory), Cannot use real-time scheduling and Operation not permitted

User root starts jack with realtime enabled

Tells me it's a permission issue. Then I read this https://jackaudio.org/faq/linux_rt_config.html where it mentions audio group and setting limits for it

I find this file on my system /etc/security/limits.d/audio.conf.disabled:

--- Code: ---# Provided by the jackd package.                                                                                                                                                                                     
# Changes to this file will be preserved.                                                                                                                                                                           
# If you want to enable/disable realtime permissions, run                                                                                                                                                           
#    dpkg-reconfigure -p high jackd                                                                                                                                                                                 
@audio   -  rtprio     95                                                                                                                                                                                           
@audio   -  memlock    unlimited                                                                                                                                                                                     
#@audio   -  nice      -19
--- End code ---

According to the link above I make a copy of it to /etc/security/limits.d/audio.conf but realtime still won't work for tc (is in the audio group). Do I have to make this file available at boot? Are dpkg* commands supposed to work on dcore?

I've set up a quick devuan vm to test this. In devuan jack did start with realtime under a non root but only with the audio.conf AND after a reboot.

I then tried to make the audio.conf available at boot in dcore, rebooted but no go.

I then tried including alsa-utils and jackd2 at boot, rebooted: no go.

What else can I be missing?


[0] Message Index

Go to full version