WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: tinkerCore-first attempts at porting piCore  (Read 4225 times)

Offline corezoo

  • Newbie
  • *
  • Posts: 33
tinkerCore-first attempts at porting piCore
« on: August 13, 2017, 06:22:52 PM »

Sorry for the long post
Does anyone have a Tinker Board?
Good specs and the ability to attach an external antenna which I think is a great feature

Following the forum post by Bmarcus
How to port piCore to other ARM boards
and the Into the Core book

With TinkerOS1.9 on an sdcard, ran it once to do it’s first run stuff.
Modified using piCore 9.0.3 as follows

as root on a x86_64 laptop, mount cards and a usb with wifi tcz’s
copied means using mc’s f5 copy defaults as set in slackware14.2

created a directory, /mnt/tmp/extract_piCore-9.0.3 and cd to it
zcat /mnt/sdd1/9.0.3v7.gz | cpio -i -H newc -d

copied /mnt/sde2/lib/modules/4.4.16-00010-g0fce7eb-dirty

copied /mnt/sde2/lib/firmware

cd /mnt/tmp/extract_picore-9.0.3/usr/local/lib/modules/
mv 4.9.22-piCore-v7 4.4.16-00010-g0fce7eb-dirty

cd /mnt/tmp/extract_piCore-9.0.3/lib/modules/4.4.16-00010-g0fce7eb-dirty
ln -s /usr/local/lib/modules/4.4.16-00010-g0fce7eb-dirty/kernel kernel.tclocal kernel.tclocal

Very confused as to what to edit this to yet it works, maybe
edit /mnt/tmp/extract_piCore-9.0.3/usr/sbin/startserial
after else change port=ttyAMA0 to port=ttyS1
ttyS1 is what Volumio for tinkerboad used in the kernel parameters of extlinux.conf. TinkerOS1.8
had “console=tty1” and TinkerOS1.9 has “plymouth.ignore-serial-consoles” and “console=tty1”
would like a less pi specific script, what sets the console? The kernel, the hardware, the OS????

did not know what to edit here left 9.0.3  ???

rm -r /mnt/tmp/extract_piCore-9.0.3/lib/modules/4.9.22-piCore-v7
cd /mnt/tmp/extract_piCore-9.0.3
find | cpio -o -H newc | gzip -2 > /mnt/sde1/9.0.3v7.gz

cd /mnt/sde2
delete all directories from tinkerOS root system, could have just reformatted to ext4
copied /mnt/sdd2/tce
copied /mnt/sdh1/<wifi stuff>
except for RPI3 specific and deleted the wireless<kernel ver> dependency in wireless_tools.tcz.dep
edited /mnt/sde2/tc/onboot.lst added wifi.tcz

could do more here but tried to keep it minimal
edited /mnt/sde1/extlinux/extlinux.conf
add line initrd /9.0.3v7.gz
on append line
quiet splash plymouth.ignore-serial-consoles console=tty1rw init=/sbin/init
root=/dev/mmcblk0p2 to root=/dev/ram0
nozswap console-tty1 console=ttyS1,115200n8
unmounted all removable media
opened sde in gparted, shrunk sde2 and added sde3 as swap

TinkerOS has very little in the boot partition
it uses uboot but where the uboot stuff hides I do not know

ported piCore 8.1.5 to volumio, ELAR-Systems distros for the tinker board and also tinkerOS 1.8
ported piCore 9.03 to tinkerOS 1.9

IT BOOTS (:-} The overscan and lack of f(n) keys is a PITA 5-6 charactors missing left and right and 1 line on top and half a line on the bottom, mc works with ALT+num, working blind in Vi
THANKS for putting ll and la in ash.rc saves many key strokes

To get the desktop
wifi.sh and connect to ap
It threw up a bunch of kernel complaints starting and ending with cut here but connected anyways

tce-ab to download TC.tcz ondemand, this is a big help having that meta package
tried to put this in onboot.lst this caused a kernel panic, should not have????

tce-load -i TC.tcz

can not figure out how to adjust the oversan it’s off the screen on all edges on all distros
Maybe some thing in hw_intf.conf but I could not find any documentation for that.

In the terminal the F(n) keys do not work, I thought it was the PFU happy hacker II and Filco minila
compact keyboards I was using not having drivers but the same problem occurred with the full sized generic 87 keyboard with separate f(n) keys

Tried to download dillo3 using the software tool but
failed at dependency check for ipv6<kernel ver>
it tried to auto insert the running kernel version and match it to the repo and failed to find it.

Downloaded dillo3.tcz, dillo3.tcz.dep, and dillo3.tcz.md5.txt manually from
and copied to /mmcblk0p1/tce/optional
edited the dillo3.tcz.dep file to remove ipv6-KERNEL.tcz most of these are built in to the kernel used
ondemand directory had the script for dillo3 and opened up from the desktop

Question: Is there a way of avoiding the requirement of downloading kernel specific tcz’s
if one is using a different kernel and already have the modules either built in or in /lib/modules?
For instance the wifi_tools and dillo3 and the kernel version modules not native to piCore can not be in the repo

More work to be done,