WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: boot option kmap=qwertz/de-latin1-nodeadkeys leads to font chache errors  (Read 3571 times)

Offline bernhard

  • Wiki Author
  • Jr. Member
  • *****
  • Posts: 81
when I add the following boot options

  kmap=qwertz/de-latin1-nodeadkeys pause

to CorePlus, I get a screen full of error Messages right after the (yellow) list of loaded extensions:

/usr/share/fonts: caching, new cache contents: 1 fonts, 8 dirs
/usr/lib/Xll/fonts: caching, new cache contents: 8 fonts, 2 dirs
/usr/lib/Xll/fonts/75dpi: caching, new cache contents: 48 fonts, 8 dirs
/usr/lib/Xll/fonts/misc: caching, new cache contents: 48 fonts, 8 dirs
/usr/local/share/fonts: caching, new cache contents: 8 fonts, 1 dirs
/usr/local/share/fonts/ttf-bitstream-vera: caching, new cache contents: 10 fonts, 0 dirs
/usr/local//lib/X11/fonts: skipping, no such directory
/.local/share/fonts: skipping, no such directory
/usr/share/fonts: caching, new cache contents: 1 fonts, 0 dirs
/usr/lib/X11/fonts: caching, new cache contents: 0 fonts, 2 dirs
/usr/local/share/fonts: caching, new cache contents: 0 fonts, 1 dirs
/usr/local/lib/X11/fonts: skipping, no such directory
/.local/share/fonts: skipping, no such directory
/var /cache/fontconfig: cleaning cache directory
/. cache/fontconfig: not cleaning non-existent cache directory


just before

fc-cache: succeeded
+ echo fluxbox
+ [ -d /tmp/tcloop/fluxbox ]
+ cp -a /tmp/tcloop/fluxbox/etc/skel/.fluxbox /etc/skel/
 Done.
Setting keymap to quertz/de-latinl-nodeadkeys Done.
Setting hostname to box Done.
Boot time configuration completed. Press <Enter> to continue.


can these messages be safely ignored or what should I do to avoid them?

These Messages occur with  version 6.3, but they were also present in previous editions, where I had added the kmap=qwertz/de-latin1-nodeadkeys to a remastered image (together with other boot options, iso= and multivt, see my small  contribution to the wiki). For version 6.3 I burned the original ISO image to CD and tested it by appending the Option manually to the ISO-Linux menu.

regards
--
  Bernhard

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 14640
You can ignore these messages (generated by fontconfig startup script)

Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 10992
@Juanito

Why not redirect them in the script? I don't think the output is needed.
The only barriers that can stop you are the ones you create yourself.

Offline gerald_clark

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 4254
Because if for some reason NO fonts are found, you would be clueless.

Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 10992
There's fc-list and friends for that, cache output on boot isn't the place IMHO. The cache doesn't prevent newer fonts being found, it merely speeds up accesses.
The only barriers that can stop you are the ones you create yourself.

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 14640
fontconfig startup script modified and extension reposted.

Offline bernhard

  • Wiki Author
  • Jr. Member
  • *****
  • Posts: 81
thanks a lot. Better than ignoring errors ...

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 14640
They were stdout rather than stderr but anyway...  :)