WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: xfe/xfw ignore LANG settings  (Read 2946 times)

Offline hjbtce

  • Newbie
  • *
  • Posts: 3
xfe/xfw ignore LANG settings
« on: April 26, 2014, 07:01:53 AM »
I've installed xfe and xfe-locale. LANG is set do "de". a grep on xfe.mo confirms that it contains german strings but xfe/xfw still start with english menus.

Any hints?

Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 10992
Re: xfe/xfw ignore LANG settings
« Reply #1 on: April 26, 2014, 10:48:09 AM »
Have you installed a german locale (with getlocale.tcz)?
The only barriers that can stop you are the ones you create yourself.

Offline Misalf

  • Hero Member
  • *****
  • Posts: 1702
Re: xfe/xfw ignore LANG settings
« Reply #2 on: April 26, 2014, 12:05:58 PM »
Exit out of X (CTRL+Alt+Backspace) then
Code: [Select]
$ export LANG=de_DE
$ startx

Lauch Xfe with german locale.
I just tryed it - works for me.
Download a copy and keep it handy: Core book ;)

Offline hjbtce

  • Newbie
  • *
  • Posts: 3
Re: xfe/xfw ignore LANG settings
« Reply #3 on: April 26, 2014, 12:26:43 PM »
Exit out of X (CTRL+Alt+Backspace) then
Code: [Select]
$ export LANG=de_DE
$ startx

Lauch Xfe with german locale.
I just tryed it - works for me.
Lucky guy ... It makes no difference for me. And it is not practicable. In the meantime I installed getlocale, run getlocale.sh and selected "de_DE.UTF-8". The bootcode is set and in a terminal I can see that $LANG contains it as well. Does it make a difference, that /tmp/tcloop/...xfe-locale/... only contains an "de" directory and not "de_DE". Renaming/linking is not possible as it is mounted readonly.

Offline Misalf

  • Hero Member
  • *****
  • Posts: 1702
Re: xfe/xfw ignore LANG settings
« Reply #4 on: April 27, 2014, 07:17:27 AM »
[...] And it is not practicable. [...]
Sure, I tryed if it works in general and it does for me.

Quote
In the meantime I installed getlocale, run getlocale.sh and selected "de_DE.UTF-8". The bootcode is set and in a terminal I can see that $LANG contains it as well.
I also tryed via boot code  lang=de_DE  and  lang=de_DE.UTF-8
Both does work.

Quote
Does it make a difference, that /tmp/tcloop/...xfe-locale/... only contains an "de" directory and not "de_DE". [...]
It's correct like that.

--

I don't think it's an Xfe related issue. Are you able to get any other program to use german locale?
Download a copy and keep it handy: Core book ;)

Offline hjbtce

  • Newbie
  • *
  • Posts: 3
Re: xfe/xfw ignore LANG settings [solved]
« Reply #5 on: April 28, 2014, 07:39:04 AM »

--

I don't think it's an Xfe related issue. Are you able to get any other program to use german locale?

Thanks for your tests and hints. I got it working. I made a new installation with 5.3; previous was 4.7.something. Before installing xfe/xfw I installed and run getlocale*. After that I installed all xfe/w related stuff and now I get the menus in german. So that problem is solved.

But now I have a new problem (I will open another thread, but perhaps you have an idea): I can input german umlauts in xfw, but in aterm I get strange symbols when entering umlauts. I have kmaps installed, set boot code kmap to qwertz/de-latin1 and put the corresponding loadkeys definition in /opt/bootlocal.sh. Seems a mismatch between latin1 and UTF-8 but I'm quite shure this problem didn't exist in my previous installation. I will try to load only qwertz/de.
« Last Edit: April 28, 2014, 08:07:25 AM by hjbtce »

Offline Misalf

  • Hero Member
  • *****
  • Posts: 1702
Re: xfe/xfw ignore LANG settings
« Reply #6 on: April 28, 2014, 09:25:08 AM »
Yes, open a new thread please. I wasn't able to get Aterm displaying Umlaute / using UTF-8 correctly, either.

Actually, there might already exist such a thread.
« Last Edit: April 28, 2014, 09:27:45 AM by Misalf »
Download a copy and keep it handy: Core book ;)