WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Is my repositories right?  (Read 3530 times)

Offline BrunoPT

  • Newbie
  • *
  • Posts: 6
Is my repositories right?
« on: January 04, 2014, 11:05:14 AM »
Hi, i am new in tinyCore and i have just instaled core plus in a usb stick.

The system is working fine but i have some problems with the repos. when i was trying to install a web browser i searched for Midori and i found that it is not in the repositories, so i have installed chromium.
Later i have tried to put my mobile broadband working, in a topic (http://forum.tinycorelinux.net/index.php?topic=12074.0) i saw this packages:
Quote
1.- In onboot:
mobile-broadband-provider-info.tcz
ModemManager.tcz
network-manager-gnome-locale.tcz
NetworkManager-locale.tcz
gnome-keyring-locale.tcz
notification-daemon-locale.tcz
usb-modeswitch-data.tcz
(the locale extensions is because my language)
This packages are not in the repository...

Can someone help me?

Offline gerald_clark

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 4254
Re: Is my repositories right?
« Reply #1 on: January 04, 2014, 11:15:14 AM »
He states he is running Version 3.8.4.
The currently maintained version is Version 5, and things are still being tested and moved from Version 4 or being compiled as needed.

Offline BrunoPT

  • Newbie
  • *
  • Posts: 6
Re: Is my repositories right?
« Reply #2 on: January 05, 2014, 10:45:20 AM »
Thanks... Is there any method to port the packages from previous versions?

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 14636
Re: Is my repositories right?
« Reply #3 on: January 05, 2014, 12:30:41 PM »
You can download the extensions from the archives and try them in tc-5.x.

The *locale and *info extensions might work as is, but the other two would need testing

Offline BrunoPT

  • Newbie
  • *
  • Posts: 6
Re: Is my repositories right?
« Reply #4 on: January 06, 2014, 12:00:39 AM »
You can download the extensions from the archives and try them in tc-5.x.

The *locale and *info extensions might work as is, but the other two would need testing

So i can get the tcz files from here (http://distro.ibiblio.org/tinycorelinux/4.x/x86/tcz/), load them and follow the tutorial?

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 14636
Re: Is my repositories right?
« Reply #5 on: January 06, 2014, 12:12:31 AM »
Yes - and once the extensions from the 4.x repo are confirmed working they can be copied to the 5.x repo.

Note:

* libpng was updated from tc-4.x to tc-5.x, most 4.x extensions that do not depend on libpng will work without problems in 5.x

* libpng, libjpeg and imlib2 were taken out of the base and several extensions (graphics-libs-1, Xprogs, Xlibs, Xorg) were refactored from tc-4.x to tc-5.x. This means the dep files of extensions from the 4.x repo might need adjusting to work in tc-5.x

Offline BrunoPT

  • Newbie
  • *
  • Posts: 6
Re: Is my repositories right?
« Reply #6 on: January 06, 2014, 05:32:28 AM »
I don't have my usb modem here right now, next weekend i will try and i will report the results here.