WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: [SOLVED] Absolute Minimum Netbooting problems  (Read 14057 times)

Offline genec

  • Full Member
  • ***
  • Posts: 240
Re: Absolute Minimum Netbooting problems
« Reply #15 on: September 07, 2013, 10:47:38 AM »
A plain tftp client helps diagnose files that can't be opened.

Also, with the client01.pxe, I'll bet that's the result of being on the NAT network and VirtualBox handing stuff out.

Put a default file at /tftpboot/pxelinux.conf/ with the menu described. Is it correct?

pxelinux.cfg/ should be your directory name.

Offline Zendrael

  • Sr. Member
  • ****
  • Posts: 362
    • Zendrael's home of projects
Re: Absolute Minimum Netbooting problems
« Reply #16 on: September 08, 2013, 05:13:03 AM »
Hi Genec!

Ooops, the pxelinux.conf was a typo... the directory is pxelinux.cfg already!

The issue with the first screenshot was solved, I had to use a internal network in virtualbox to get the clients booting.

When the client is booting, it says that the prefix of TFTP is "/"... maybe I can change this to pxelinux.cfg in some way?

The booting process is working, just the nsf is not...

Offline Akane

  • Jr. Member
  • **
  • Posts: 71
    • My home server by RaspberryPi
Re: Absolute Minimum Netbooting problems
« Reply #17 on: September 09, 2013, 03:23:54 AM »
Hi Zendrael.

What files is the PXELinux reading?
( maybe '01-...', 'C...', and 'default'.)
And what path is pointed?

Please list them.

Regards,
Akane.
Sorry for my terrible English.
Country: Japan
Interested in: HPC, low-level programming, embedded system and so on

Offline Zendrael

  • Sr. Member
  • ****
  • Posts: 362
    • Zendrael's home of projects
Re: Absolute Minimum Netbooting problems
« Reply #18 on: September 09, 2013, 04:54:13 AM »
Hey Akane!

I had in the pxelinux.cfg directory two files, one is 01-<mac_address> and the other is "default" - both have the same information as I'm testing with only a client at the moment.

But, which path is being pointed, I don't know, as I thought that the default path is /tftpboot/pxelinux.cfg... And, as you can see in one of the last screenshots, the tftp say that the prefix is "/" but can't find any files...

Maybe I have some problems with permissions? Can I use "chmod 777 -Rf" in the tftpboot directory without compromising other configs?

Offline Akane

  • Jr. Member
  • **
  • Posts: 71
    • My home server by RaspberryPi
Re: Absolute Minimum Netbooting problems
« Reply #19 on: September 09, 2013, 05:07:52 AM »
Hi Zendrael.

Oh sorry. I did not notice the picture.

So now, the PXE client can load the config file and can be booted, right?

Excuse me but I did not understand what is the problem now?

Regards,
Akane.
Sorry for my terrible English.
Country: Japan
Interested in: HPC, low-level programming, embedded system and so on

Offline Zendrael

  • Sr. Member
  • ****
  • Posts: 362
    • Zendrael's home of projects
Re: Absolute Minimum Netbooting problems
« Reply #20 on: September 09, 2013, 05:24:01 AM »
Hi Akane!

The PXE client is not loading the config.

I keep receiving the "tftpd: can't open file" in the Terminal Server app and the only thing that the client do is boot up the base (without any extensions) of the Core...

Offline Akane

  • Jr. Member
  • **
  • Posts: 71
    • My home server by RaspberryPi
Re: Absolute Minimum Netbooting problems
« Reply #21 on: September 09, 2013, 05:28:36 AM »
Hi Zendrael!

Now I understand. Thank you!

In the base of the core, could you run `cat /proc/cmdline` and upload the result please?

Regards,
Akane.
Sorry for my terrible English.
Country: Japan
Interested in: HPC, low-level programming, embedded system and so on

Offline Zendrael

  • Sr. Member
  • ****
  • Posts: 362
    • Zendrael's home of projects
Re: Absolute Minimum Netbooting problems
« Reply #22 on: September 09, 2013, 05:36:02 AM »
Hello Akane!

Attached is the result of the command in the server and in the client (as the filename suggests).

Hope it could be helpful!

Thanks for your help!

Offline Akane

  • Jr. Member
  • **
  • Posts: 71
    • My home server by RaspberryPi
Re: Absolute Minimum Netbooting problems
« Reply #23 on: September 09, 2013, 06:02:11 AM »
Hi Zendrael!

Thank you for the photos.

The command line lacks 'nfsmount=' option.
Where did you put 'tcz' directory for client?
Please add below to the PXELinux configuration file. (DIRECTORY is the place that you installed 'tcz' directory for client.)
Code: [Select]
nfsmount=servidor:DIRECTORY(If the 'tcz' directory is '/tftpboot/tcz', replace DIRECTORY /tftpboot)

Please try.

Regards,
Akane.
Sorry for my terrible English.
Country: Japan
Interested in: HPC, low-level programming, embedded system and so on

Offline Akane

  • Jr. Member
  • **
  • Posts: 71
    • My home server by RaspberryPi
Re: Absolute Minimum Netbooting problems
« Reply #24 on: September 09, 2013, 06:03:04 AM »
Note that :D is ':' and 'D'.
Sorry for my terrible English.
Country: Japan
Interested in: HPC, low-level programming, embedded system and so on

Offline Zendrael

  • Sr. Member
  • ****
  • Posts: 362
    • Zendrael's home of projects
Re: Absolute Minimum Netbooting problems
« Reply #25 on: September 09, 2013, 06:12:47 AM »
Hey Akane!

The option is in the "default" and "01-<mac_address>" inside pxeliunux.cfg, inside tftpboot like:

/tftpboot/pxelinux.cfg/default

The problem is that the clients are not reading the files inside pxelinux.cfg... They boot because of the TerminalServer app in the server, but they not read the files inside pxelinux.cfg

Offline Akane

  • Jr. Member
  • **
  • Posts: 71
    • My home server by RaspberryPi
Re: Absolute Minimum Netbooting problems
« Reply #26 on: September 09, 2013, 06:22:53 AM »
Hi Zendrael.

Maybe you are wrong.
Sans PXELinux configuration file, client cannot load any other file such as kernel.

So the client loads the configuration file normally.

I'm sorry to trouble you but please show me the pxelinux.cfg/default.

Regards,
Akane.
Sorry for my terrible English.
Country: Japan
Interested in: HPC, low-level programming, embedded system and so on

Offline Zendrael

  • Sr. Member
  • ****
  • Posts: 362
    • Zendrael's home of projects
Re: Absolute Minimum Netbooting problems
« Reply #27 on: September 09, 2013, 06:29:45 AM »
Hey Akane!

The pxelinux.cfg/default is:

Code: [Select]
label ws1
  MENU LABEL WS1
  kernel /nfs/ws1/vmlinuz
  append initrd=/nfs/ws1/core.gz nfsmount=servidor:/tftpboot/nfs/ws1 tftplist=servidor:/nfs/ws1/nfs.list tce=nfs/tce

And yes, the directories exist and the files vmlinuz and core.gz are there too.

I said that the clients are not reading the files because the server drops that "tftpd: can't open file" just when the clients are trying to read them...

So, by not reading them, they boot thru the vmlinuz and core of the server configured in the Terminal Server app.



Offline Akane

  • Jr. Member
  • **
  • Posts: 71
    • My home server by RaspberryPi
Re: Absolute Minimum Netbooting problems
« Reply #28 on: September 09, 2013, 07:30:44 AM »
Hi Zendrael!

Ummmm... I see.
That's really strange.
Thank you.

I think "tftpd: can't open file" is okay because there are no 'C', 'C0' and so on.

I am really sorry but please show me /etc/udhcpd.conf (on the server) and the outputs of 'ps | grep tftpd' (on the server).

Regards,
Akane.
Sorry for my terrible English.
Country: Japan
Interested in: HPC, low-level programming, embedded system and so on

Offline Zendrael

  • Sr. Member
  • ****
  • Posts: 362
    • Zendrael's home of projects
Re: Absolute Minimum Netbooting problems
« Reply #29 on: September 09, 2013, 07:45:55 AM »
Hi Akane!

The "ps | grep tftpd" returns the attached image01.

There is no /etc/udhcpd.conf... BUT as the ps shows a "/netboot" directory, I was looking at it and inside it, there is a udhcpd.conf! The image02 attached show its contents.

I'm really lost on it... maybe I should restart everything from the ground...