WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: [SOLVED] parole can't find libxfce4util.so.4  (Read 2982 times)

nomer

  • Guest
[SOLVED] parole can't find libxfce4util.so.4
« on: July 12, 2012, 02:32:44 PM »
Hi,

I have a problem. I've been using parole.tcz for a media player for a few months. A couple of weeks ago I tried running the latest xfce4-appfinder and xfce4-panel, neither of which I got working.
It has been awhile since I used Parole and when I tried running it today I got this error something like this on the command line:
Quote
parole: error while loading shared libraries: libxfce4util.so.4: cannot open shared object file: No such file or directory

After doing some looking around I ran this command:
Quote
sudo ln -s /tmp/tcloop/libxfce4util/usr/local/lib/libxfce4util.so.6.0.0 /usr/local/lib/libxfce4util.so.4
After I logging off and on, when I try to run this command I get:
Quote
parole: symbol lookup error: /usr/local/lib/libxfce4util.so.4: undefined symbol: g_mutex_lock

Both parole.tcz and libxfce4util.tcz are up to date with the repo.
I fixed any missing deps (using Apps) and checked for updates.
EDIT: I'm running TinyCore version 4.5.6

My guess is that Parole must be recompiled with the latest xfce4 libraries, but that is only a guess.
If anyone could offer advice that would be nice.

Cheers,
Nomer
« Last Edit: July 23, 2012, 02:55:16 PM by nomer »

Offline Arslan S.

  • Hero Member
  • *****
  • Posts: 825
Re: parole can't find libxfce4util.so.4
« Reply #1 on: July 13, 2012, 06:09:36 AM »
rebuilding completed

nomer

  • Guest
Re: parole can't find libxfce4util.so.4
« Reply #2 on: July 17, 2012, 08:41:50 PM »
Hi,

I just installed the update today and rebooted. Now when I run parole, I get this output:
Quote
parole: symbol lookup error: /usr/local/lib/libxfce4util.so.6: undefined symbol: g_mutex_lock

This is rather disappointing, although I don't fault you (Arslan).

It looks like it has been a while since the upstream version of Parole was updated. It could be that it would need to be modified if one wanted to use it with the Xfce 4.10 libraries.

I think I'll use VLC Player while I do some more looking into these issues.

Offline Arslan S.

  • Hero Member
  • *****
  • Posts: 825
Re: parole can't find libxfce4util.so.4
« Reply #3 on: July 18, 2012, 02:29:19 AM »
parole works here i can't reproduce your error

g_mutex_lock is defined in libgthreads-2.0 and it is linked to parole

nomer

  • Guest
Re: parole can't find libxfce4util.so.4
« Reply #4 on: July 18, 2012, 09:21:57 AM »
Oh, you are right. I just installed parole in a brand new virtual machine and it worked fine.
Must be something on my system.

nomer

  • Guest
Re: parole can't find libxfce4util.so.4
« Reply #5 on: July 18, 2012, 12:24:25 PM »
Okay, Parole seems to be working now.
I finally had to drop to the command line and force an update of all packages.
Thanks for the upgraded package.

Cheers,
Nomer