WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: NETGEAR WG511 v2  (Read 2367 times)

Offline gtsigaridis

  • Newbie
  • *
  • Posts: 2
NETGEAR WG511 v2
« on: January 08, 2012, 08:19:22 AM »
I have an old laptop with pcmcia and have a netgear WG511 v2 card for wireless and can't get the drivers to work on tinycore but it works on my usb wireless how can I get tinycore to see netgear card
Great job everyone on tinycore, super nice linux OS

Offline Rich

  • Administrator
  • Hero Member
  • *****
  • Posts: 11138
Re: NETGEAR WG511 v2
« Reply #1 on: January 08, 2012, 08:34:55 AM »
Hi gtsigaridis
Near the top left of the page, between  Help  and  Moderate, click on the  Help  button and search
for  wg511. You'll get seven hit's, see if one of those answers your question.


Offline gtsigaridis

  • Newbie
  • *
  • Posts: 2
Re: NETGEAR WG511 v2
« Reply #2 on: January 08, 2012, 09:19:57 AM »
I have already searched and didn't find anything helpful or maybe I am looking at something wrong

Offline Rich

  • Administrator
  • Hero Member
  • *****
  • Posts: 11138
Re: NETGEAR WG511 v2
« Reply #3 on: January 08, 2012, 11:45:49 AM »
Hi gtsigaridis
A little Googling seems to indicate you may need to use  ndiswrapper  for your adapter. I'm going
to defer to someone else who knows how to do this to help you.

Offline gwalther

  • Full Member
  • ***
  • Posts: 139
Re: NETGEAR WG511 v2
« Reply #4 on: January 08, 2012, 08:49:56 PM »
I have successfully used a Netgear WG511 v2 pcmcia card in an earlier version of TC2.x using ndiswrapper and the drivers from windows2000.....WG511v2.inf...WG511v2.cat and WG511v2.sys .

I found to connect to my home network using WEP, that I had to issue key [1] open command like this:

     sudo ndiswrapper -i /mnt/hda3/Windows2000/WG511v2.inf
     sleep 5
     sudo modprobe ndiswrapper
     sleep 5
     sudo iwconfig wlan0 essid xxxxxxxxxxxx key xxxxxxxxxx key [1] open
     sleep 5
     sudo udhcpc -n -i wlan0

Of course put your network essid and key in for the x's
I can not remember for sure if I tried winxp drivers for WG511v2,,,but I think I did and had problems.
« Last Edit: January 08, 2012, 08:57:06 PM by gwalther »