WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: VideoLan 1.1.12: can't load module  (Read 2789 times)

Offline AmatCoder

  • Full Member
  • ***
  • Posts: 179
    • AmatCoder Projects
VideoLan 1.1.12: can't load module
« on: December 16, 2011, 02:12:53 PM »
With Videolan newer version (1.1.12), I can't get Dvb (TV) working.
vlc -vv shows:
Quote
cannot load module '/tmp/tcloop/vlc/usr/local/lib/vlc/plugins/access/libv412_plugin.so No such file or directory

This library exists into /usr/local/lib/vlc/plugins/access/  so likely it's a configuration mistake when compiled.

Regards.
« Last Edit: December 16, 2011, 08:30:57 PM by AmatCoder »

Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 10939
Re: VideoLan 1.1.12: can't load module
« Reply #1 on: December 18, 2011, 01:59:47 AM »
Sounds like VLC needs to be copied always. Please test if putting it to copy2fs fixes this bug ("tce-load -ic vlc" when not loaded for a temporary try).
The only barriers that can stop you are the ones you create yourself.

Offline AmatCoder

  • Full Member
  • ***
  • Posts: 179
    • AmatCoder Projects
Re: VideoLan 1.1.12: can't load module
« Reply #2 on: December 18, 2011, 03:59:51 AM »
I found the problem. Vlc was compiled against an old libdvdpsi library, so it seeks for libdvdpsi.so.6 but it finds libdvbpsi.so.7.

I test with old libdvbpsi.tcz from 3.x repository and now DVB is working fine.
« Last Edit: December 18, 2011, 04:01:38 AM by AmatCoder »

Offline killerhippy

  • Newbie
  • *
  • Posts: 18
Re: VideoLan 1.1.12: can't load module
« Reply #3 on: December 26, 2011, 03:13:43 PM »
I have tc v4.1 running Xorg, supporting my dvb-t usbstick, mplayer can be used to play tv
Code: [Select]
mplayer dvb://at my Asus eepc.

Is the issue with vlc already fixed at tc v4.2?
If not, how do I install old packages?

Offline AmatCoder

  • Full Member
  • ***
  • Posts: 179
    • AmatCoder Projects
Re: VideoLan 1.1.12: can't load module
« Reply #4 on: December 27, 2011, 06:56:29 AM »
Is the issue with vlc already fixed at tc v4.2?
No, 4.2 is just an update of base tools. Extensions are the same.
Vlc would need recompilation to fix that.
If not, how do I install old packages?
You can get libdvbpsi.tcz from 3.x and to replace it in your /tce/optional folder.
I would put a link here, but I'm not sure this is allowed...

Offline Rich

  • Administrator
  • Hero Member
  • *****
  • Posts: 11131
Re: VideoLan 1.1.12: can't load module
« Reply #5 on: December 27, 2011, 11:52:40 AM »
Quote
You can get libdvbpsi.tcz from 3.x and to replace it in your /tce/optional folder.
You could, but you might break something else that relied on the newer version.

Offline AmatCoder

  • Full Member
  • ***
  • Posts: 179
    • AmatCoder Projects
Re: VideoLan 1.1.12: can't load module
« Reply #6 on: December 27, 2011, 01:16:48 PM »
Quote
You could, but you might break something else that relied on the newer version.
I don't think so because libdvbpsi library is only used by vlc...