WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: rrdtool - Fontconfig error  (Read 3535 times)

Offline ccaaee

  • Newbie
  • *
  • Posts: 2
rrdtool - Fontconfig error
« on: December 15, 2011, 01:06:45 PM »
Hi

I'm trying to get rrdtool going and am running into problems:

I keep getting "Fontconfig error: Cannot load default config file"

Normally I've got all the correct dependencies ...

Thanks in advance
ccaaee

Offline Rich

  • Administrator
  • Hero Member
  • *****
  • Posts: 11315
Re: rrdtool - Fontconfig error
« Reply #1 on: December 15, 2011, 04:36:07 PM »
Hi ccaaee
Check  /etc/fonts/  and see it the file  fonts.conf  exists. If it doesn't, make sure  fontconfig.tcz
is installed. I also read somewhere that running  fc-cache  from the command line might help.
If that doesn't solve your problem, install  strace.tcz  and use that to trace what's happening.
Code: [Select]
strace rrdtool parameterswhere  parameters  is what you might normally enter after  rrdtool. Then check the output for
a line containing  fonts.conf, that should provide a hint of what is wrong.

Offline ccaaee

  • Newbie
  • *
  • Posts: 2
Re: rrdtool - Fontconfig error
« Reply #2 on: December 16, 2011, 11:41:32 AM »

Sorry,I should have added that this is microcore
I tried it with tinycore and it worked !
There must be some X related libraries ...

Thanks