WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: pcmcia-socket-startup  (Read 2758 times)

Offline zzzed

  • Newbie
  • *
  • Posts: 2
« on: November 25, 2011, 03:15:09 PM »
I have an old Compaq Presario 1220 that won't boot from the cdrom (don't tell me to edit the BIOS), so I looked for a somewhat current distro that would boot from floppy. All I could find were older versions of distros. So I tried DSL 4.4.10 (I know it's inactive), and it worked. Then I did some research on Tinycore, in the current release no floppy boot, but in release 1.4 (if I remember correctly) there was a boot floppy. I booted up the Tinycore boot floppy and it was a Grub floppy. So  I came up with a way to install the current version of Tinycore. I booted up DSL, copied vmlinuz and tinycore.gz to the harddrive, booted the Tinycore floppy and edited the Grub menu to boot Tinycore from the harddisk. I installed Tinycore to the harddisk (frugal) and it works fine except that it will not recognize my pcmcia Linksys pcmcp100 wired ethernet card. The reason I gave this background info is because the card is recognized by DSL 4.4.10. In Tinycore 4.0.2, in /etc/udev/drules.d/60-pcmcia.rules it runs 'pcmcia-socket-startup' which gives messages:
pcmcia_socket pcmcia_socket0: pccard: PCMCIA card inserted into  slot 0
pcmcia_socket pcmcia_socket0: cs:: IO port probe ....
pcmcia_socket pcmcia_socket0: cs: memory probe ...
'pcmcia_socket pcmcia_socket0: cs: unable to map card memory'

and if I do ifconfig -a, it gives 2 devices: dummy0 and lo.

Any ideas/help would be greatly appreciated.

Offline gerald_clark

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 4254
Re: pcmcia-socket-startup
« Reply #1 on: November 25, 2011, 05:43:51 PM »
Do not double post.
This thread is now locked.