WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Xorg-7.4-dev: some libs are misconfigured  (Read 3482 times)

Offline Roberto A. Foglietta

  • Full Member
  • ***
  • Posts: 212
    • personal home page
Xorg-7.4-dev: some libs are misconfigured
« on: April 07, 2009, 12:53:54 PM »
All these libraries do not use ${exec_prefix} in libdir and result broken in compilation:

Code: [Select]
root@box:/usr/local/lib/pkgconfig# grep =/usr/lib *     
sm-pc:libdir=/usr/lib
ice.pc:libdir=/usr/lib
xau.pc:libdir=/usr/lib
x11.pc:libdir=/usr/lib
xaw6.pc:libdir=/usr/lib
xaw7.pc:libdir=/usr/lib
xcursor.pc:libdir=/usr/lib
xdmcp.pc:libdir=/usr/lib
xext.pc:libdir=/usr/lib
xfont.pc:libdir=/usr/lib
xft.pc:libdir=/usr/lib
xi.pc:libdir=/usr/lib
xmu.pc:libdir=/usr/lib
xmuu.pc:libdir=/usr/lib
xpm.pc:libdir=/usr/lib
xrandr.pc:libdir=/usr/lib
xrender.pc:libdir=/usr/lib
xt.pc:libdir=/usr/lib

to test the package try to compile gtk2_prefs-0.4.1:

Code: [Select]
root@box:/home/tc/downloads/gtk2_prefs-0.4.1# make
...
mkdir .libs
libtool: link: cannot find the library `/usr/lib/libXrender.la'
make[2]: *** [gtk2_prefs] Error 1
make[2]: Leaving directory `/home/tc/downloads/gtk2_prefs-0.4.1/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/tc/downloads/gtk2_prefs-0.4.1'
make: *** [all] Error 2


Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 10992
Re: Xorg-7.4-dev: some libs are misconfigured
« Reply #1 on: April 07, 2009, 01:28:24 PM »
Could you clarify? All those libs are in /usr/lib?
The only barriers that can stop you are the ones you create yourself.

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 14641
Re: Xorg-7.4-dev: some libs are misconfigured
« Reply #2 on: April 07, 2009, 11:33:51 PM »
I've seen the same errors from time to time - adding a symlink for the purposes of being able to compile seems to fix the problem, ie:

/usr/lib/libXrender.la -> /usr/local/lib/libXrender.la

Offline Roberto A. Foglietta

  • Full Member
  • ***
  • Posts: 212
    • personal home page
Re: Xorg-7.4-dev: some libs are misconfigured
« Reply #3 on: April 08, 2009, 07:11:53 AM »
I've seen the same errors from time to time - adding a symlink for the purposes of being able to compile seems to fix the problem, ie:

/usr/lib/libXrender.la -> /usr/local/lib/libXrender.la

yes this trick solve the problem. However I think the package itself should be fixed.

Offline danielibarnes

  • Hero Member
  • *****
  • Posts: 548
Re: Xorg-7.4-dev: some libs are misconfigured
« Reply #4 on: April 10, 2009, 12:12:00 PM »
I had the same errors, but I didn't know what was causing the problem. Here is what I have to do when compiling open-vm-tools:
Code: [Select]
ln -f /usr/lib/libpng12.la /usr/local/lib/
ln -f /usr/local/lib/libXrender.la /usr/lib/
ln -f /usr/local/lib/libX11.la /usr/lib/   
ln -f /usr/local/lib/libXau.la /usr/lib/
ln -f /usr/local/lib/libXdmcp.la /usr/lib/
and then I remove the links after the build. I really wanted to get to the bottom of this, but I haven't had the time. The libpng12.la is part of the old compiletc; I've not checked the new one.