WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: mc slow extension loading at boot  (Read 18468 times)

Offline uggla

  • Sr. Member
  • ****
  • Posts: 438
mc slow extension loading at boot
« on: June 16, 2011, 11:05:52 AM »
Hi!

With the latest microcore (3.7) the loading of extensions during boot takes significantly longer time and the hd led is lit steadily during the whole process (with earlier versions it was blinking). Any idea why?

Regards
Uggla
« Last Edit: June 21, 2011, 11:46:57 PM by uggla »

Offline uggla

  • Sr. Member
  • ****
  • Posts: 438
Re: mc 3.7 slow extension loading at boot
« Reply #1 on: June 16, 2011, 01:42:38 PM »
I've now upgraded my second computer and that one is even slower (much slower than before).

Here's my onboot.lst:

wbar.tcz
flwm_topside.tcz
laptop-mode-tools.tcz
cpufreq-2.6.33.3-tinycore.tcz
alsa.tcz
flit.tcz
Xorg-7.5-3d.tcz
Xlibs.tcz
Xprogs.tcz
fluff.tcz

/Uggla

Offline uggla

  • Sr. Member
  • ****
  • Posts: 438
Re: mc 3.7 slow extension loading at boot
« Reply #2 on: June 16, 2011, 01:55:06 PM »
Note! During the update I updated wbar, Xlibs, Xprogs and fluff as well (the problem could lie there).

/Uggla

Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 10969
Re: mc 3.7 slow extension loading at boot
« Reply #3 on: June 16, 2011, 02:08:47 PM »
Possibly caused by the chown, used to detect a read-only fs (but fails on fat32, there's a thread open).
The only barriers that can stop you are the ones you create yourself.

Offline uggla

  • Sr. Member
  • ****
  • Posts: 438
Re: mc 3.7 slow extension loading at boot
« Reply #4 on: June 16, 2011, 02:29:01 PM »
I have no fat32 partitions.

Offline roberts

  • Administrator
  • Hero Member
  • *****
  • Posts: 7361
  • Founder Emeritus
Re: mc 3.7 slow extension loading at boot
« Reply #5 on: June 16, 2011, 02:40:50 PM »
I really doubt it. As everyone would have noticed a much slower boot and not as claimed only microcore.
That test occurs only once and not upon each extension load. I am however in the process of narrowing the test.
10+ Years Contributing to Linux Open Source Projects.

Offline Rich

  • Administrator
  • Hero Member
  • *****
  • Posts: 11256
Re: mc 3.7 slow extension loading at boot
« Reply #6 on: June 16, 2011, 03:00:24 PM »
Hi uggla

You could take a look at the output of  dmesg  and see if maybe your hard drive is being put
into PIO instead of DMA mode.

Offline Guy

  • Hero Member
  • *****
  • Posts: 1089
Re: mc 3.7 slow extension loading at boot
« Reply #7 on: June 16, 2011, 10:58:48 PM »
To test this properly, set up your computer to boot more than one version.

http://wiki.tinycorelinux.net/wiki:update

Boot it using different versions, with the same apps.

Time the boot with a clock, to see how long it really takes.


I have noticed that loading apps on my computer takes longer than it did before.

This may have started around the time I started using version 3.7.

Around the same time, I also installed additional apps, and I had been thinking those apps were taking longer than the others.

You can test to find out.
Many people see what is. Some people see what can be, and make a difference.

Offline uggla

  • Sr. Member
  • ****
  • Posts: 438
Re: mc 3.7 slow extension loading at boot
« Reply #8 on: June 17, 2011, 02:13:13 AM »
Hi uggla

You could take a look at the output of  dmesg  and see if maybe your hard drive is being put
into PIO instead of DMA mode.


I doubt it has anything to do with that since one of my computers has no hard drive at all, it runs from an usb stick.

/Uggla

Offline Rich

  • Administrator
  • Hero Member
  • *****
  • Posts: 11256
Re: mc 3.7 slow extension loading at boot
« Reply #9 on: June 17, 2011, 11:06:18 AM »
Hi uggla

My answer was based on the information you originally supplied.

Offline uggla

  • Sr. Member
  • ****
  • Posts: 438
Re: mc 3.7 slow extension loading at boot
« Reply #10 on: June 17, 2011, 11:44:10 AM »
Hi uggla

My answer was based on the information you originally supplied.


Yes, that was my first computer (with hard drive)  ;)

Offline uggla

  • Sr. Member
  • ****
  • Posts: 438
Re: mc 3.7 slow extension loading at boot
« Reply #11 on: June 18, 2011, 01:57:27 PM »
This issue remains with 3.7.1  :(

Offline jur

  • Hero Member
  • *****
  • Posts: 863
    • cycling photo essays
Re: mc 3.7 slow extension loading at boot
« Reply #12 on: June 18, 2011, 08:02:39 PM »
What are your comparative test results with 3.6 and 3.7?

Offline uggla

  • Sr. Member
  • ****
  • Posts: 438
Re: mc 3.7 slow extension loading at boot
« Reply #13 on: June 19, 2011, 05:30:20 AM »
Where can I get the previous version of wbar, Xlibs and Xprogs?

Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 10969
Re: mc 3.7 slow extension loading at boot
« Reply #14 on: June 19, 2011, 08:01:39 AM »
Under 3.x/archive/version/distribution_files.

Any change wrt copy2fs? Enabling it would have this effect.
« Last Edit: June 19, 2011, 08:03:46 AM by curaga »
The only barriers that can stop you are the ones you create yourself.