WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Configuring acpid: /usr/local/etc/acpi/events/all won't stay persistent.  (Read 5051 times)

Offline Jorh

  • WikiUser
  • *
  • Posts: 1
Hi. So far Tiny Core Linux has been only slightly harder for me than Arch Linux. I'm glad I fiddled with Arch first, I learned alot that way.

Anyways, I've been setting up my aunt's old computer (256MB RAM). They'll use it to browse around the net. I've installed TCL next to Windows XP with extlinux. I've got a persistent home, opt, sound, and apps. I've set up the acpid according to the wiki. There were a couple of bugs in it, like switching gen.sh from opt to home, but I got it figured out.

newbielink:http://wiki.tinycorelinux.net/wiki:using_acpid_to_control_your_pc_buttons [nonactive]

Anyways, I got it to the point where I got it working. I put "usr/local/etc/acpi/events/all" into "/opt/.filetool.lst" . I restarted acpid, pressed the power button, and it turned off. I booted it back into Tiny Core, and pressed the power button again. I waited and nothing happened. I went into the filesystem to investigate. I found that everything was in order, except "/usr/local/etc/acpi/events/all" has disappeared. It even appears in filetool. I tried this several times. Made sure there was no possibility of it being misspelled.

Offline tinypoodle

  • Hero Member
  • *****
  • Posts: 3857
Did you run a backup?
"Software gets slower faster than hardware gets faster." Niklaus Wirth - A Plea for Lean Software (1995)

Offline jur

  • Hero Member
  • *****
  • Posts: 863
    • cycling photo essays
It's possible that on using the power button routine, backup is skipped. Do a backup once and try again.

Offline maro

  • Hero Member
  • *****
  • Posts: 1228
.... and in case you did not know: a backup can be done via filetool.sh -b