WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: ata drivers missing  (Read 4940 times)

Offline sschoen

  • WikiUser
  • *
  • Posts: 6
ata drivers missing
« on: March 29, 2009, 08:50:33 AM »
Hi,
I started some weeks ago to use a TC 1.1 based hardisk installation on some PCs of my school as a sort of kiosk for nx clients connecting to a freenx terminal server. Harddisk install works quite well for Dell Optiplex 755 with scsi.tce.  But on a not brandnew Maxdata sata drive system the harddisk is not recognized by TC, so no installation is posssible. If one starts the GParted-CD (also with the 2.6.26 kernel) the drive is seen and it can be repartitioned etc.. Dmesg tells that the following drivers are used by the CD distro: libata.ko, ata-generic.ko and sata_sil.ko - all tree being on the GParted-CD in  /lib/modules/2.6.26-1-486/kernel/drivers/ata . An ata-directory ist missing in TC, so this means that my projekt ist stopped quite abruptly.

Did I overlook something, maybe in more actual TC versions? Is there a workaround for my problem? Are there plans to close the gap? Is there a HowTo for inserting drivers from the another distro of the same kernel version into TC?

Yours,
Stephan

Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 10667
Re: ata drivers missing
« Reply #1 on: March 29, 2009, 08:57:18 AM »
There are indeed plans to add that driver in the next kernel update.

Copying modules from another distro will not work, if you are in a hurry you'd need to recompile the kernel. If not, wait a couple of weeks and see :)
The only barriers that can stop you are the ones you create yourself.

Offline sschoen

  • WikiUser
  • *
  • Posts: 6
Re: ata drivers missing
« Reply #2 on: March 29, 2009, 09:36:02 AM »
Hi curaga,

Thank you.

I *am* in a hurry , but I prefer waiting, since compiling a kernel would the first time for me.

I offer my help for testing the new feature on one of our Maxdata boxes.

Yours,
Stephan

Offline ^thehatsrule^

  • Administrator
  • Hero Member
  • *****
  • Posts: 1726
Re: ata drivers missing
« Reply #3 on: March 29, 2009, 01:51:34 PM »
I still had my build tree up, so I decided to create an extension: http://forum.tinycorelinux.net/index.php?topic=954.0
Hopefully that'll work for you (for now).

Offline sschoen

  • WikiUser
  • *
  • Posts: 6
Re: ata drivers missing
« Reply #4 on: March 29, 2009, 03:38:05 PM »
Thank you, I'll test this in some hours.

Yours,
Stephan

Offline sschoen

  • WikiUser
  • *
  • Posts: 6
Re: ata drivers missing
« Reply #5 on: March 30, 2009, 08:27:40 AM »
Thank you, it worked at once! Great job!

Yours,
Stephan

Offline ^thehatsrule^

  • Administrator
  • Hero Member
  • *****
  • Posts: 1726
Re: ata drivers missing
« Reply #6 on: March 30, 2009, 07:32:25 PM »
Glad it works!

Note: I've made some changes since the first revision