WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Page down key not working?  (Read 4647 times)

Offline tayloratosu

  • WikiUser
  • *
  • Posts: 20
Page down key not working?
« on: February 18, 2011, 10:00:51 AM »
I'm running TC 3.4 using openbox with Xorg, and I've run into weird problem -- the page-down key doesn't seem to work.  I can scroll down in, say, firefox or mousepad, and then use page-up to scroll up again, but if I hit the page-down key, nothing happens.  I've noticed this on two different computers -- one using config-less Xorg and the other using an xorg.conf with the openchrome video driver, both of them using openbox and TC 3.4.

Has anybody seen this behavior before?

Offline tinypoodle

  • Hero Member
  • *****
  • Posts: 3857
Re: Page down key not working?
« Reply #1 on: February 18, 2011, 03:15:09 PM »
You could exclude (or not) a system wide issue, by trying shift-up and then shift-down on tty1, e.g after running 'dmesg'.
"Software gets slower faster than hardware gets faster." Niklaus Wirth - A Plea for Lean Software (1995)

Offline tayloratosu

  • WikiUser
  • *
  • Posts: 20
Re: Page down key not working?
« Reply #2 on: February 19, 2011, 06:08:18 AM »
In a terminal, I ran dmesg.  I then was able to successfully scroll up and down in the terminal window using shift-up and shift-down.

Offline tinypoodle

  • Hero Member
  • *****
  • Posts: 3857
Re: Page down key not working?
« Reply #3 on: February 19, 2011, 07:39:28 AM »
Here is a test you can do under X:
Code: [Select]
xev |grep -B 2 -A 3 Next--> move pointer into white rectangle, then press PgDn for a few secs and check for output.
"Software gets slower faster than hardware gets faster." Niklaus Wirth - A Plea for Lean Software (1995)

Offline tinypoodle

  • Hero Member
  • *****
  • Posts: 3857
Re: Page down key not working?
« Reply #4 on: February 19, 2011, 07:55:47 AM »
In a terminal, I ran dmesg.  I then was able to successfully scroll up and down in the terminal window using shift-up and shift-down.

Oops, I just realized I was phrasing that imprecisely...
What I meant was "Shift-PgUp"/"Shift-PgDn"
(the way it was phrased it could be taken for Arrow* instead of Pg*).
"Software gets slower faster than hardware gets faster." Niklaus Wirth - A Plea for Lean Software (1995)

Offline tayloratosu

  • WikiUser
  • *
  • Posts: 20
Re: Page down key not working?
« Reply #5 on: February 19, 2011, 10:14:23 AM »
Heh.  I actually did misunderstand. :-)

In the terminal window, shift-arrow-up and shift-arrow-down work.  Shift-page-up works.  Shift-page-down does not.

I ran the "xev |grep -B 2 -A 3 Next" test.  Put the arrow in the white rectangle and pressed any number of keys, including page-down and got no output.  Ran xev without the grep, and pressing page-down gave the following response (I think this is the right one):

KeyPress event, serial 39, synthetic NO, window 0x1200001,
    root 0x101, subw 0x0, time 52412923, (1,20), root:(805,311),
    state 0x0, keycode 105 (keysym 0xffe4, Control_R), same_screen YES,
    XLookupString gives 0 bytes:
    XmbLookupString gives 0 bytes:
    XFilterEvent returns: False

Does that help?

Offline tinypoodle

  • Hero Member
  • *****
  • Posts: 3857
Re: Page down key not working?
« Reply #6 on: February 19, 2011, 11:21:58 AM »
You actually misunderstood in a way in which my inaccuracy wouldn't have mattered...   :P

When I said on tty1, I meant not in a window and not under X.

Hit Ctrl+Alt+F1 to get to tty1 and then try the same again.
(Ctrl+Alt+F2 to switch back to X).


The lack of output of xev is an indication that the PgDn key is not recognized under your X server.
I would try with the default Xvesa as shipped in base.

For your convenience, you may save just the xev binary while running Xorg, as it is not in base.
"Software gets slower faster than hardware gets faster." Niklaus Wirth - A Plea for Lean Software (1995)

Offline tayloratosu

  • WikiUser
  • *
  • Posts: 20
Re: Page down key not working?
« Reply #7 on: February 19, 2011, 01:13:59 PM »
Ah, I see!  Yes, I did misunderstand.  (And I kinda wondered why you were saying "tty" rather than "xterm window".  :-)

Okay, I switched to tty1, and there, the shift-page-down combination works just fine.  And when I run under Xvesa, page-down works as expected.  It just doesn't work when using Xorg, either on the computer using it config-less or on the computer using openchrome. 

When I run the xev test using Xvesa, I do get output when I press page-down.  Do you need to know what it is, or just that I got something?

I guess Xvesa would be fine with the config-less computer; I don't really know why it got set up with Xorg in the first place.  The computer using the openchrome setup is slow, though, and it really needs the video acceleration in order for me to watch movies on it.

Thanks for all your help so far.  So, anything else I can tell you that can help sort this out?

Offline tinypoodle

  • Hero Member
  • *****
  • Posts: 3857
Re: Page down key not working?
« Reply #8 on: February 19, 2011, 02:29:20 PM »
Could not harm if you would post the xev output...
But the fact per se that you do get output in Xvesa as opposed to Xorg also is of relevance of course.

Have you verified by testing that playing movies under Xvesa is slower than under Xorg, or is that just your estimation?
"Software gets slower faster than hardware gets faster." Niklaus Wirth - A Plea for Lean Software (1995)

Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 10037
Re: Page down key not working?
« Reply #9 on: February 19, 2011, 10:19:11 PM »
If your pagedown key is really recognized as the right control, try specifying a keymap in xorg.conf. (XkbLayout "us", perhaps?)
The only barriers that can stop you are the ones you create yourself.

Offline tayloratosu

  • WikiUser
  • *
  • Posts: 20
Re: Page down key not working?
« Reply #10 on: February 21, 2011, 07:24:49 AM »
Okay, I think I've fixed this.  The secret appears to be to run the setxkbmap command after X has started up.

(I tried specifying the keymap in xorg.conf, but it didn't help.  Googled "XkbLayout" and ran across the above tip.  Worked on the config-less machine, even without an xorg.conf file.  I'll try it on the openchrome machine when I get home tonight; I expect it to work there, too.)

Thanks, tinypoodle and curaga, for all your help.  Your time was much appreciated.

(And curaga -- Dang!  How did you know my pgdn key was behaving like a control key?  That was spot-on!)

Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 10037
Re: Page down key not working?
« Reply #11 on: February 21, 2011, 09:32:59 AM »
From your xev output :)
The only barriers that can stop you are the ones you create yourself.

Offline tinypoodle

  • Hero Member
  • *****
  • Posts: 3857
Re: Page down key not working?
« Reply #12 on: February 21, 2011, 09:56:08 AM »
I'd expect it to show "Next" instead of "Control_R" after being fixed.
"Software gets slower faster than hardware gets faster." Niklaus Wirth - A Plea for Lean Software (1995)

Offline tayloratosu

  • WikiUser
  • *
  • Posts: 20
Re: Page down key not working?
« Reply #13 on: February 22, 2011, 07:29:58 AM »
Curaga:  "From your xev output"

Mr. Jabez Wilson laughed heavily. "Well, I never!" said he. "I thought at first that you had done something clever, but I see that there was nothing in it, after all."

--"The Red-Headed League"

 ;D