WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Grub 0.97 problem microcore  (Read 1786 times)

Offline Terminator3000

  • Jr. Member
  • **
  • Posts: 64
Grub 0.97 problem microcore
« on: October 24, 2010, 10:47:12 AM »
Hi,I am getting an error message when installing grub to my microcore.It goes through most of it fine until the very end when I get

error 6 mismatched or corrupt version of stage1/stage2

Ive installed microcore fine a number of times so this is a new one on me.
Ive tried adding the line root (hd0,1) manually to menu.lst (my setup is simple, hda1 swap,hda2 boot)

Everything else with the install seems fine.

Any tips welcome, particularly any about using lilo or grub4dos as alternative,Ive just used grub until now. Thanks.
« Last Edit: October 24, 2010, 10:50:23 AM by Terminator3000 »

Offline gutmensch

  • Administrator
  • Hero Member
  • *****
  • Posts: 606
  • I can make it disappear, have no fear!
    • remembrance blog
Re: Grub 0.97 problem microcore
« Reply #1 on: October 24, 2010, 11:18:31 AM »
Just a guess... did you check the copied files from /usr/lib/grub/i386-pc/ to the target? it's possible you only copied the links, this way stage1/stage2 would be corrupted (I think). Copy again directly from /tmp/tcloop/grub-0.97-splash/usr/lib/grub/i386-pc/ and try again, maybe even use the grub command
Code: [Select]
find /boot/bzImageto get the proper device.
If I seem unduly clear to you, you must have misunderstood what I said. (Alan Greenspan)

Offline Terminator3000

  • Jr. Member
  • **
  • Posts: 64
Re: Grub 0.97 problem microcore
« Reply #2 on: October 24, 2010, 12:09:27 PM »
Hi,wiped and tried again even switching boot to hda1 and copying grub as you advised and grub found (hd0,0) correctly, but I got exactly the same error,so I'm now suspecting a possible hardware/harddrive problem as Ive done this umpteen times without a hitch on other machines.

Thanks alot (still always learn new tips posting here!)

UPDATE:  After changing harddrive installation went fine!
« Last Edit: October 24, 2010, 02:34:22 PM by Terminator3000 »