WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Problems does not work on Acer313T  (Read 1670 times)

Offline stefanogreg

  • WikiUser
  • *
  • Posts: 5
Problems does not work on Acer313T
« on: July 26, 2010, 08:15:42 AM »
Hello Guys,
Thanks to all for the fantastic work which made TCL possible! It's simply great.
Anyway, also if i read almost all the forum posts i continue to have problems with XVesa video dirver.
This is not the only distro that had the same effect, also DSL was not working with XVesa but only with XOrg :(
My little Acer 313T has a NeoMagic MagicGraph 128ZV+, with 1.1 Mb of RAM capable of 65k colors at 800x600
so should work fine with 800x600x16 (788) but more I try less it works: X starts but I've  a strange green screen where it is impossible to read anything, than when i go back to Text mode (ctr+alt+bks) the console is unreadable.
I tried to use XFbdev but no results, but I have the impression that the .xsession is not correctly created, so i started in Text mode configured .xsession as in previous forum post for framebuffer but nothing ...
Any Idea??
I think XVesa "should" work with such an old HW may be needed some extra param?

Thanks

Offline stefanogreg

  • WikiUser
  • *
  • Posts: 5
Re: Problems does not work on Acer313T
« Reply #1 on: July 26, 2010, 08:23:05 AM »
Hello, Browsing the web i found that XVesa provides some special param for linux kernel and a dedicated module for neoMagic framebuffer:

video=neofb ==> Framebuffer driver for NeoMagic PCI Chips

The description is taken form here: http://www.gregfolkert.net/info/vesa-display-codes.html
and refers to the 2.6.20 kernel so as I'll have time i try again to pass such parameter as boot option.


 

Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 10226
Re: Problems does not work on Acer313T
« Reply #2 on: July 26, 2010, 10:38:57 AM »
The special fb drivers are not enabled in our config. Have you tried Xorg?
The only barriers that can stop you are the ones you create yourself.

Offline stefanogreg

  • WikiUser
  • *
  • Posts: 5
Re: Problems does not work on Acer313T
« Reply #3 on: July 27, 2010, 01:45:47 AM »
I've tried Xorg-7.4 and i got a segfault,
checked the logs and neomagic is correctly detected, the log stops after the keyboard module is loaded,
On Puppy Linux Xorg works fine, now I'm trying to get the proper config form there, but I also noticed some error messages when starting TinyCore3 that with 2.x there wasn't, may be the new kernel includes some module that does not work with my old laptop.
here is the last part of Xorg log (attached the whole one):

(**) Option "CoreKeyboard"
(**) <default keyboard>: always reports core events
(**) Option "Protocol" "standard"
(**) <default keyboard>: Protocol: standard
(**) Option "AutoRepeat" "500 30"
(**) Option "XkbRules" "xorg"
(**) <default keyboard>: XkbRules: "xorg"
(**) Option "XkbModel" "pc105"
(**) <default keyboard>: XkbModel: "pc105"
(**) Option "XkbLayout" "us"
(**) <default keyboard>: XkbLayout: "us"
(**) Option "CustomKeycodes" "off"
(**) <default keyboard>: CustomKeycodes disabled
(II) XINPUT: Adding extended input device "<default keyboard>" (type: KEYBOARD)

Backtrace:
0: /usr/local/bin/Xorg(xorg_backtrace+0x33) [0x80fe7c3]
1: /usr/local/bin/Xorg(xf86SigHandler+0x75) [0x80b2160]
2: [0xb7781400]
3: /usr/local/bin/Xorg(FreeClientResources+0x83) [0x806cfc2]
4: /usr/local/bin/Xorg(FreeAllResources+0x48) [0x806d06c]
5: /usr/local/bin/Xorg(main+0x48f) [0x806b8c5]
6: /lib/libc.so.6(__libc_start_main+0xe6) [0xb7363b86]
7: /usr/local/bin/Xorg() [0x806ae01]

Fatal server error:
Caught signal 11.  Server aborting


Please consult the TinyCore Linux support
    at www.tinycorelinux.com
 for help.
Please also check the log file at "/var/log/Xorg.0.log" for additional information.

(II) UnloadModule: "mouse"
(II) UnloadModule: "kbd"

Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 10226
Re: Problems does not work on Acer313T
« Reply #4 on: July 27, 2010, 01:53:31 AM »
Please try Xorg-7.5 on TC 3.
The only barriers that can stop you are the ones you create yourself.

Offline stefanogreg

  • WikiUser
  • *
  • Posts: 5
Re: Problems does not work on Acer313T
« Reply #5 on: July 27, 2010, 02:20:35 AM »
Xorg7.5 also does not work :(
The screen become black and no mouse pointer ctrl+alt+bks does not produce any effect,
may be I try to install TC2.x and run from there X I think is much more a kernel than a X problem

Offline stefanogreg

  • WikiUser
  • *
  • Posts: 5
Re: Problems does not work on Acer313T
« Reply #6 on: August 02, 2010, 03:50:54 AM »
 ;)
I rolled back to TinyCore 2.11.6 with Xfbdev.tcz from 3.x , boot in text mode loaded manually with:
  tce-load -i Xfbdev.tcz
then I run xsetup.sh and finally startx command and WOW this time it worked,
the XServer started quite fast (on my OOOLDDD lap too amazing :O ).

Than i rebooted with save option and whole desktop (with bar, menu and tools) was starting properly


I'll repeat and properly fix the procedure also trying with 3.x TC too.
boot parameter i used:
quiet vga=788 tce=hda1
I forgot to copy in tce PPR Xfbdev.tcs so I loaded it manually, may be this is the trick as I used the same parameters and procedure several times ....
I'll check an update i saw on the net that there are lot of Acer31XT owners trying to install some Linux Inside and due to PCMCIA CD + unbootable USB1.0 port this can be a nice recipe!