WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: gimp2  (Read 2535 times)

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 12997
gimp2
« on: June 07, 2010, 05:41:15 AM »
updated extension, compiled against everything I could find, posted:
Code: [Select]
Title:          gimp2.tcz
Description:    gnu image manipulation program
Version:        2.6.8
Author:         see list of sites below
Original-site:  see list of sites below
Copying-policy: see list of sites below
Size: 7.3MB
Extension_by:   juanito
Comments:       gimp...
                ----------
                can also be used with the SDL, openexr, libopenraw, libavformat,
                librsvg, libaa, libwmf, poppler, perl5, python, graphviz
                and webkit extensions.
                ----------
                Notes:
                libexif reqiured to open jpeg images
                librsvg, shared-mime-info, hicolor/gnome-icon-theme enable "nicer" icons
                webkit will enable on-line help
                ----------
                This extension contains:
                gimp-2.6.8 - GPLv2 - ftp://ftp.gimp.org/pub/gimp/v2.6/gimp-2.6.8.tar.bz2
                ----------
Change-log:     2008/12/30
                updated 2.6.3 -> 2.6.7 and recompiled against latest babl/gegl
                2009/09/28
                updated 2.6.7 -> 2.6.8
Current:        2010/06/05

Offline althalus

  • Sr. Member
  • ****
  • Posts: 351
Re: gimp2
« Reply #1 on: June 12, 2010, 04:28:25 AM »
When trying to run GIMP:
Code: [Select]
/usr/local/bin/gimp: error while loading shared libraries: libgegl-0.0.so.0: cannot open shared object file: No such file or directoryIt would seem GIMP has been built against an old version of libgegl?
Code: [Select]
$ ls /tmp/tcloop/gegl/usr/local/lib/
gegl-0.1/               libgegl-0.1.so          libgegl-0.1.so.0.101.1
libgegl-0.1.la          libgegl-0.1.so.0        pkgconfig/

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 12997
Re: gimp2
« Reply #2 on: June 12, 2010, 04:35:55 AM »
Both gimp2 and gegl have been updated recently - works fine for me - are you sure you have the latest versions of both?

Edit: check "gimp --version" gives 2.6.8, otherwise see attached screenshot
« Last Edit: June 12, 2010, 04:42:32 AM by Juanito »

Offline althalus

  • Sr. Member
  • ****
  • Posts: 351
Re: gimp2
« Reply #3 on: June 12, 2010, 05:59:18 AM »
gimp crashes out with the libgegl error when trying to check version, but otherwise, neither gimp2 nor gegl extensions are listed by apps-audit as needing to update. MD5's also check out against latest in repo.

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 12997
Re: gimp2
« Reply #4 on: June 12, 2010, 06:20:42 AM »
From this:
Code: [Select]
$ ldd `which gimp` | grep gegl
        libgegl-0.1.so.0 => /usr/local/lib/libgegl-0.1.so.0 (0xb6ff2000)

..it looks like you don't have the latest version of gimp2, could you try the same command locally and if you get libgegl-0.0.so.0, then you have the old version of gimp2.

Maybe you could delete your local copy of gimp2 and download it again?

Offline althalus

  • Sr. Member
  • ****
  • Posts: 351
Re: gimp2
« Reply #5 on: June 12, 2010, 06:45:14 PM »
I deleted and then re-downloaded both extensions last night before I posted in this thread the first time.

But now I am really confused. This morning, it is working, although I have changed absolutely nothing...

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 12997
Re: gimp2
« Reply #6 on: June 12, 2010, 08:24:42 PM »
But now I am really confused. This morning, it is working, although I have changed absolutely nothing...

Maybe something to do with the mirrors - but good it's working anyway  :)