WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Xvesa freaks out when I restart X from a script  (Read 1567 times)

Offline RedWagon

  • WikiUser
  • *
  • Posts: 2
Xvesa freaks out when I restart X from a script
« on: April 15, 2010, 07:09:55 PM »
I'm working towards deploying Tiny Core at my work.  All of our computers have monitors with a 4:3 aspect ratio except for these EEE Tops we just got in.  To automatically set the resolution for the EEE tops without having to use a different image I wrote a small script that checks the output of lspci to determine if the computer is an EEE top and if it is edit .xsession, kill X and then restart it.  Everything works like a charm except for startx.  When startx is run the screen continuously flashes the Xvesa Resolution Setup page followed by

sh: can't open /de *reaches the end of the screen*
y: No such device or address

This is also exactly what happened when I added /bin/bash to the end of my ~/.ashrc as a failed workaround to switch the default shell to bash.

EDIT: Also wanted to add that if I remove the sections of the script that kill and restart X and then manually do it with alt-ctrl-backspace then startx everything works as it should.
« Last Edit: April 15, 2010, 07:38:57 PM by RedWagon »

Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 9970
Re: Xvesa freaks out when I restart X from a script
« Reply #1 on: April 16, 2010, 02:34:35 AM »
Where do you run this script? Why not change the resolution before the first X start?

A built-in way would be to use the bootcode on those machines, ie "xvesa=1280x1024x24".
The only barriers that can stop you are the ones you create yourself.