WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Changing Xkblayout From US to Gbr  (Read 2073 times)

Offline jaygeetiny

  • WikiUser
  • *
  • Posts: 20
Changing Xkblayout From US to Gbr
« on: February 05, 2009, 03:04:05 PM »
I'm trying to change the TC keyboard layout from the default "us" to "gbr" so that the " and @ keys are not transposed as they are at present.

I can't find xorg.conf anywhere so I downloaded kmaps.tce thinking it just needed a root CLI of "loadkmap" to do the job. Not so.

Any help would be appreciated.
Using TC 1.1 in PPR/TC mode on a bootable USB stick with boot options "quiet noswap tce=sda1 waitusb=7 pause"

Offline ^thehatsrule^

  • Administrator
  • Hero Member
  • *****
  • Posts: 1726
Re: Changing Xkblayout From US to Gbr
« Reply #1 on: February 05, 2009, 05:50:19 PM »
I'm guessing you did this while in X.  See this FAQ entry should you want more info: http://www.tinycorelinux.com/faq.html#keyboard

Offline jaygeetiny

  • WikiUser
  • *
  • Posts: 20
Re: Changing Xkblayout From US to Gbr
« Reply #2 on: February 06, 2009, 06:14:59 AM »
Hi hats

Thanks for the link.

One slight problem arose; "fi-latin9.kmap" seems to be aimed at Finnish users so I added "loadkmap
< /usr/share/kmap/uk.kmap" to /opt/bootlocal.sh instead and it works fine.
« Last Edit: February 11, 2009, 09:34:37 AM by jaygeetiny »
Using TC 1.1 in PPR/TC mode on a bootable USB stick with boot options "quiet noswap tce=sda1 waitusb=7 pause"