WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Readline  (Read 3893 times)

Offline 4-stroke

  • Jr. Member
  • **
  • Posts: 72
Readline
« on: March 05, 2010, 06:46:41 AM »
I'm trying to compile fim from here:
http://mirrors.aixtools.net/sv/fbi-improved/
Configure complains:
Code: [Select]
checking for rl_replace_line in -lreadline... no
configure: error: *** GNU readline library headers not found !  please install them or run ./configure --disable-readline ***
I've installed readline.tcz and readline-dev.tcz.
 ???
A learning experience is one of those things that say, "You know that thing you just did? Don't do that." - Douglas Adams

Offline Jason W

  • Administrator
  • Hero Member
  • *****
  • Posts: 9707
Re: Readline
« Reply #1 on: March 05, 2010, 06:51:15 AM »
Did you set the pkg-config path as mentioned here?

http://wiki.tinycorelinux.com/tiki-index.php?page=Creating+Extensions

specifically-
export PKG_CONFIG_PATH=/usr/local/lib/pkgconfig:/usr/lib/pkgconfig

Offline 4-stroke

  • Jr. Member
  • **
  • Posts: 72
Re: Readline
« Reply #2 on: March 05, 2010, 06:57:48 AM »
Did you set the pkg-config path as mentioned here?

http://wiki.tinycorelinux.com/tiki-index.php?page=Creating+Extensions

specifically-
export PKG_CONFIG_PATH=/usr/local/lib/pkgconfig:/usr/lib/pkgconfig

Yes I did. And the compiler flags.
A learning experience is one of those things that say, "You know that thing you just did? Don't do that." - Douglas Adams

Online Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 12410
Re: Readline
« Reply #3 on: March 05, 2010, 07:00:13 AM »
Have a look in config.log - sometimes the error message does not exactly match the actual error that occurred.

Offline 4-stroke

  • Jr. Member
  • **
  • Posts: 72
Re: Readline
« Reply #4 on: March 05, 2010, 07:12:03 AM »
There's this:
Code: [Select]
configure:10798: checking for rl_replace_line in -lreadline
configure:10834: g++ -o conftest -g -O2   conftest.cpp -lreadline  -lcurses
       -lm  >&5
/usr/local/bin/ld: cannot find -lcurses
collect2: ld returned 1 exit status
configure:10840: $? = 1
configure: failed program was:
| /* confdefs.h.  */
And this:
 
Code: [Select]
/* Override any GCC internal prototype to avoid an error.
|    Use char because int might match the return type of a GCC
|    builtin and then its argument prototype would still apply.  */
| #ifdef __cplusplus
| extern "C"
| #endif
| char rl_replace_line ();
| int
| main ()
| {
| return rl_replace_line ();
|   ;
|   return 0;
| }
configure:10858: result: no
configure:10870: error: *** GNU readline library headers not found !  please install them or run ./configure --disable-readline ***
A learning experience is one of those things that say, "You know that thing you just did? Don't do that." - Douglas Adams

Online Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 12410
Re: Readline
« Reply #5 on: March 05, 2010, 08:41:18 AM »
..so it's probably libcurses that's missing - you could try the ncurses-lib.tcz/ncurses-lib-dev.tcz extensions

Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 10273
Re: Readline
« Reply #6 on: March 05, 2010, 08:44:26 AM »
libcurses is in the base. Do you have base-dev loaded?
The only barriers that can stop you are the ones you create yourself.

Offline robc

  • Sr. Member
  • ****
  • Posts: 447
Re: Readline
« Reply #7 on: March 05, 2010, 09:33:05 AM »
libcurses is in the base. Do you have base-dev loaded?
libncurses is in the base, this is looking for libcurses which I don't see in the base.
The headers are in base-dev, but I don't see an actual libcurses  :-\

Have you tried this?
Code: [Select]
sudo ln -s /lib/libncurses.so /lib/libcurses.so
sudo ldconfig
This will make a link to libncurses, should work...

Have you tried configuring with --disable-readline?
"Never give up! Never surrender!" - Commander Peter Quincy Taggart

"Make it so." - Captain Picard

Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 10273
Re: Readline
« Reply #8 on: March 05, 2010, 09:37:31 AM »
Hm, I thought there still was the ld redirection script curses -> ncurses from LFS in base-dev. I guess it was forgotten at some point. Juanito, could it be added?
The only barriers that can stop you are the ones you create yourself.

Online Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 12410
Re: Readline
« Reply #9 on: March 05, 2010, 09:48:16 AM »
Sure - give me a day or two to get around to it  :)

Offline 4-stroke

  • Jr. Member
  • **
  • Posts: 72
Re: Readline
« Reply #10 on: March 05, 2010, 10:40:51 AM »
Have you tried this?
Code: [Select]
sudo ln -s /lib/libncurses.so /lib/libcurses.so
sudo ldconfig
This will make a link to libncurses, should work...

Have you tried configuring with --disable-readline?

This worked. There was some warnings though, got to check them out.
Thanks!

Edit: Duh! Forgot to install readline.tcz again. In fact the only thing needed was the symlink.
« Last Edit: March 05, 2010, 10:58:42 AM by 4-stroke »
A learning experience is one of those things that say, "You know that thing you just did? Don't do that." - Douglas Adams