WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: [SOLVED] How to compile glibc for i486?  (Read 2157 times)

Offline Iguleder

  • WikiUser
  • *
  • Posts: 12
[SOLVED] How to compile glibc for i486?
« on: March 03, 2010, 10:48:25 AM »
Hello, I have a question: how can I compile glibc with support for i486?

When I try to boot my ISO with an emulated i686 processor it works fine, but I get some error with libc.so.6 when I try the same with an i486 processor.

The problem must be in the CFLAGS I use ...
I configured glibc this way:

CFLAGS="-march=i486 -mtune=i686 -O2 -pipe"
CC="gcc -m32"
echo "CFLAGS += -march=i486 -mtune=i686 -O2 -pipe" > configparms
../glibc-2.11.1/configure --prefix=/usr --disable-profile --enable-add-ons --enable-kernel=2.6.33 --libexecdir=/usr/lib/glibc

I also tried the same, but with glibc's processor parameter, I set it to i386, as i486 is unsupported: the result is identical. It simply won't run init: it says that something in glibc is unsupported, some function, and it mentions ./sysdeps/x86_64 or something, that is clearly a directory in glibc's sources tree.

And yes, I verified this: the CFLAGS are passed properly ... What am I missing?

Thanks!

EDIT: solved. I'm such an idiot, I know.

echo "CFLAGS += -march=i486 -mtune=i686 -O2 -pipe" > configparms
CFLAGS="-march=i486 -mtune=i686 -pipe"
CC="gcc -m32"
../glibc-2.11.1/configure --prefix=/usr     --disable-profile --enable-add-ons     --enable-kernel=2.6.18 --libexecdir=/usr/lib/glibc --build=i486-pc-linux-gnu
« Last Edit: March 03, 2010, 11:13:30 AM by Iguleder »

Offline gerald_clark

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 4254
Re: [SOLVED] How to compile glibc for i486?
« Reply #1 on: March 03, 2010, 02:48:43 PM »
This is unnecessary.
V 2.9 has 486 glibc.