WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Xvesa: Default Display Blanking Timeout  (Read 4776 times)

Offline Tahoe

  • WikiUser
  • *
  • Posts: 15
Xvesa: Default Display Blanking Timeout
« on: January 01, 2010, 08:21:56 PM »
Happy New Years Folks,

Running the latest 2.7 on a laptop and looking for where the (ten min.) default screen blanking info's kept. I've searched and read through a few threads, notably this vbetool topic http://forum.tinycorelinux.net/index.php?topic=1591.0 I'd be happy to alter the stock setup which I gather is possible, or learn vbetool's use. I'd prefer to stay with Xvesa and would like to know if the *suspend* package is essential for working with vbetool, thanks.
People tend to make rules for others and exceptions for themselves. Well now, how about that?

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 11193
Re: Xvesa: Default Display Blanking Timeout
« Reply #1 on: January 01, 2010, 10:26:03 PM »
The suspend extension was originally used with vbetool to provide a couple of dependencies - these dependencies (libx86, libpci) have been moved to separate extensions, so the suspend extension should not be needed now.

Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 10100
Re: Xvesa: Default Display Blanking Timeout
« Reply #2 on: January 02, 2010, 12:02:30 AM »
The xset utility may be used to change the timeouts. "xset q" to see the current ones.
The only barriers that can stop you are the ones you create yourself.

Offline Tahoe

  • WikiUser
  • *
  • Posts: 15
Re: Xvesa: Default Display Blanking Timeout
« Reply #3 on: January 02, 2010, 06:27:21 AM »
OK, I've got the deps Jaunito listed along with an 845g chipset, 915resolution invoked from bootlocal.sh. For testing purposes I've tried:

xset dpms 0 0 60

... which results in a "server does not have extension for dpms option" before following up with usage. Perhaps my syntax?

xset q results in:

Code: [Select]
Keyboard Control:
  auto repeat:  on    key click percent:  0    LED mask:  00000000
  auto repeating keys:  00ffffffdffffbbf
                        fadfffffffedffff
                        ffffffffffffffff
                        ffffffffffffff7f
  bell percent:  50    bell pitch:  400    bell duration:  100
Pointer Control:
  acceleration:  2/1    threshold:  4
Screen Saver:
  prefer blanking:  yes    allow exposures:  yes
  timeout:  600    cycle:  600
Colors:
  default colormap:  0x20    BlackPixel:  0    WhitePixel:  16777215
Font Path:
  /usr/lib/X11/fonts/misc/,/usr/lib/X11/fonts/75dpi/
Bug Mode: compatibility mode is disabled
DPMS (Energy Star):
  Server does not have the DPMS Extension
Font cache:
  Server does not have the FontCache Extension

I'll note the 915res is somewhat sluggish compared to video without and doubt it's doing me much good either. Hopefully you guys can help me achieve nirvana without much ado, thanks again.

PS - Is there a file holding that 600 timeout value or is it generated by an extension?
People tend to make rules for others and exceptions for themselves. Well now, how about that?

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 11193
Re: Xvesa: Default Display Blanking Timeout
« Reply #4 on: January 02, 2010, 06:34:16 AM »
xset dpms 0 0 60

... which results in a "server does not have extension for dpms option" before following up with usage. Perhaps my syntax?

..maybe the syntax is wrong, but I would guess you need the full "X" from the Xorg extension for the dpms option to be enabled? On the bright side, this would mean you wouldn't need 915resolution  ;)

Offline Tahoe

  • WikiUser
  • *
  • Posts: 15
Re: Xvesa: Default Display Blanking Timeout
« Reply #5 on: January 02, 2010, 06:44:03 AM »
Yeah maybe, I'm thinking lose the 915. Xorg's worked OK on other distros I've tried but not a few boots ago, she wouldn't go. Since eyeballing related items in appbrowser, I'd say it's time for another shot. In the event she doesn't load, what are my outs? Slip a working xorg.conf in there (I know my refresh rates)?

Then again, about that 600 value? It exist somewhere I could adjust?
« Last Edit: January 02, 2010, 06:48:19 AM by Tahoe »
People tend to make rules for others and exceptions for themselves. Well now, how about that?

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 11193
Re: Xvesa: Default Display Blanking Timeout
« Reply #6 on: January 02, 2010, 06:58:18 AM »
I've not managed to get the couple of intel graphics chipsets to which I've had access to work confless with xorg, but they do work with a suitable xorg.conf culled from google.

As for the 600 screensaver setting - I don't know, but maybe the xset linux man page might turn something up?

Edit:
Quote
The default values are built into X, and need not appear anywhere else. That's why, if you grepped for timeouts, you may not have found them.

They can also be set via xset. You can set the blank timeout with:
xset s blank
xset s 300
will tell X to use screen blanking after the system has been idle for 300 seconds (five minutes).

xset dpms 0 360 420
disables DPMS standby and sets the DPMS suspend time to 360 seconds and the off time to 420 seconds. In theory, this combined with the previous xset commands would first blank the screen at five minutes; then at six minutes, the display would go to suspend, turning off another minute later. In practice, this won't work for most people, as we'll see later. (DPMS through xorg seems only to toggle the screen-blanked state -- so if the screen was already blanked, it will actually turn back on! -- rather than going to a power saving state.)

But the timeouts can also be specified in the X configuration file: /etc/X11/xorg.conf. In the "Monitor" section, you need a line like:
        Option          "DPMS"
Then, in the "ServerLayout" section (for Xorg 7.2 and later, make a separate ServerFlags section instead), include lines like this:
        Option          "BlankTime"     "4"
        Option          "StandbyTime"   "0"
        Option          "SuspendTime"   "0"
        Option          "OffTime"       "5"
Caution: note the numbers are all small. xorg.conf needs times specified in minutes, not seconds as with xset.

If you're seeing a timeout that isn't one of the defaults, but isn't specified in xorg.conf -- as with the two-minute timeout which set me on this quest in the first place -- you may have to hunt around for a place that's calling xset dpms with a different set of timeouts. In my case, it turned out that Ubuntu Breezy sets the dpms timeouts in /etc/acpi/power.sh, which gets called at boot time. So anything you set in xorg.conf may well get overridden.

Hint: when debugging timeouts, try setting them to unusual numbers like 765 or 666 instead of 300 or 600. That makes it easier to be sure whether you're seeing your own numbers or something coming from a system setting somewhere else.
« Last Edit: January 02, 2010, 07:09:17 AM by Juanito »

Offline Tahoe

  • WikiUser
  • *
  • Posts: 15
Re: Xvesa: Default Display Blanking Timeout
« Reply #7 on: January 02, 2010, 07:12:11 AM »
So Confless is (partially) responsible for auto-configuring users hardware? In the meantime I'll try and follow along here http://forum.tinycorelinux.net/index.php?topic=4091.0, it's recent.
People tend to make rules for others and exceptions for themselves. Well now, how about that?

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 11193
Re: Xvesa: Default Display Blanking Timeout
« Reply #8 on: January 02, 2010, 07:13:39 AM »
did you see the edit to the post above?

Offline Tahoe

  • WikiUser
  • *
  • Posts: 15
Re: Xvesa: Default Display Blanking Timeout
« Reply #9 on: January 02, 2010, 07:20:10 AM »
Oh sure, thanks Juanito. Think I'll dig around a little and see what turns up.
People tend to make rules for others and exceptions for themselves. Well now, how about that?

Offline Tahoe

  • WikiUser
  • *
  • Posts: 15
Re: Xvesa: Default Display Blanking Timeout
« Reply #10 on: January 02, 2010, 06:58:08 PM »
Solution, albeit simple! These two issued one after the other.
They probably won't for monitors not supporting dpms.

xset s blank

Followed by:

xset s [time_in_seconds] 180 for my preference.

Now how to apply before the Xserver's up?
People tend to make rules for others and exceptions for themselves. Well now, how about that?

Offline ^thehatsrule^

  • Administrator
  • Hero Member
  • *****
  • Posts: 1726
Re: Xvesa: Default Display Blanking Timeout
« Reply #11 on: January 02, 2010, 07:58:43 PM »
This can be used only after X is up.  See ~/.xsession

Offline Tahoe

  • WikiUser
  • *
  • Posts: 15
Re: Xvesa: Default Display Blanking Timeout
« Reply #12 on: January 02, 2010, 08:16:49 PM »
Unfortunately I'm still a greenhorn when it comes to appending necessary information.

Code: [Select]
Xvesa -br -screen 1024x768x32 -shadow -mouse /dev/input/mice,5 -nolisten tcp -I >/dev/null 2>&1 &
waitforX
"$DESKTOP" 2>/tmp/wm_errors &
export WM_PID=$!
[ -n "$THEME" ] && cp /opt/jwmThemes/"$THEME" .jwmrc-theme
if [ -n "$BACKGROUND" ]; then
  setbackground image /opt/backgrounds/"$BACKGROUND"
else
  [ -x ./.setbackground ] && ./.setbackground
fi
[ "$ICONS" == "wbar" ] && /usr/bin/wbar.sh
[ -x ./.mouse_config ] && ./.mouse_config &
[ $(which flit) ] && flit &
[ $(which watcher) ] && watcher -g +0-0 &

Will I need to add the options from Xvesa's cli or xset's?
The Xvesa line before the "waitforX" notation, right?
« Last Edit: January 02, 2010, 08:24:04 PM by Tahoe »
People tend to make rules for others and exceptions for themselves. Well now, how about that?

Offline Tahoe

  • WikiUser
  • *
  • Posts: 15
[SOLVED] Xvesa: Default Display Blanking Timeout
« Reply #13 on: January 16, 2010, 05:47:20 PM »
Xvesa's! Options v and -s [minutes] somewhere in the line before "waitforX."
People tend to make rules for others and exceptions for themselves. Well now, how about that?