WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: boot messages interrupt the boot code security password input  (Read 2155 times)

Offline bigpcman

  • Hero Member
  • *****
  • Posts: 719
boot messages interrupt the boot code security password input
« on: January 15, 2009, 06:52:47 AM »
This is a minor issue but I thought I would report it. When the security boot code is used the root password entry dialog is interrupted by messages like "sda cache write through enabled ( not the exact message)" which makes the password entry a little confusing.
big pc man

Offline ^thehatsrule^

  • Administrator
  • Hero Member
  • *****
  • Posts: 1726
Re: boot messages interrupt the boot code security password input
« Reply #1 on: January 15, 2009, 09:13:43 AM »
Are these from the kernel messages when you use the bootcodes i.e. from http://forum.tinycorelinux.net/index.php?topic=431.0 ?  If so, just turn them off again.

Offline bigpcman

  • Hero Member
  • *****
  • Posts: 719
Re: boot messages interrupt the boot code security password input
« Reply #2 on: January 15, 2009, 11:57:15 AM »
No I had all those messages turned off via "quiet".
big pc man

Online curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 10070
Re: boot messages interrupt the boot code security password input
« Reply #3 on: January 15, 2009, 12:20:12 PM »
quiet is an alias for loglevel=4, debug is for loglevel=10. Try loglevel=3 and lower until you don't see those messages anymore. Try not to jump straight to 1, because you still want to see the critical messages like your cpu exploded ;)

Could you post the exact message? If I can find it in the source, I'll be able to tune it's loglevel up so it won't show up on "quiet" anymore (after the next kernel update)
« Last Edit: January 15, 2009, 12:23:06 PM by curaga »
The only barriers that can stop you are the ones you create yourself.

Offline bigpcman

  • Hero Member
  • *****
  • Posts: 719
Re: boot messages interrupt the boot code security password input
« Reply #4 on: January 15, 2009, 12:55:09 PM »
Ok, here's a brute force screen shot and my isolinux.cfg.

Quote
display boot.msg
default tinycore
label tinycore
   kernel /boot/bzImage
   append initrd=/boot/tinycore.gz quiet nofstab norestore user secure

implicit 0   
prompt 1   
timeout 1
F1 boot.msg
F2 f2
F3 f3
big pc man