WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: bootup slowed down by scans of IDE devices - boot code fix?  (Read 2465 times)

Offline bigpcman

  • Hero Member
  • *****
  • Posts: 719
bootup slowed down by scans of IDE devices - boot code fix?
« on: January 14, 2009, 02:20:54 PM »
I noticed the boot up time on my system is bogged down by the system trying to determine the status of my ntfs hd. Is there a boot code to tell the system to skip this step?

-----------------------
edit: Well OK I didn't offer much to go on here so here is part of the dmesg output:

Quote
Probing IDE interface ide0...
hda: Hitachi HTS541616J9AT00, ATA DISK drive
hda: host max PIO4 wanted PIO255(auto-tune) selected PIO4
hda: UDMA/100 mode selected
Probing IDE interface ide1...
hdc: HL-DT-STCD-RW/DVD-ROM GCC-4240N, ATAPI CD/DVD-ROM drive
hdc: host max PIO4 wanted PIO255(auto-tune) selected PIO4
hdc: UDMA/33 mode selected
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
ide1 at 0x170-0x177,0x376 on irq 15
ide_generic: please use "probe_mask=0x3f" module parameter for probing all legacy ISA IDE ports
ide_generic: I/O resource 0x1F0-0x1F7 not free.
ide_generic: I/O resource 0x170-0x177 not free.

It seems to take about 6-7 seconds to get through this sequence. Actually I don't know if the ntfs file format has anything to do with the delay. But since I don't want to access the hd anyway when I'm running tc I was hoping there was a way to get the boot script to skip this stuff.

-----------------------------------------
edit 2: After looking at the boot sequence more closely the delay occurs between the time the booting kernel message comes out and when the last two "ide_generic..." messages come out. Maybe the delay is actually occurring somewhere else in the boot sequence and I can't see it. Is there anyway to turn on the dmesg's during the boot sequence to see what exactly is causing the delay?
« Last Edit: January 14, 2009, 06:47:46 PM by bigpcman »
big pc man

Offline ^thehatsrule^

  • Administrator
  • Hero Member
  • *****
  • Posts: 1726
Re: bootup slowed down by scans of IDE devices - boot code fix?
« Reply #1 on: January 14, 2009, 08:32:37 PM »
I get the same 2 ide_generic messages as well (on a VM), but it doesn't seem to slow things down.

To avoid scanning, you could try the "nofstab" boot option.

To look at the kernel messages during boot, you can either remove "quiet" or add "debug" boot option.  It may be useful to add "pause" as well (pauses in console after boot, using shift+pgup/dn to scroll).


Edit by Curaga: s/nostab/nofstab/
« Last Edit: January 15, 2009, 04:53:43 AM by curaga »

Offline mikshaw

  • Sr. Member
  • ****
  • Posts: 368
Re: bootup slowed down by scans of IDE devices - boot code fix?
« Reply #2 on: January 15, 2009, 02:32:05 AM »
Quote
It may be useful to add "pause" as well (pauses in console after boot, using shift+pgup/dn to scroll).
Thanks for that pearl. I think it will be very useful.  It seems that TC clears the screen once the user is logged in.