WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: (solved on the server) fixing appbrowser in rc9 and below  (Read 4598 times)

Offline tobiaus

  • Suspended
  • Hero Member
  • *****
  • Posts: 599
(solved on the server) fixing appbrowser in rc9 and below
« on: January 01, 2009, 11:21:12 AM »
this post assumes that appbrowser is working in rc9b, the latest version of tc.

i am using rc9. gimp2 and wine have been uploaded as tce's. i have managed to install them from the http and ftp pages at ibiblio, so this is about appbrowser, not wine or gimp really.

originally i think i needed to reboot. ruled that out booting from my usb.

i usually boot in cloud, so right now i have these installed: leafpad * nano  * minefield * wine * gimp2

not to mention anything else that i setup when i reboot. i'll reboot soon enough, but right now i want to make appbrowser work again. it works fine for every extension except gimp2 and newer. for these, they are not even listed!

when i was told that ftp was updated more often (or sooner) than http, i tried to change the mirror used. i did this by modifying /opt/.tcrc and /usr/bin/tce-fetch.sh to use ftp instead of http. perhaps i should have modified /usr/bin/tcemirror. (or maybe not, i see it's a binary.)

anyway, good guesses included that it was still being uploaded. they are there, i've installed them. they're just not getting listed so i can install from appbrowser.

since then i have gone as far as downloading the new rc rc9b, mounting the iso and "unzipping" tinycore.gz into /tmp/folder per the wiki's remastering instructions.

so i have all the files from tc rc9b if i need them, and i have "upgraded" (copied to the right place) these files:

/opt/.tcrc (it's the same as rc9 but now it's fresh)
/usr/bin/appbrowser (i now have the latest version. that should work!)
/usr/bin/*tce* (4 files, including the newest tce-load and tce-fetch)

my question: what else has changed in rc9b that needs to be updated before appbrowser works properly?

i'm enjoying the mystery but every time i get an idea how to get appbrowser working, it still works- it just won't list wine or gimp2 in its list.

i've upgraded every known component of the package system, from rc9b. obviously i'm not updating something from rc9.

i've learned a lot, too. not enough obviously :) any ideas?
« Last Edit: January 01, 2009, 12:02:21 PM by tobiaus »

Offline roberts

  • Administrator
  • Hero Member
  • *****
  • Posts: 7361
  • Founder Emeritus
Re: fixing appbrowser in rc9 and below
« Reply #1 on: January 01, 2009, 11:48:40 AM »
A bug on the server side. It is now fixed. Thanks for the report.
10+ Years Contributing to Linux Open Source Projects.

Offline tobiaus

  • Suspended
  • Hero Member
  • *****
  • Posts: 599
Re: (solved on the server) fixing appbrowser in rc9 and below
« Reply #2 on: January 01, 2009, 12:09:16 PM »
thanks! i kept thinking it might be that somehow, but trying to get "the new appbrowser" working on older versions was an experience. tinycore is really becoming the distro i always dreamed of.

i'm using wine in it now that my install of wine on xubuntu doesn't work, and so far, flash is faster and more stable from a tinycore usb install than from my xubuntu hd install. i wanted something that let me do more of the things i use xubuntu for, but overall more like using dsl. sooner or later tc may replace xubuntu for me entirely, at least after i get wireless with it. i'm probably not doing that yet, but i am going to start removing things from my xubuntu install :)