WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Requests for extensions  (Read 205762 times)

Offline jls

  • Hero Member
  • *****
  • Posts: 2135
Re: Requests for extensions
« Reply #75 on: January 28, 2009, 08:22:14 AM »
I would like amule and nicotine
dCore user

Offline bigpcman

  • Hero Member
  • *****
  • Posts: 719
Re: Requests for extensions
« Reply #76 on: January 28, 2009, 01:00:04 PM »
how to get Komposer to work?

Received the error "error while loading shared libraries: libgtk-x11-2.0.so.0: cannot open shared object file: no such file or directory"
This means you need to load the gtk+-2 extension (and probably its dependencies)

Ok that worked. Now I get the error "error while loading shared libraries: libXinerama.so.1: cannot open shared object file: no such file or directory"

How about this error?

Perhaps the moderator should put this in a new thread named "how to get Komposer to work?"
« Last Edit: January 28, 2009, 01:05:06 PM by bigpcman »
big pc man

Offline bigpcman

  • Hero Member
  • *****
  • Posts: 719
Re: Requests for extensions
« Reply #77 on: January 28, 2009, 02:05:23 PM »
Here's a copy of Skype that works with  OSS and libstc++5.0.7 installed.  I could never get this working with DSL, but it works great with tiny. I included a menu, or load with "skype"

[^thehatsrule^: link removed - compliance to company license not shown]

Edit: the license is included in the skype folder.  Not enough???

What happened here? It would be great to have skype!

-------
There is a Skype "package" for puppy linux if that makes any difference.
« Last Edit: January 28, 2009, 07:24:55 PM by bigpcman »
big pc man

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 13334
Re: Requests for extensions
« Reply #78 on: January 28, 2009, 07:31:03 PM »
Ok that worked. Now I get the error "error while loading shared libraries: libXinerama.so.1: cannot open shared object file: no such file or directory"
Xorg-7.4 extension (does google work on your machine  ;) )

Offline bigpcman

  • Hero Member
  • *****
  • Posts: 719
Re: Requests for extensions
« Reply #79 on: January 28, 2009, 08:11:35 PM »

Ok that worked. Now I get the error "error while loading shared libraries: libXinerama.so.1: cannot open shared object file: no such file or directory"
Xorg-7.4 extension (does google work on your machine  ;) )

Wow xorg is huge. This presents an interesting problem. I run my extension applications using the optional install method. I don't want to run xorg all the time, only when applications need it. So I would want Xorg plus dependencies, the config file and new xsession file all to install with the extension and then the xsession to restart automatically. Then upon reboot revert back to xvesa unless the extension is in the tce folder instead of the optional folder. I'll have ponder what to do about all this.
« Last Edit: January 28, 2009, 08:15:41 PM by bigpcman »
big pc man

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 13334
Re: Requests for extensions
« Reply #80 on: January 28, 2009, 08:17:33 PM »
There's a distinct possibility that you only need libXinerama.so.1 so you could make your own mini-extension of /usr/local/lib/libXinerama* to avoid loading the full X extension every time.

Offline bigpcman

  • Hero Member
  • *****
  • Posts: 719
Re: Requests for extensions
« Reply #81 on: January 28, 2009, 08:35:04 PM »
Thanks for that tip. But when I install the xorg extension I don't get the libXinerama.so.1 file instead I get libXinerama.a and libXinerama.la in /usr/local/lib/.
big pc man

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 13334
Re: Requests for extensions
« Reply #82 on: January 28, 2009, 08:50:20 PM »
Those are the "dev" files, the lib has to be there somewhere (I'm not at a tc machine at the moment) - in /usr/lib as opposed to /usr/local/lib maybe?

Note that libXinerama.so.1 will mostly likely be a symlink, you will need all the libXinerama.so* files.

Edit: with the version of Xorg-7.4 I have:
Code: [Select]
$ ls /usr/local/lib/libXin*
/usr/local/lib/libXinerama.so
/usr/local/lib/libXinerama.so.1
/usr/local/lib/libXinerama.so.1.0.0
Note that there's no libXinerama.a/la - did you maybe load Xorg-7.4-dev in error?
« Last Edit: January 29, 2009, 12:20:49 AM by Juanito »

Offline bigpcman

  • Hero Member
  • *****
  • Posts: 719
Re: Requests for extensions
« Reply #83 on: January 29, 2009, 05:50:45 AM »
Thanks again for your help. Yes indeed I loaded the dev files by mistake. I decided to take a brute force approach and installed emelfm2 and xorg for support. Then I unpacked the Komposer tarball in /home/tc and ran the program. It came right up! So I now know xorg does not have to be running.
big pc man

Offline chalbersma

  • WikiUser
  • *
  • Posts: 14
Re: Requests for extensions
« Reply #84 on: January 30, 2009, 01:49:32 PM »
How about an integrated developement enviornment.  Anyone would do fine.

Offline jpeters

  • Restricted
  • Hero Member
  • *****
  • Posts: 1017
Re: Requests for extensions
« Reply #85 on: February 01, 2009, 08:34:46 AM »
Here's a copy of Skype that works with  OSS and libstc++5.0.7 installed.  I could never get this working with DSL, but it works great with tiny. I included a menu, or load with "skype"

[^thehatsrule^: link removed - compliance to company license not shown]

Edit: the license is included in the skype folder.  Not enough???

What happened here? It would be great to have skype!

-------
There is a Skype "package" for puppy linux if that makes any difference.

The Puppy version probably won't work. Hats wouldn't allow my submission without getting permission
from Skype....and Skype doesn't respond to emails (I've sent two now).  Personally, I think it's a non-issue (there's some statement in the license about wanting latest version updates on sites which makes no sense for distros they don't support). Besides, they get subscription fees. You can PM me, and I'll send you a copy.   

Offline florian

  • Full Member
  • ***
  • Posts: 116
    • Home Page
Re: Requests for extensions
« Reply #86 on: February 01, 2009, 11:56:38 AM »
How about an integrated developement enviornment.  Anyone would do fine.
Gimme one or two days and I'll build FLDev and submit it. It's tiny minimal IDE made with FLTK.

Offline jpeters

  • Restricted
  • Hero Member
  • *****
  • Posts: 1017
Re: Requests for extensions
« Reply #87 on: February 01, 2009, 11:24:58 PM »
How about an integrated developement enviornment.  Anyone would do fine.
Gimme one or two days and I'll build FLDev and submit it. It's tiny minimal IDE made with FLTK.

could use XML support...

Offline Surreal Killa

  • WikiUser
  • *
  • Posts: 1
Re: Requests for extensions
« Reply #88 on: February 03, 2009, 04:59:45 AM »
Awesome window manager.

Offline Onyarian

  • Sr. Member
  • ****
  • Posts: 337
Re: Requests for extensions
« Reply #89 on: February 09, 2009, 09:58:01 AM »
Reply to bigpcman

Quote
how to get Komposer to work?
Quote
Ok that worked. Now I get the error "error while loading shared libraries: libXinerama.so.1: cannot open shared object file: no such file or directory"
Quote
Wow xorg is huge. This presents an interesting problem. I run my extension applications using the optional install method. I don't want to run xorg all the time, only when applications need it.

Now you have kompozer extension, and you don't need to load Xorg (23Mb) but skype_support.tcel extension with only 20Kb.

See:  http://forum.tinycorelinux.net/index.php?topic=595.0