WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: odd message on shutdown  (Read 5152 times)

Offline 3rail

  • Full Member
  • ***
  • Posts: 113
odd message on shutdown
« on: October 13, 2009, 11:40:25 AM »
using 241, upon shutdown of X, one of the messages says:

sh: quiet: unknown operand

no harm is done, thought I'd report it anyway :)

thanks as always!
« Last Edit: October 13, 2009, 07:22:49 PM by 3rail »

Offline roberts

  • Administrator
  • Hero Member
  • *****
  • Posts: 7361
  • Founder Emeritus
Re: odd message on shutdown
« Reply #1 on: October 13, 2009, 01:14:35 PM »
I haven't see it.
Please describe your operating environment.
What type of install?
Are you running in a virtual machine?
What does showbootcodes produce?
10+ Years Contributing to Linux Open Source Projects.

Offline 3rail

  • Full Member
  • ***
  • Posts: 113
Re: odd message on shutdown
« Reply #2 on: October 13, 2009, 07:20:31 PM »
I use a 32mb flash disk (via ide, not usb) as my boot drive.  I created it by booting from a tinycore v2.4.1 usb cd and using usbinstall.  I chose extlinux.  I have not loaded any extensions yet.  Upon exit of flwm via logout:shut down:no backup, it states:

sh: quiet: unknown operand

Here is the content of my stats.txt:

Code: [Select]
processor : 0
vendor_id : GenuineTMx86
cpu family : 5
model : 4
model name : Transmeta(tm) Crusoe(tm) Processor TM5800
stepping : 3
cpu MHz : 731.566
cache size : 512 KB
fdiv_bug : no
hlt_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 1
wp : yes
flags : fpu vme de pse tsc msr cx8 sep cmov mmx longrun lrti constant_tsc up
bogomips : 1463.09
clflush size : 32
power management:

MemTotal:         499016 kB
MemFree:          463428 kB
Buffers:              16 kB
Cached:            17904 kB
SwapCached:            0 kB
Active:            25872 kB
Inactive:             32 kB
Active(anon):      25864 kB
Inactive(anon):        0 kB
Active(file):          8 kB
Inactive(file):       32 kB
Unevictable:           0 kB
Mlocked:               0 kB
HighTotal:             0 kB
HighFree:              0 kB
LowTotal:         499016 kB
LowFree:          463428 kB
SwapTotal:             0 kB
SwapFree:              0 kB
Dirty:                 0 kB
Writeback:             0 kB
AnonPages:          7988 kB
Mapped:             3488 kB
Slab:               7960 kB
SReclaimable:       3740 kB
SUnreclaim:         4220 kB
PageTables:          160 kB
NFS_Unstable:          0 kB
Bounce:                0 kB
WritebackTmp:          0 kB
CommitLimit:      249508 kB
Committed_AS:      27876 kB
VmallocTotal:     524344 kB
VmallocUsed:         232 kB
VmallocChunk:     523392 kB
DirectMap4k:        8128 kB
DirectMap4M:      499712 kB
eth0      Link encap:Ethernet  HWaddr 00:0F:20:D9:A9:23  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:15 Base address:0xc000

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:12 errors:0 dropped:0 overruns:0 frame:0
          TX packets:12 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:600 (600.0 B)  TX bytes:600 (600.0 B)

squashfs 11732 0 - Live 0xdf833000
scsi_wait_scan 260 0 - Live 0xdf826000
serio_raw 2240 0 - Live 0xdf819000
via_rhine 12476 0 - Live 0xdf8b2000
parport_pc 18352 0 - Live 0xdf893000
parport 18768 1 parport_pc, Live 0xdf856000
PID   USER     COMMAND
    1 root     init      
    2 root     [kthreadd]
    3 root     [migration/0]
    4 root     [ksoftirqd/0]
    5 root     [events/0]
    6 root     [work_on_cpu/0]
    7 root     [khelper]
    8 root     [kblockd/0]
    9 root     [kacpid]
   10 root     [kacpi_notify]
   11 root     [ata/0]
   12 root     [ata_aux]
   13 root     [ksuspend_usbd]
   14 root     [khubd]
   15 root     [kseriod]
   17 root     [pdflush]
   18 root     [pdflush]
   19 root     [kswapd0]
   20 root     [aio/0]
   21 root     [nfsiod]
   36 root     [kpsmoused]
   37 root     [hid_compat]
   40 root     [rpciod/0]
   66 root     /sbin/udevd --daemon
 1174 tc       -sh
 1232 root     Xvesa -br -screen 1024x768x32 -shadow -mouse /dev/input/mice,5 -nolisten tcp -I
 1248 tc       flwm
 1253 tc       wbar -bpress -config /usr/local/tce.wbar
 1270 root     /sbin/udhcpc -b -i eth0 -h box -p /var/run/udhcpc.eth0.pid
 1271 tc       /usr/bin/cpanel
 1272 tc       [sh]
 1284 tc       stats
 1300 tc       sh -c ps ax | tee /tmp/stats.txt >> stats.txt
 1301 tc       ps ax
 1302 tc       tee /tmp/stats.txt
Linux version 2.6.29.1-tinycore (root@box) (gcc version 4.2.2) #1337 SMP Fri Apr 10 19:12:39 EEST 2009
KERNEL supported cpus:
  Intel GenuineIntel
  AMD AuthenticAMD
  NSC Geode by NSC
  Cyrix CyrixInstead
  Centaur CentaurHauls
  Transmeta GenuineTMx86
  Transmeta TransmetaCPU
  UMC UMC UMC UMC
PAT not supported by CPU.
BIOS-provided physical RAM map:
 BIOS-e820: 0000000000000000 - 000000000009b000 (usable)
 BIOS-e820: 000000000009b000 - 00000000000a0000 (reserved)
 BIOS-e820: 00000000000f0000 - 0000000000100000 (reserved)
 BIOS-e820: 0000000000100000 - 000000001eff0000 (usable)
 BIOS-e820: 000000001eff0000 - 000000001eff3000 (ACPI NVS)
 BIOS-e820: 000000001eff3000 - 000000001f000000 (ACPI data)
 BIOS-e820: 00000000ffff0000 - 0000000100000000 (reserved)
DMI 2.3 present.
Phoenix BIOS detected: BIOS may corrupt low RAM, working around it.
last_pfn = 0x1eff0 max_arch_pfn = 0x100000
kernel direct mapping tables up to 1eff0000 @ 10000-15000
RAMDISK: 1e79e000 - 1efee0a9
ACPI: RSDP 000F62A0, 0014 (r0 I-BASE)
ACPI: RSDT 1EFF3000, 0028 (r1 I-BASE AWRDACPI 42302E31 AWRD        0)
ACPI: FACP 1EFF3040, 0074 (r1 I-BASE AWRDACPI 42302E31 AWRD        0)
FADT: X_PM1a_EVT_BLK.bit_width (16) does not match PM1_EVT_LEN (4)
ACPI: DSDT 1EFF30C0, 1A71 (r1 I-BASE AWRDACPI     1000 MSFT  100000E)
ACPI: FACS 1EFF0000, 0040
0MB HIGHMEM available.
495MB LOWMEM available.
  mapped low ram: 0 - 1eff0000
  low ram: 00000000 - 1eff0000
  bootmap 00011000 - 00014e00
(9 early reservations) ==> bootmem [0000000000 - 001eff0000]
  #0 [0000000000 - 0000001000]   BIOS data page ==> [0000000000 - 0000001000]
  #1 [0000001000 - 0000002000]    EX TRAMPOLINE ==> [0000001000 - 0000002000]
  #2 [0000006000 - 0000007000]       TRAMPOLINE ==> [0000006000 - 0000007000]
  #3 [0000100000 - 0000528674]    TEXT DATA BSS ==> [0000100000 - 0000528674]
  #4 [001e79e000 - 001efee0a9]          RAMDISK ==> [001e79e000 - 001efee0a9]
  #5 [0000529000 - 000052c000]    INIT_PG_TABLE ==> [0000529000 - 000052c000]
  #6 [000009b000 - 0000100000]    BIOS reserved ==> [000009b000 - 0000100000]
  #7 [0000010000 - 0000011000]          PGTABLE ==> [0000010000 - 0000011000]
  #8 [0000011000 - 0000015000]          BOOTMAP ==> [0000011000 - 0000015000]
Zone PFN ranges:
  DMA      0x00000010 -> 0x00001000
  Normal   0x00001000 -> 0x0001eff0
  HighMem  0x0001eff0 -> 0x0001eff0
Movable zone start PFN for each node
early_node_map[2] active PFN ranges
    0: 0x00000010 -> 0x0000009b
    0: 0x00000100 -> 0x0001eff0
On node 0 totalpages: 126843
free_area_init_node: node 0, pgdat c0450d80, node_mem_map c1000200
  DMA zone: 32 pages used for memmap
  DMA zone: 0 pages reserved
  DMA zone: 3947 pages, LIFO batch:0
  Normal zone: 960 pages used for memmap
  Normal zone: 121904 pages, LIFO batch:31
ACPI: PM-Timer IO Port: 0x4008
SMP: Allowing 1 CPUs, 0 hotplug CPUs
No local APIC present or hardware disabled
nr_irqs_gsi: 16
PM: Registered nosave memory: 000000000009b000 - 00000000000a0000
PM: Registered nosave memory: 00000000000a0000 - 00000000000f0000
PM: Registered nosave memory: 00000000000f0000 - 0000000000100000
Allocating PCI resources starting at 20000000 (gap: 1f000000:e0ff0000)
NR_CPUS:8 nr_cpumask_bits:8 nr_cpu_ids:1 nr_node_ids:1
PERCPU: Allocating 32768 bytes of per cpu data
Built 1 zonelists in Zone order, mobility grouping on.  Total pages: 125851
Kernel command line: initrd=/tce/tinycore.gz quiet noswap tce=hda1/tce max_loop=255 waitusb=5 tce=UUID="8420c823-3288-44f7-bd4f-10d858f504a0" BOOT_IMAGE=/tce/bzImage
Initializing CPU#0
PID hash table entries: 2048 (order: 11, 8192 bytes)
Fast TSC calibration failed
TSC: PIT calibration matches PMTIMER. 2 loops
Detected 731.566 MHz processor.
Console: colour VGA+ 80x25
console [tty0] enabled
Dentry cache hash table entries: 65536 (order: 6, 262144 bytes)
Inode-cache hash table entries: 32768 (order: 5, 131072 bytes)
Memory: 489956k/507840k available (2433k kernel code, 17228k reserved, 1088k data, 344k init, 0k highmem)
virtual kernel memory layout:
    fixmap  : 0xfff50000 - 0xfffff000   ( 700 kB)
    pkmap   : 0xff800000 - 0xffc00000   (4096 kB)
    vmalloc : 0xdf7f0000 - 0xff7fe000   ( 512 MB)
    lowmem  : 0xc0000000 - 0xdeff0000   ( 495 MB)
      .init : 0xc0477000 - 0xc04cd000   ( 344 kB)
      .data : 0xc0360468 - 0xc04707b0   (1088 kB)
      .text : 0xc0100000 - 0xc0360468   (2433 kB)
Checking if this processor honours the WP bit even in supervisor mode...Ok.
Calibrating delay loop (skipped), value calculated using timer frequency.. 1463.09 BogoMIPS (lpj=2438553)
Mount-cache hash table entries: 512
CPU: L1 I Cache: 64K (64 bytes/line), D cache 64K (32 bytes/line)
CPU: L2 Cache: 512K (128 bytes/line)
CPU: Processor revision 1.4.1.0, 733 MHz
CPU: Code Morphing Software revision 4.4.1-10-125
CPU: 20030401 14:19 official release 4.4.1#4
CPU serial number disabled.
Checking 'hlt' instruction... OK.
SMP alternatives: switching to UP code
Freeing SMP alternatives: 9k freed
ACPI: Core revision 20081204
ACPI: setting ELCR to 0200 (from 8e00)
weird, boot CPU (#0) not listed by the BIOS.
SMP motherboard not detected.
Local APIC not detected. Using dummy APIC emulation.
SMP disabled
Brought up 1 CPUs
Total of 1 processors activated (1463.09 BogoMIPS).
net_namespace: 944 bytes
NET: Registered protocol family 16
ACPI: bus type pci registered
PCI: PCI BIOS revision 2.10 entry at 0xfa2e0, last bus=0
PCI: Using configuration type 1 for base access
bio: create slab <bio-0> at 0
ACPI: EC: Look up EC in DSDT
ACPI: Interpreter enabled
ACPI: (supports S0 S5)
ACPI: Using PIC for interrupt routing
ACPI: No dock devices found.
ACPI: PCI Root Bridge [PCI0] (0000:00)
pci 0000:00:00.0: reg 10 32bit mmio: [0xe2000000-0xe20fffff]
pci 0000:00:0d.0: reg 10 32bit mmio: [0xe0000000-0xe0ffffff]
pci 0000:00:0d.0: reg 14 io port: [0xd000-0xd0ff]
pci 0000:00:0d.0: reg 18 32bit mmio: [0xe2100000-0xe2100fff]
pci 0000:00:0d.0: reg 30 32bit mmio: [0x000000-0x01ffff]
pci 0000:00:0d.0: supports D1 D2
pci 0000:00:11.1: reg 20 io port: [0xd400-0xd40f]
pci 0000:00:11.2: reg 20 io port: [0xd800-0xd81f]
pci 0000:00:11.3: reg 20 io port: [0xdc00-0xdc1f]
pci 0000:00:11.5: reg 10 io port: [0xe000-0xe0ff]
pci 0000:00:11.5: reg 14 io port: [0xe400-0xe403]
pci 0000:00:11.5: reg 18 io port: [0xe800-0xe803]
pci 0000:00:12.0: reg 10 io port: [0xec00-0xecff]
pci 0000:00:12.0: reg 14 32bit mmio: [0xe2101000-0xe21010ff]
pci 0000:00:12.0: supports D1 D2
pci 0000:00:12.0: PME# supported from D0 D1 D2 D3hot D3cold
pci 0000:00:12.0: PME# disabled
pci_bus 0000:00: on NUMA node 0
ACPI: PCI Interrupt Routing Table [\_SB_.PCI0._PRT]
ACPI: PCI Interrupt Link [LNKA] (IRQs 1 3 4 5 6 7 10 11 12 14 *15)
ACPI: PCI Interrupt Link [LNKB] (IRQs 1 3 4 5 6 7 10 11 12 14 15) *0, disabled.
ACPI: PCI Interrupt Link [LNKC] (IRQs 1 3 4 5 6 7 *10 11 12 14 15)
ACPI: PCI Interrupt Link [LNKD] (IRQs 1 3 4 5 6 7 10 *11 12 14 15)
SCSI subsystem initialized
libata version 3.00 loaded.
usbcore: registered new interface driver usbfs
usbcore: registered new interface driver hub
usbcore: registered new device driver usb
PCI: Using ACPI for IRQ routing
pnp: PnP ACPI init
ACPI: bus type pnp registered
pnp: PnP ACPI: found 10 devices
ACPI: ACPI bus type pnp unregistered
PnPBIOS: Disabled by ACPI PNP
system 00:00: iomem range 0xd2000-0xd3fff has been reserved
system 00:00: iomem range 0xf0000-0xf7fff could not be reserved
system 00:00: iomem range 0xf8000-0xfbfff could not be reserved
system 00:00: iomem range 0xfc000-0xfffff could not be reserved
system 00:00: iomem range 0x1eff0000-0x1effffff could not be reserved
system 00:00: iomem range 0xffff0000-0xffffffff has been reserved
system 00:00: iomem range 0x0-0x9ffff could not be reserved
system 00:00: iomem range 0x100000-0x1efeffff could not be reserved
system 00:00: iomem range 0xfee00000-0xfee00fff has been reserved
system 00:02: ioport range 0x4d0-0x4d1 has been reserved
pci_bus 0000:00: resource 0 io:  [0x00-0xffff]
pci_bus 0000:00: resource 1 mem: [0x000000-0xffffffff]
NET: Registered protocol family 2
IP route cache hash table entries: 4096 (order: 2, 16384 bytes)
TCP established hash table entries: 16384 (order: 5, 131072 bytes)
TCP bind hash table entries: 16384 (order: 5, 131072 bytes)
TCP: Hash tables configured (established 16384 bind 16384)
TCP reno registered
NET: Registered protocol family 1
checking if image is initramfs...<7>Switched to high resolution mode on CPU 0
 it is
Freeing initrd memory: 8512k freed
fuse init (API version 7.11)
msgmni has been set to 973
alg: No test for stdrng (krng)
io scheduler noop registered
io scheduler deadline registered (default)
pci 0000:00:0d.0: Boot video device
input: Power Button (FF) as /devices/LNXSYSTM:00/LNXPWRBN:00/input/input0
ACPI: Power Button (FF) [PWRF]
input: Sleep Button (FF) as /devices/LNXSYSTM:00/LNXSLPBN:00/input/input1
ACPI: Sleep Button (FF) [SLPF]
input: Power Button (CM) as /devices/LNXSYSTM:00/device:00/PNP0C0C:00/input/input2
ACPI: Power Button (CM) [PWRB]
ACPI: CPU0 (power states: C1[C1] C2[C2])
processor ACPI_CPU:00: registered as cooling_device0
ACPI: Processor [CPU0] (supports 2 throttling states)
isapnp: Scanning for PnP cards...
isapnp: No Plug & Play device found
Real Time Clock Driver v1.12b
Non-volatile memory driver v1.3
Serial: 8250/16550 driver, 4 ports, IRQ sharing disabled
serial8250: ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
00:07: ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
Floppy drive(s): fd0 is unknown type 15 (usb?), fd1 is unknown type 13 (usb?)
floppy0: no floppy controllers found
brd: module loaded
loop: loaded (max 255 devices)
PPP generic driver version 2.4.2
PPP Deflate Compression module registered
NET: Registered protocol family 24
tun: Universal TUN/TAP device driver, 1.6
tun: (C) 1999-2004 Max Krasnyansky <maxk@qualcomm.com>
Uniform Multi-Platform E-IDE driver
via82cxxx 0000:00:11.1: VIA vt8231 (rev 10) IDE UDMA100
via82cxxx 0000:00:11.1: IDE controller (0x1106:0x0571 rev 0x06)
via82cxxx 0000:00:11.1: IDE port disabled
via82cxxx 0000:00:11.1: not 100% native mode: will probe irqs later
    ide0: BM-DMA at 0xd400-0xd407
Probing IDE interface ide0...
hda: 32MB ATA Flash Disk, CFA DISK drive
hda: host max PIO5 wanted PIO255(auto-tune) selected PIO4
hda: host max PIO5 wanted PIO255(auto-tune) selected PIO4
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
ide_generic: please use "probe_mask=0x3f" module parameter for probing all legacy ISA IDE ports
ide-gd driver 1.18
hda: max request size: 128KiB
hda: 62592 sectors (32 MB) w/1KiB Cache, CHS=489/4/32
 hda: hda1
ide-cd driver 5.00
Driver 'sd' needs updating - please use bus_type methods
ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver
uhci_hcd: USB Universal Host Controller Interface driver
ACPI: PCI Interrupt Link [LNKD] enabled at IRQ 11
PCI: setting IRQ 11 as level-triggered
uhci_hcd 0000:00:11.2: PCI INT D -> Link[LNKD] -> GSI 11 (level, low) -> IRQ 11
uhci_hcd 0000:00:11.2: UHCI Host Controller
uhci_hcd 0000:00:11.2: new USB bus registered, assigned bus number 1
uhci_hcd 0000:00:11.2: irq 11, io base 0x0000d800
usb usb1: configuration #1 chosen from 1 choice
hub 1-0:1.0: USB hub found
hub 1-0:1.0: 2 ports detected
uhci_hcd 0000:00:11.3: PCI INT D -> Link[LNKD] -> GSI 11 (level, low) -> IRQ 11
uhci_hcd 0000:00:11.3: UHCI Host Controller
uhci_hcd 0000:00:11.3: new USB bus registered, assigned bus number 2
uhci_hcd 0000:00:11.3: irq 11, io base 0x0000dc00
usb usb2: configuration #1 chosen from 1 choice
hub 2-0:1.0: USB hub found
hub 2-0:1.0: 2 ports detected
Initializing USB Mass Storage driver...
usbcore: registered new interface driver usb-storage
USB Mass Storage support registered.
PNP: No PS/2 controller found. Probing ports directly.
serio: i8042 KBD port at 0x60,0x64 irq 1
serio: i8042 AUX port at 0x60,0x64 irq 12
mice: PS/2 mouse device common for all mice
cpuidle: using governor ladder
cpuidle: using governor menu
padlock: VIA PadLock not detected.
padlock: VIA PadLock Hash Engine not detected.
usbcore: registered new interface driver hiddev
usbcore: registered new interface driver usbhid
usbhid: v2.6:USB HID core driver
ip_tables: (C) 2000-2006 Netfilter Core Team
TCP cubic registered
NET: Registered protocol family 17
NET: Registered protocol family 15
RPC: Registered udp transport module.
RPC: Registered tcp transport module.
IO APIC resources could be not be allocated.
Using IPI No-Shortcut mode
Freeing unused kernel memory: 344k freed
usb 1-1: new full speed USB device using uhci_hcd and address 2
usb 1-1: configuration #1 chosen from 1 choice
usb 1-2: new low speed USB device using uhci_hcd and address 3
usb 1-2: configuration #1 chosen from 1 choice
input: Microsoft Microsoft Notebook/Mobile Optical Mouse 2.0 as /devices/pci0000:00/0000:00:11.2/usb1/1-2/1-2:1.0/input/input3
generic-usb 0003:045E:007D.0001: input: USB HID v1.10 Mouse [Microsoft Microsoft Notebook/Mobile Optical Mouse 2.0] on usb-0000:00:11.2-2/input0
usb 2-1: new full speed USB device using uhci_hcd and address 2
usb 2-1: configuration #1 chosen from 1 choice
hub 2-1:1.0: USB hub found
hub 2-1:1.0: 3 ports detected
usb 2-1.1: new low speed USB device using uhci_hcd and address 3
usb 2-1.1: configuration #1 chosen from 1 choice
input: Alps Electric Apple USB Keyboard as /devices/pci0000:00/0000:00:11.3/usb2/2-1/2-1.1/2-1.1:1.0/input/input4
generic-usb 0003:05AC:0201.0002: input: USB HID v1.00 Keyboard [Alps Electric Apple USB Keyboard] on usb-0000:00:11.3-1.1/input0
parport_pc: VIA 686A/8231 detected
parport_pc: probing current configuration
parport_pc: Current parallel port base: 0x378
parport0: PC-style at 0x378, irq 7 [PCSPP,TRISTATE,EPP]
parport_pc: VIA parallel port: io=0x378, irq=7
via-rhine.c:v1.10-LK1.4.3 2007-03-06 Written by Donald Becker
ACPI: PCI Interrupt Link [LNKA] enabled at IRQ 15
PCI: setting IRQ 15 as level-triggered
via-rhine 0000:00:12.0: PCI INT A -> Link[LNKA] -> GSI 15 (level, low) -> IRQ 15
eth0: VIA Rhine II at 0xe2101000, 00:0f:20:d9:a9:23, IRQ 15.
eth0: MII PHY found at address 1, status 0x7849 advertising 05e1 Link 0000.
Marking TSC unstable due to TSC halts in idle
squashfs: version 4.0 (2009/01/31) Phillip Lougher
eth0: link down
rootfs on / type rootfs (rw)
tmpfs on / type tmpfs (rw,size=449116k)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
devpts on /dev/pts type devpts (rw,mode=600)
tmpfs on /dev/shm type tmpfs (rw)
/dev/hda1 on /mnt/hda1 type ext2 (rw,nosuid,nodev,relatime,errors=continue)
Filesystem                Size      Used Available Use% Mounted on
tmpfs                   438.6M     17.8M    420.8M   4% /
tmpfs                   243.7M         0    243.7M   0% /dev/shm
/dev/hda1                29.6M     10.7M     18.9M  36% /mnt/hda1
initrd=/tce/tinycore.gz
quiet
noswap
tce=hda1/tce
max_loop=255
waitusb=5
tce=UUID="8420c823-3288-44f7-bd4f-10d858f504a0"
BOOT_IMAGE=/tce/bzImage

I'd be happy to provide any further information you might like.  As I said before, the error seems harmless and I'm not bothered by it.

Thanks for your time.
« Last Edit: October 13, 2009, 07:22:25 PM by 3rail »

Offline roberts

  • Administrator
  • Hero Member
  • *****
  • Posts: 7361
  • Founder Emeritus
Re: odd message on shutdown
« Reply #3 on: October 14, 2009, 06:24:47 AM »
Quote
tce=hda1/tce
max_loop=255
waitusb=5
tce=UUID="8420c823-3288-44f7-bd4f-10d858f504a0"

Seems that you have the tce option listed twice, only one is needed, likely just the UUID one as it was the one actually used during bootiing.

Not sure that this would cause your shhh quiet issue
10+ Years Contributing to Linux Open Source Projects.

Offline 3rail

  • Full Member
  • ***
  • Posts: 113
Re: odd message on shutdown
« Reply #4 on: October 14, 2009, 06:28:40 AM »
good point.  using usbinstall, I specified the tce= parameter, not knowing that usbinstall did that for me automatically.

thanks!

Offline 3rail

  • Full Member
  • ***
  • Posts: 113
Re: odd message on shutdown
« Reply #5 on: October 14, 2009, 06:46:40 AM »
removal of the extra tce= parameter doesn't yield any effect on the 'quiet' message.  where does the shutdown script live?

Offline danielibarnes

  • Hero Member
  • *****
  • Posts: 548
Re: odd message on shutdown
« Reply #6 on: October 14, 2009, 10:32:37 AM »
The error message you see is generated by line 12 of /etc/init.d/rc.shutdown:
if [ !$(grep "noswap" /proc/cmdline) ]; then

In your case, this expands to:
if [ !initrd=/tce/tinycore.gz quiet noswap tce=hda1/tce max_loop=255 waitusb=5 ... ]; then

which leads to incorrect syntax for the if statement. It is usually expressed as:
if ! checkbootparam noswap; then

This message isn't entirely harmless as it means the swapoff code will never be executed on shutdown. I'm not sure what the consequences of that are.
« Last Edit: October 14, 2009, 10:35:33 AM by danielibarnes »

Offline gerald_clark

  • TinyCore Moderator
  • Hero Member
  • *****
  • Posts: 4254
Re: odd message on shutdown
« Reply #7 on: October 14, 2009, 10:54:47 AM »
That line could be changed to:
if ! grep -q "noswap" /proc/cmdline ; then

Offline danielibarnes

  • Hero Member
  • *****
  • Posts: 548
Re: odd message on shutdown
« Reply #8 on: October 14, 2009, 11:21:54 AM »
That line could be changed to:
if ! grep -q "noswap" /proc/cmdline ; then

It appears that was the author's original intent. I considered that as well, but checkbootparam uses shell script. It does not require an external program invocation, making it simpler and faster.

Offline 3rail

  • Full Member
  • ***
  • Posts: 113
Re: odd message on shutdown
« Reply #9 on: October 19, 2009, 06:52:11 AM »
@roberts, is there a chance this fix could make the next RC?

Offline roberts

  • Administrator
  • Hero Member
  • *****
  • Posts: 7361
  • Founder Emeritus
Re: odd message on shutdown
« Reply #10 on: October 19, 2009, 10:02:20 AM »
It is in there!
10+ Years Contributing to Linux Open Source Projects.

Offline 3rail

  • Full Member
  • ***
  • Posts: 113
Re: odd message on shutdown
« Reply #11 on: October 19, 2009, 10:30:31 AM »
Ok, thanks.

later...

1. removing noswap boot parameter relieves the 'sh: quiet: operand not found' shutdown error message

2. replacing line 12 of /etc/init.d/rc.shutdown with

Code: [Select]
if ! grep -q "noswap" /proc/cmdline ; then
also allows me to use the noswap boot parameter without seeing the 'sh: quiet: operand not found' shutdown error message

Big thanks all!
« Last Edit: October 20, 2009, 12:14:00 PM by 3rail »

Offline ^thehatsrule^

  • Administrator
  • Hero Member
  • *****
  • Posts: 1726
Re: odd message on shutdown
« Reply #12 on: October 20, 2009, 10:46:50 PM »
Just to be precise, using grep -w (for words) would probably be better.

Offline 3rail

  • Full Member
  • ***
  • Posts: 113
Re: odd message on shutdown
« Reply #13 on: October 21, 2009, 07:30:27 AM »
I've updated it to say

Code: [Select]
if ! grep -q -w "noswap" /proc/cmdline ; then
tested, works well