WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: eeePC 900A  (Read 7316 times)

Offline roberts

  • Administrator
  • Hero Member
  • *****
  • Posts: 7361
  • Founder Emeritus
eeePC 900A
« on: October 07, 2009, 07:47:06 PM »
Quote
What would it take to modify this for the eeepc 900a which uses the Atheros AR5007EG
See the eeePC S101 topic, http://forum.tinycorelinux.net/index.php?topic=3234.0,
The 900a and S101 have the same wireless. I once owned a 900a and tinycore wireless worked fine, both WEP and WPA.

 wireless-2.6.29-1-tinycore.tczm &  wireless_tools.tczl
« Last Edit: December 07, 2009, 08:45:43 PM by roberts »
10+ Years Contributing to Linux Open Source Projects.

Offline julianb

  • WikiUser
  • *
  • Posts: 41
Re: eeePC 900A
« Reply #1 on: December 04, 2009, 03:14:24 PM »
I just successfully set up tinycorelinux to use wifi, Opera with flash player, sound, (that is, youtube works) and other basic functions for my eeepc 900A.

It seems as though some apps have support for other languages - any advice on how to quickly switch this machine to French wherever translations are available? I set it up 100% in english / US so far but I want to change it.

(apps installed are gnumeric, abiword, opera, emelfm, wicd. though wicd doesn't work for some reason, I have to use the command line to connect to wireless networking)

Offline bmarkus

  • Administrator
  • Hero Member
  • *****
  • Posts: 7003
    • My Community Forum
Re: eeePC 900A
« Reply #2 on: December 04, 2009, 10:43:56 PM »
(apps installed are gnumeric, abiword, opera, emelfm, wicd. though wicd doesn't work for some reason, I have to use the command line to connect to wireless networking)

Can you provide details what is happening when you start WICD, what type of network you are conencting?
Béla
Ham Radio callsign: HA5DI

"Amateur Radio: The First Technology-Based Social Network."

Offline julianb

  • WikiUser
  • *
  • Posts: 41
Re: eeePC 900A
« Reply #3 on: December 06, 2009, 10:11:25 AM »
I'm connecting to an unsecured wireless network, which has worked very easily for me on many linux and windows machines. The message I get is "Could not connect to wicd's D-Bus interface. Check the wicd log for error messages."

I don't know where the wicd log is.

Offline bmarkus

  • Administrator
  • Hero Member
  • *****
  • Posts: 7003
    • My Community Forum
Re: eeePC 900A
« Reply #4 on: December 07, 2009, 12:01:18 AM »
I'm connecting to an unsecured wireless network, which has worked very easily for me on many linux and windows machines. The message I get is "Could not connect to wicd's D-Bus interface. Check the wicd log for error messages."

I don't know where the wicd log is.

Message indicates that D-Bus daemon is not running. Did you start wicd as it is in the info file?

Quote

Run 'wicd-start' as root to start wicd daemon


This command starts all necessary services required by WICD if they are not running, like D-Bus and HAL.

If you are connecting to an open network, you can try wifi-radar also if you are looking for a GUI or using few basic commands. For details see WIKI article

http://wiki.tinycorelinux.com/tiki-index.php?page=Setting+up+Wifi
« Last Edit: December 07, 2009, 12:05:42 AM by bmarkus »
Béla
Ham Radio callsign: HA5DI

"Amateur Radio: The First Technology-Based Social Network."

Offline OldAdamUser2

  • Full Member
  • ***
  • Posts: 199
Re: eeePC 900A
« Reply #5 on: December 07, 2009, 05:55:17 AM »
Here is the easy way to automate connection to wifi. click on Aterm (the screen button at the bottom-center of your display) and type in "sudo mc" without the parentheses. This will open Midnight Commander your file-manager/file-editor. Find your way to the /opt directory and highlight the bootlocal.sh file. This is a file that automatically executes commands every time you reboot your computer. Enter the following lines:
________________________________________
         sudo iwconfig wlan0 essid any
          sudo udhpc -i wlan0
___________________________________________________

    Push F2 to save the changes you have made to bootlocal.sh. (If the script doesn't work, you may need to change wlan0 to ath0.) The first two commands assume that you are going to be using a public wifi signal (i.e., no password needed). If you will normally be using a password-protected network, you can modify the lines appropriately. For example, to connect automatically to a wep-wifi, you will need the following:
__________________________________________________
         sudo iwconfig wlan0 essid your-essid-name
          sudo iwconfig wlan0 mode managed key your-password
          sudo udhdpc -i wlan0
« Last Edit: December 07, 2009, 05:58:14 AM by OldAdamUser2 »

Offline julianb

  • WikiUser
  • *
  • Posts: 41
Re: eeePC 900A
« Reply #6 on: December 07, 2009, 08:01:07 PM »
Thanks. I have now successfully used this machine (the 900A) to connect to wireless with and without WEP encryption, using wireless-tools. WICD also works. (but i gather that putting sudo wicd-start in bootlocal.sh would be the way to make it work without having to do that command every time the machine starts)

I still have not succeeded in getting the realtek rtl 8187se wireless card to work on my eee pc 701sd. i'm trying to make ndiswrapper do the job. will let you know if it works.

Offline roberts

  • Administrator
  • Hero Member
  • *****
  • Posts: 7361
  • Founder Emeritus
Re: eeePC 900A
« Reply #7 on: December 07, 2009, 08:46:39 PM »
Command in /opt/bootlocal.sh run as user root. sudo is not needed.
10+ Years Contributing to Linux Open Source Projects.

Offline OldAdamUser2

  • Full Member
  • ***
  • Posts: 199
Re: eeePC 900A
« Reply #8 on: December 08, 2009, 03:34:29 PM »
Right you are, roberts! Thank you. Good code is clean, efficient code.

Offline gpiers

  • WikiUser
  • *
  • Posts: 2
Re: eeePC 900A
« Reply #9 on: January 23, 2010, 02:13:34 AM »
Hi first time posting,

I was trying tiny core on eee 900ha.
I managed to set the required static ip for my network (10.0.0.X) range.
Saved the configuration.

Then when I boot back into windows the wireless adapter cannot connect.  It even shows up as a different instance eg #2.
The adapter detects wireless network.

If I go back into tiny core I can't connect either.  Its as if the first time it locked the wireless adapter.

I have tried to boot into safe mode in windows and uninstall the #2 (device manager) and let it auto detect the wireless adapter next boot, but no joy.

newbielink:http://forums.techarena.in/xp-hardware/47055.htm [nonactive]



Any ideas on how I can solve this problem please?

Offline alu

  • Sr. Member
  • ****
  • Posts: 429
Re: eeePC 900A
« Reply #10 on: January 23, 2010, 09:58:42 AM »
in tinycore, try at the command line:

sudo ifconfig wlan0 up (i assume that wlan0 is the name of your wifi device)

then see if wlan0 is there with:

sudo iwconfig

if it is there, you can configure your device as you did it the first time; you can save your configuration by adding appropriate lines in your /opt/.filetool.lst and issuing a backup

in windows, you probably need to re-install the driver

Offline gpiers

  • WikiUser
  • *
  • Posts: 2
Re: eeePC 900A
« Reply #11 on: January 23, 2010, 06:05:50 PM »
Thank you very much for such a prompt reply -thilled.
I tried what you said in tiny core and I got a message that the wireless adapter couldn't be detected.  :-[

I then went back to widows googled a bit more and found
newbielink:http://wiki.eeeuser.com/howto:wireless_unexpected_stop [nonactive]

Oh Fix #1 Reboot the router -lets try that. (I was also doing yet another clean install -to be sure!)

Rebooting the router worked - just chose my network, entered the key and all was good.

Thank you again for the response.  I look forward to having another play with tiny core soon. I really love what I've seen so far -Cheers