WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: eeePC 1000  (Read 9595 times)

Offline vkcbo

  • WikiUser
  • *
  • Posts: 4
Tiny Core on eeePC 1000
« Reply #15 on: October 07, 2009, 11:21:53 PM »
Hi Mike,
            Thank you for your work on the RT2860 tzc module.
            Is it still necessary to use;
                  wireless-2.6.29-1. tinycore tczm,
                  wireless-tools.tczl and
                  wl.tczm  ?

            My plan is to try your module on Tinycore 2.4 final when it is available.
                                                                 cheers,
                                                                            Rod



Online Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 12065
Tiny Core on eeePC 1000
« Reply #16 on: October 08, 2009, 12:06:47 AM »
wl  is the kernel module for broadcom wireless hardware, so if you're using RT2860,I don't think you'll need this.

Offline MikeLockmoore

  • Hero Member
  • *****
  • Posts: 503
  • Good software needn't be big!
Tiny Core on eeePC 1000
« Reply #17 on: October 08, 2009, 06:03:28 AM »
vkcbo:

Just to provide proper credit, I did not make the .tczm, Robert S. did.  I just compiled the .ko file used in the .tczm and helped test the .tczm. 

I find it convenient to use the iwconfig utility from wireless_tools.tczl, and it has a dep on wireless-2.6.29.1-tinycore.tczm.  Juanito is right: for the eeePC 1000, wl.tczm is not needed.

However, you might be able to avoid the wireless_tools.tczl and the --.tczm by modifying the hardware config file /etc/RT2860STA/RT2860STA.dat that is installed by the rt2860.tczm extension.  I think (but have not tried) that one can define the default connection parameters in this file and the driver will try to connect based on them when if first comes up.  If you try it, make a backup of it somewhere, edit it, and add

   etc/RT2860STA/RT2860STA.dat

to your /opt/.filetool.lst file to make the changes persistent.  Since I connect to different WLANs at different times, I prefer to have the iwconfig utility called through some convenience scripts, but maybe you can save some space and boot time by putting your settings in the .dat file.  If you do, let us know what works for you!
--
Mike L.

Offline chexmix

  • WikiUser
  • *
  • Posts: 14
    • burning clown
Tiny Core on eeePC 1000
« Reply #18 on: October 08, 2009, 07:52:57 AM »
I have TC working very very happily on an eeePC 1000HE.  :D

Tried out wireless this morning and got it working even though wireless is one of my many technical "blind spots."

Great work, all.

Offline roberts

  • Administrator
  • Hero Member
  • *****
  • Posts: 7361
  • Founder Emeritus
Tiny Core on eeePC 1000
« Reply #19 on: October 08, 2009, 11:32:53 AM »
Mike,
I need a .info file and source before I post rt2860.tczm in the repository.
I have sent a sample .info for you to complete.
10+ Years Contributing to Linux Open Source Projects.

Offline roberts

  • Administrator
  • Hero Member
  • *****
  • Posts: 7361
  • Founder Emeritus
Re: eeePC 1000
« Reply #20 on: October 08, 2009, 08:33:34 PM »
The rt2860 wireless support for eeePC 1000 is now posted!
See: http://forum.tinycorelinux.net/index.php?topic=3293.msg17222#msg17222
10+ Years Contributing to Linux Open Source Projects.

Offline jur

  • Hero Member
  • *****
  • Posts: 863
    • cycling photo essays
Re: eeePC 1000
« Reply #21 on: October 11, 2009, 03:51:38 AM »
I have tc_2.4.1 running with Xorg with an attached 1600x900 monitor on my 1000HE (atom version).

Attached is my xorg.conf file. (I had to haul the relevant sections from puppylinux and mod the file created by Xorg -configure.

I'm a happy puppy!  Err make that happy tc-er... :P

Offline argos3016

  • WikiUser
  • *
  • Posts: 9
Re: eeePC 1000
« Reply #22 on: February 15, 2010, 02:51:16 AM »
#!/bin/sh
# commands to associate with wireless access point
read -p "introduce essid>>> " essid
read -p "introduce key>>> " key
iwconfig
read -p "interface name>>> " interface
sudo /sbin/ifconfig "$interface" up
sudo /usr/local/sbin/iwconfig "$interface"  essid "$essid" key restricted "$key"
sleep 2
sudo /sbin/udhcpc -i "$interface"
sleep 7
# Fix up incorrect (SLOW!) resolv.conf content with a copy of resolv.conf with a real DNS IP!
sudo cp -f /home/tc/drivers/etc_resolv.conf /etc/resolv.conf~









only a suggestion!!