WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: fltk  (Read 2346 times)

Offline jpeters

  • Restricted
  • Hero Member
  • *****
  • Posts: 1017
fltk
« on: September 06, 2009, 10:41:20 AM »
I know we use fltk libs. Is there a compiler? Trying to compile fltk-1.1.9 from source gets

Code: [Select]
  3 checking for X... no
  4 configure: error: Configure could not find required X11 libraries
  5 ./configure: line 10538: exit: aborting.: numeric argument required
  6 ./configure: line 10538: exit: aborting.: numeric argument required

Offline roberts

  • Administrator
  • Hero Member
  • *****
  • Posts: 7361
  • Founder Emeritus
Re: fltk
« Reply #1 on: September 06, 2009, 10:51:54 AM »
I typically have Xorg dev extension loaded when compiling fltk items.
10+ Years Contributing to Linux Open Source Projects.

Offline jpeters

  • Restricted
  • Hero Member
  • *****
  • Posts: 1017
Re: fltk
« Reply #2 on: September 06, 2009, 11:12:27 AM »
I typically have Xorg dev extension loaded when compiling fltk items.

Thanks, that's what it needed


edit: next problem.  It seems to want a "man" script to put together documentation; I haven't found a way to disable.  

edit:  Built a copy (I had to compile it in puppy); indeed, looks like just about everything is already installed...but I have an idea now of all the files involved in the original package ( and docs might be handy when learning). 
« Last Edit: September 06, 2009, 06:55:58 PM by jpeters »