WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: Tinycore 14.0 - libpcre2-8 error - PHP fpm  (Read 1233 times)

Offline pek

  • Full Member
  • ***
  • Posts: 111
Tinycore 14.0 - libpcre2-8 error - PHP fpm
« on: April 16, 2023, 07:09:35 PM »
Hi, after many failed attempts running nginx and php8, I finally found out that
libpcre2-8 cannot be loaded.

Turns out reinstalling pcre2.tcz solved this.

Just incase anyone needs to know  ;)

Offline andyj

  • Hero Member
  • *****
  • Posts: 1023
Re: Tinycore 14.0 - libpcre2-8 error - PHP fpm
« Reply #1 on: April 17, 2023, 03:17:24 AM »
Is this 32 bit or 64 bit? The pcre2 library names/versions are different.

Offline pek

  • Full Member
  • ***
  • Posts: 111
Re: Tinycore 14.0 - libpcre2-8 error - PHP fpm
« Reply #2 on: April 17, 2023, 03:50:12 AM »
It's Tinycore 32 bit.

To clarify...
PCRE2.TCZ was not initially installed. (No dependency requirement from any tcz i installed).
But PCRE.TCZ was.

Therefore libpcre2-8 was not found.
« Last Edit: April 17, 2023, 03:55:27 AM by pek »

Offline andyj

  • Hero Member
  • *****
  • Posts: 1023
Re: Tinycore 14.0 - libpcre2-8 error - PHP fpm
« Reply #3 on: April 17, 2023, 04:27:23 AM »
PHP library requirements tend to lag behind what's available, but the most recent versions I am testing all have pcre2 as a dependency so this should be resolved soon.

Offline pek

  • Full Member
  • ***
  • Posts: 111
Re: Tinycore 14.0 - libpcre2-8 error - PHP fpm
« Reply #4 on: May 11, 2023, 12:32:51 AM »
Yes I think it's updated to pcre2 now.