WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: qt5 error: 'numeric_limits' is not a class template with gcc-11  (Read 286 times)

Offline rhermsen

  • Jr. Member
  • **
  • Posts: 85
qt5 error: 'numeric_limits' is not a class template with gcc-11
« on: October 04, 2022, 02:44:33 PM »
Using qmake I get errors
Code: [Select]
/usr/local/include/qt5/QtCore/qfloat16.h:294:7: error: 'numeric_limits' is not a class template
Searching for these errors point to GCC-11 changes requiring #include <limits>

From the following I get that
https://bugs.gentoo.org/768342
https://bugs.gentoo.org/768354
https://bugs.gentoo.org/752012
QT-5 requires recompile with the patches.

The majority of the patches look to be in the following attachment:
https://752012.bugs.gentoo.org/attachment.cgi?id=681397



Can someone help with that?


Not sure if needed but also found the following patches referred to in the bug reports:   

kio-gcc11-limits.patch
Code: [Select]
diff -u -r a/src/kntlm/des.cpp b/src/kntlm/des.cpp
--- a/src/kntlm/des.cpp 2021-03-15 22:21:04.196943384 +1100
+++ b/src/kntlm/des.cpp 2021-03-15 21:43:53.852259629 +1100
@@ -26,10 +26,10 @@
 
 #include "des.h"
 
+#include <limits>
 #include <qendian.h>
 #include <string.h>
 
-#include <limits>
 
 static void permute_ip(unsigned char *inblock, DES_KEY *key, unsigned char *outblock);
 static void permute_fp(unsigned char *inblock, DES_KEY *key, unsigned char *outblock);


kwave.gcc11.limits.patch
Code: [Select]
--- ./plugins/codec_wav/WavDecoder.cpp.orig 2021-07-05 14:10:02.000000000 -0500
+++ ./plugins/codec_wav/WavDecoder.cpp 2021-08-05 11:47:18.353814614 -0500
@@ -18,6 +18,7 @@
 #include "config.h"
 #include <stdlib.h>
 #include <new>
+#include <limits>
 
 #include <audiofile.h>