WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: [Solved]: picore 13.1.0 X11-forwarding disabled  (Read 787 times)

Offline jab

  • Newbie
  • *
  • Posts: 5
[Solved]: picore 13.1.0 X11-forwarding disabled
« on: September 05, 2022, 11:06:59 AM »
Hi Team,

I installed picore 13.1.0 on my old Raspberry today. Previously, I was using Raspian OS lite but its response was not good for me.

When I connect to picore with Mobaxterm, I get following info with start of my session. It was enabled / available with Raspian OS

X11-forwarding  :  ?  (disabled or not supported by server)

I have edited  /usr/local/etc/ssh/ssh_config file and uncommented and enabled  - ForwardX11 yes.
Saving the file and adding it to /opt/.filetool.lst worked. After reboot, I can see the setting stays enabled

However X11-forwarding  still shows as disabled or not supported by server.

I want to connect to picore from my windows machine via Mobaxterm and launch browser via xterm. That way I can bypass restriction on my windows machine and browse youtube , gmail etc websites.

Any one else is doing similar setup / config ?

Please let me know how I can do this. Apologies  if this topic is covered some where else.

Regards,
Jab



« Last Edit: September 06, 2022, 08:00:56 AM by Rich »

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 14096
Re: picore 13.1.0 X11-forwarding disabled
« Reply #1 on: September 05, 2022, 11:23:46 AM »
Maybe I’m missing something here, but is x running on your piCore machine?

Offline jab

  • Newbie
  • *
  • Posts: 5
Re: picore 13.1.0 X11-forwarding disabled
« Reply #2 on: September 05, 2022, 11:44:11 AM »
Thanks Juanito for your reply.

I am new to this world so may be I am missing something basic.
I assumed it will be started by default. Any link/wiki for installing configuring Xserver on picore. I followed the GUi / Desktop steps and I assumed it will take care of it

I can see a process for Xorg

tc@box:~$ ps -ef |grep x
   38 root     [xprtiod]
  314 root     [ext4-rsv-conver]
 1286 root     /usr/local/lib/xorg/Xorg -nolisten tcp
 1295 root     /sbin/udhcpc -b -i eth0 -x hostname:box -p /var/run/udhcpc.eth0.pid
« Last Edit: September 05, 2022, 11:50:04 AM by jab »

Offline patrikg

  • Hero Member
  • *****
  • Posts: 515
Re: picore 13.1.0 X11-forwarding disabled
« Reply #3 on: September 05, 2022, 12:35:02 PM »
Maybe you could get something from this old thread:

http://forum.tinycorelinux.net/index.php/topic,16224.0.html

I just searched in the forum for xauth.

You can also install putty and xming on windows machine.
https://laptops.eng.uci.edu/engineering-software/using-linux/how-to-configure-putty-xming-on-your-laptop
« Last Edit: September 05, 2022, 12:45:23 PM by patrikg »

Offline CNK

  • Full Member
  • ***
  • Posts: 113
Re: picore 13.1.0 X11-forwarding disabled
« Reply #4 on: September 05, 2022, 04:18:25 PM »
I gather you want the browser to display on your Windows computer, not the Pi, so you don't need an X server running on PiCore, but you do want one running on Windows (that seems to be what MobaXterm is).

You've got Xorg running on the Pi, but that shouldn't harm anything, it's just not required. If MobaXterm works like OpenSSH then it should automatically export the DISPLAY environment variable so that programs are opened on the Windows computer's X server instead of Xorg on the Pi. Maybe try connecting without Xorg running on the Pi in case something's not working right with how MobaXterm does that.

Also if you have another computer running Linux and Xorg, try using "ssh -X" to do the same thing from that instead of the Windows computer, just to see whether the problem is specific to MobaXterm.
« Last Edit: September 05, 2022, 04:21:58 PM by CNK »

Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 10741
Re: picore 13.1.0 X11-forwarding disabled
« Reply #5 on: September 05, 2022, 10:05:39 PM »
It'd be lower overhead to use SSH's proxy instead of tunneling a whole app, assuming you have the permissions to set the proxy on your local Windows browsers.
The only barriers that can stop you are the ones you create yourself.

Offline jab

  • Newbie
  • *
  • Posts: 5
Re: picore 13.1.0 X11-forwarding disabled
« Reply #6 on: September 06, 2022, 05:31:06 AM »
It'd be lower overhead to use SSH's proxy instead of tunneling a whole app, assuming you have the permissions to set the proxy on your local Windows browsers.

That will not work for me. My WIndows laptop is locked via Zscaler. Mail , whatsapp , facebook etc is blocked.
I am surprised how this forum website is allowed  8)

Offline jab

  • Newbie
  • *
  • Posts: 5
Re: picore 13.1.0 X11-forwarding disabled
« Reply #7 on: September 06, 2022, 05:45:05 AM »
I gather you want the browser to display on your Windows computer, not the Pi, so you don't need an X server running on PiCore, but you do want one running on Windows (that seems to be what MobaXterm is).

You've got Xorg running on the Pi, but that shouldn't harm anything, it's just not required. If MobaXterm works like OpenSSH then it should automatically export the DISPLAY environment variable so that programs are opened on the Windows computer's X server instead of Xorg on the Pi. Maybe try connecting without Xorg running on the Pi in case something's not working right with how MobaXterm does that.

Also if you have another computer running Linux and Xorg, try using "ssh -X" to do the same thing from that instead of the Windows computer, just to see whether the problem is specific to MobaXterm.

Thanks CNK for your reply.
Yes, I want browser to display on windows computer. I was able to do it out of the box with Mobaxterm and Raspian OS Lite. But performance was not good, so I wanted to try with picore.

I will try with another linux machine over weekend and will post results here.

Thanks

Offline jab

  • Newbie
  • *
  • Posts: 5
Re: picore 13.1.0 X11-forwarding disabled
« Reply #8 on: September 06, 2022, 06:53:46 AM »
It'd be lower overhead to use SSH's proxy instead of tunneling a whole app, assuming you have the permissions to set the proxy on your local Windows browsers.

Many thanks for your tip Curaga. I spoke too soon.
I tried setting up a tunnel with putty and used that in firefox socks proxy.. and guess what it worked  8)

I was not aware of this option. Again thanks for your help.

It solves my issue to access blocked websites..so I think we can mark tis thread as resolved.

I will continue exploring tinycore and see what else I can do with it.

Thaks a ton guys.. you all are awesome