WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: LAMP environment  (Read 7387 times)

Offline MrToga

  • Full Member
  • ***
  • Posts: 142
LAMP environment
« on: April 14, 2022, 06:22:09 AM »
Hello i'm a newbie on tiny linux and I'm triyng to create a lamp environment on my rpi 2 with piCore v13.x and i do not find the apache, mariadb and php extension on the repo.

Can someone help me please

Thanks in advance.
It's fine

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 13997
Re: LAMP environment
« Reply #1 on: April 14, 2022, 08:35:01 AM »
Those extensions do not exist in the repo - you would need to compile them.

Offline MrToga

  • Full Member
  • ***
  • Posts: 142
Re: LAMP environment
« Reply #2 on: April 15, 2022, 12:05:38 AM »
Thank you for your response

How can i compile them (sorry i'm very new to linux) ?
It's fine

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 13997
Re: LAMP environment
« Reply #3 on: April 15, 2022, 12:12:34 AM »
If you look here: http://www.tinycorelinux.net/10.x/x86_64/tcz/src/php/

..there’s an example build script for php for x86_64 that could be adapted..

Offline MrToga

  • Full Member
  • ***
  • Posts: 142
Re: LAMP environment
« Reply #4 on: April 15, 2022, 12:50:40 AM »
I read the build script(what I could)but were can i execute this? (I have installed gcc.tcz and compiletcz i don't know if this can be of any use)
It's fine

Offline MrToga

  • Full Member
  • ***
  • Posts: 142
Re: LAMP environment
« Reply #5 on: April 15, 2022, 02:25:07 AM »
I have compiled php-7.4.0.tar.xz(this package can be find on the link you sent me earlier) on piCore     but when i run the configure script, he don't find the libxml-2.0 package.
So i tried to install the lixml2.tcz in the repo and create a symbolic link with the libxml2.so into libxml-2.0.
But he still doesn't find the package.
Any tought?
It's fine

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 13997
Re: LAMP environment
« Reply #6 on: April 15, 2022, 03:55:45 AM »
You need to load the libxml2-dev extension.

Offline MrToga

  • Full Member
  • ***
  • Posts: 142
Re: LAMP environment
« Reply #7 on: April 15, 2022, 04:13:40 AM »
It works ! thank you I also needed to load SQlite3-dev.tcz and now i was thinking if I import the apache2.4 extension from the piCore v9 into mine.

Is it possible or do i need to do the same thing as I did(if you have a link for the apache2.4 it would be nice).
It's fine

Offline Rich

  • Administrator
  • Hero Member
  • *****
  • Posts: 10363
Re: LAMP environment
« Reply #8 on: April 15, 2022, 04:23:59 AM »
Hi MrToga
A build script for Apache can be found here:
http://tinycorelinux.net/8.x/armv7/tcz/src/apache2.4/

Offline MrToga

  • Full Member
  • ***
  • Posts: 142
Re: LAMP environment
« Reply #9 on: April 15, 2022, 06:22:59 AM »
Thanks.
But is it ok if i use this extension for piCore v8 on my piCore v13.x?
It's fine

Offline MrToga

  • Full Member
  • ***
  • Posts: 142
Re: LAMP environment
« Reply #10 on: April 15, 2022, 07:46:18 AM »
I tried to compile apache with the link you send but when i ./configure i get an error that i don't have APR-util so i tried to install APR-util with the same link you send me.
But now when I ./configure the directory apr-util i have an error that said APR could not be located. Please use the --with-apr option but when i use the --with-apr piCore don't find any .shell.  Am I missing a file?
It's fine

Offline patrikg

  • Sr. Member
  • ****
  • Posts: 494
Re: LAMP environment
« Reply #11 on: April 15, 2022, 08:22:10 AM »
Do you need apache ?
I think it easier to make/compile a nginx extension.
And with PHP-FPM.

Offline Rich

  • Administrator
  • Hero Member
  • *****
  • Posts: 10363
Re: LAMP environment
« Reply #12 on: April 15, 2022, 08:49:09 AM »
Hi MrToga
... get an error that i don't have APR-util so i tried to install APR-util with the same link you send me. ...
No, install  apr-util-dev.tcz  from TC13:
Code: [Select]
tce-load -wi apr-util-dev.tcz

Offline MrToga

  • Full Member
  • ***
  • Posts: 142
Re: LAMP environment
« Reply #13 on: April 19, 2022, 01:32:28 AM »
Hello guys and thank for the help so far.

So when ./configure it worked fine but after reading the INSTALL file then told us to use the command make after ./configure but i get this error :

/bin/sh: /usr/local/build-1/libtool : not found

So i checked if libtool is there and it is.

Any tought ?
It's fine

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 13997
Re: LAMP environment
« Reply #14 on: April 19, 2022, 02:51:53 AM »
I’d guess you are missing perl5, python or bash.