WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: [Solved] Change screen resolution to 1280x800 from default 1024x768, how?  (Read 1507 times)

Offline puppybyte!

  • Jr. Member
  • **
  • Posts: 63
I have TC13, 32bit running on Dell Inspiron 1300 laptop.  In Bionicpup32 (puppylinux) the default screen resolution is 1280x800, but in TC my default xrandr setting is 1024x768.  Control Panel-Xvesa only gives upto 1024x768 but nothing higher (i.e. 1280x800).  Is there a way to change the resolution to 1280x800?
command of inxi gives
Code: [Select]
Graphics:
  Device-1: Intel Mobile 915GM/GMS/910GML Express Graphics driver: N/A
  Display: server: TinyCore Linux Xvesa 1.3 driver: loaded: N/A
    s-res: 1024x768
  Message: Unable to show advanced data. Required tool glxinfo missing.

« Last Edit: March 22, 2022, 01:45:10 PM by Rich »

Offline frimical

  • Jr. Member
  • **
  • Posts: 75
Re: Change screen resolution to 1280x800 from default 1024x768, how?
« Reply #1 on: March 19, 2022, 10:39:04 AM »
Hello,
you can first try to add to the Grub's kernel command line at boot:   "xvesa=1280x800x32"  it must work.
Regards

Offline puppybyte!

  • Jr. Member
  • **
  • Posts: 63
Re: Change screen resolution to 1280x800 from default 1024x768, how?
« Reply #2 on: March 19, 2022, 11:12:57 AM »
Hi: frimical:
I entered the command you suggesed at boot, by entering Tab, and adding to the end of the line followed by letting it complete the boot but failed.  How do I enter the command exactly?, I do have the extlinux.conf file in the boot folder, do I edit this?, which line?

I appreciate your input.
« Last Edit: March 19, 2022, 11:34:20 AM by puppybyte! »

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 13848
Re: Change screen resolution to 1280x800 from default 1024x768, how?
« Reply #3 on: March 19, 2022, 11:23:00 PM »
Is your other os using Xvesa, Xfbdev or Xorg?

Are you using legacy bios boot or uefi?

Offline puppybyte!

  • Jr. Member
  • **
  • Posts: 63
Re: Change screen resolution to 1280x800 from default 1024x768, how?
« Reply #4 on: March 20, 2022, 05:36:10 AM »
Is your other os using Xvesa, Xfbdev or Xorg?

Are you using legacy bios boot or uefi?

I only run TC13 on a 32bit laptop using JWM window manager.  I boot from an internal hard drive.  No other OS.  As stated above when I ran inxi -Fz (after installing inxi.tcz), I seem to get Xvesa driver.  When I boot up from a usb stick with puppylinux (Bionicpup32), default screen resolutions is 1280x800, which is the resolution that look the best.  How can I run this resolution using TC13?

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 13848
Re: Change screen resolution to 1280x800 from default 1024x768, how?
« Reply #5 on: March 20, 2022, 05:50:27 AM »
You can check which xserver you are running in tinycore and puppylinux using the command "ps aux | grep X" once the gui has started.

The reason I asked about legacy bios versus uefi is that I seem to remember that I get 1366x768 with Xvesa using a uefi boot, but not with a legacy bios boot.

If you are using Xvesa with tinycore, you could try Xorg-7.7 instead - it should use your screen native resolution automatically.

Offline puppybyte!

  • Jr. Member
  • **
  • Posts: 63
Re: Change screen resolution to 1280x800 from default 1024x768, how?
« Reply #6 on: March 20, 2022, 07:43:25 AM »
Hi: Juanito, ps ... command does confirm Xvesa.  I am using legacy bios in an old dell laptop.  I tried Xorg-7.7, after reboot many error messages and prompt, I type in startx and does not work..., something about X...  I am backup again after deleting the line Xorg.. in onboot.lst.
« Last Edit: March 20, 2022, 07:54:15 AM by puppybyte! »

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 13848
Re: Change screen resolution to 1280x800 from default 1024x768, how?
« Reply #7 on: March 20, 2022, 07:53:39 AM »
I type in startx and does not work..., something about X...

Instead of "startx", try "Xorg -nolisten tcp".

Offline puppybyte!

  • Jr. Member
  • **
  • Posts: 63
Re: Change screen resolution to 1280x800 from default 1024x768, how?
« Reply #8 on: March 20, 2022, 08:39:26 AM »
I type in startx and does not work..., something about X...

Instead of "startx", try "Xorg -nolisten tcp".

get long list of errors,.., tried to >error.txt didn't work...  Will give up at this point, got it backup running by deleting xorg line on onboot.lst.

Offline Rich

  • Administrator
  • Hero Member
  • *****
  • Posts: 10210
Re: Change screen resolution to 1280x800 from default 1024x768, how?
« Reply #9 on: March 20, 2022, 08:58:38 AM »
Hi puppybyte!
...  tried to >error.txt didn't work... 
Try:
Code: [Select]
Xorg -nolisten tcp > error.txt 2>&1

Offline frimical

  • Jr. Member
  • **
  • Posts: 75
Re: Change screen resolution to 1280x800 from default 1024x768, how?
« Reply #10 on: March 21, 2022, 11:35:38 AM »
Hello Puppybyte and everybody,

Sorry for the delay and thank you for trying my suggestion eventhough it didn't succeed (and frankly It was expected for different reasons, unless...).

Now that it's clear that you're using extlinux to boot and Xvesa server on an old 32 bits computer with intel graphic card, I may suggest that you try the '915resolution' command. It used to work with no hassle in similar situations, when screen resolutions weren't standard vesa ones.

Once booted normally, you need to have the 915resolution.tcz extension installed, exit from X completly to a terminal, and issue from there:
Code: [Select]
sudo 915resolution 50 1280 800 32 then
Code: [Select]
startx to come back to X

You might still need to use the kernel option 'xvesa=1280x800x32' at the boot prompt.
To answer your question about this option and where it goes: it must be on the boot prompt. Either typed ***without quotes***   or later added in the 'extlinux.conf' file on the 'append' line, inside the section you're using to start TC. ( 'append' line comes after 'linux/kernel' and 'initrd' lines).

You might need it so that it will be added to the '.xsession' file automatically when TC configures itself at boot.
An important note so, maybe you need to replace the '32' by '24' or '16' eventually, in case your screen cannot handle 32 bits depth.

Hope it works.
Regards

Offline puppybyte!

  • Jr. Member
  • **
  • Posts: 63
Hi frimical,

I had given up!, now working perfectly after rebooting.  After installing 915resolution.tcz and confirming startx does indeed work.  I edited my extlinux.conf following your detailed instruction.  I didn't need to create .xsession and only 32 worked but not 24 / 16 on my laptop.  I appreciate your detailed instructions.

Please mark it solved. :)

Offline Rich

  • Administrator
  • Hero Member
  • *****
  • Posts: 10210
Hi puppybyte!
... Please mark it solved. :)
Done.  ;D

Offline frimical

  • Jr. Member
  • **
  • Posts: 75
Hello puppybyte!

I'm really glad to hear that you succeeded and that my explanations were just right for you.

Cheers.

Offline puppybyte!

  • Jr. Member
  • **
  • Posts: 63
Hi, frimical

Your knowledge and willingness to help is appreciated.   :)