WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: TinyCore-current.iso, VMware ESXi 6.7 U3, Console, Mouse doesn't move  (Read 3939 times)

Offline DO76

  • Newbie
  • *
  • Posts: 1
Hi everyone.  I am new to TinyCore and have little to no Linux experience whatsoever.  Sorry, I'm an "M$ Windows" professional.

I am setting up a VMware test lab and need some ultra small VM's to test with and found TinyCore.

I downloaded "TinyCore-current.iso" and was able to a) boot to GUI off ISO and b) install to virtual disk and boot to GUI off vDisk.

But in all cases, when I open the virtual machine use the VMware Web Console to access the system the mouse won't move.  I can click and get the menu, but the mouse just stays in the center of the screen.  Both when booted off CD/ISO and booted off the vDisk.

Google found how to install VMtools with command "tce-load -wi open-vm-tools-desktop".  But no improvement.

Lots of Googling I found references to:
1) Kernel parameter i8042.noloop is the answer
2) pci=noacpi

I tried entering those parameters into the "/mnt/sda1/tcs/boot/extlinux/extlinux.conf" but 1) I don't know if I did it right and if I did it didn't work.

Does anyone have any insights on this?
Any guidance on how I add the kernel parameter or pci= parameter correctly?

TinyCore looks pretty cool and useful but if the mouse won't move I can't use it.

Please help.  Thanks Much!

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 13997

Offline darwinzeng

  • Newbie
  • *
  • Posts: 4
After searching and trying around, I still can't get mouse to work in TinyCoreLinux 13.1 and ESXi 7.0. Could we make an easier way to fix the mouse issue, and add the fix to the base ISO? It's very common for users to load ISO in ESXi, and get frustrated that mouse doesn't move.

I tried to install the open-vm-tools-desktop, but the pangomm.tcz has checksum issue. I can't get the open-vm-tools-desktop installed. Even if I can, it seems we are using large amount of tcz to fix a tiny mouse issue.

Offline Rich

  • Administrator
  • Hero Member
  • *****
  • Posts: 10363
Hi darwinzeng
Welcome to the forum.

I just checked the  pangomm.tcz  files for both x86 and x86_64 in the TC13 repository. The md5sum was correct in both cases.
It's possible you had a corrupt download. Remove all of the  pangomm.tcz  files:
Code: [Select]
rm /etc/sysconfig/tcedir/optional/pangomm.tcz*Then try downloading it again.

Offline darwinzeng

  • Newbie
  • *
  • Posts: 4
Hi Rich,

Thanks a lot for the prompt reply. I have been using TCL for years and I have most questions answered in the forum. Thanks to you guys.

I have a clean TCL install and reinstall the tcz and it works. So the checksum in repository is ok. And the mouse works after I followed this link: newbielink:http://tinycorelinux.net/11.x/x86_64/tcz/open-vm-tools-desktop.tcz.info [nonactive]

I will remaster with the open-vm-tools-desktop.tcz build in so the mouse will work in ESXi. This tcz many times larger than TCL, hope we got a better solution in the future.


Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 10701
It's probably a VM software issue, at least in other VM sws it is. They changed the mouse defaults, and now require drivers for the seamless no-grab behavior. Since most people run the big OSes, it's not a big issue for them.

Try changing the mouse grab settings, or google. E.g. this hit:
https://kb.vmware.com/s/article/1027578
The only barriers that can stop you are the ones you create yourself.

Offline andyj

  • Hero Member
  • *****
  • Posts: 973
The mouse works in TC version 12 and ESXi 6.7, using both the web console and VMRC. I don't have ESXi 7, it doesn't recognize any of the NIC's like it use to so I'm stuck for now. It will take a little while to compile for TC 13 and upload so maybe by tomorrow. The VMware desktop tools require X.org because they have their own video driver, so it pulls in a lot of other libraries. However things like copy/paste, USB support, host folders, sound, resizing only work in VM Workstation or Player, so there isn't much to be gained by running open-vm-tools-desktop in ESXi VM's. Have you tried it using just open-vm-tools only, without the -desktop extension loaded?

Offline darwinzeng

  • Newbie
  • *
  • Posts: 4
Hi curaga,

As long as the mouse can move, seamless no-grab is not a must. I google around and found the most relevant article is:
newbielink:https://kb.vmware.com/s/article/5739104 [nonactive]
While TCL doesn't have xorg.conf and I have no idea how to apply.  It would be great if we can fix it by changing configure.

Hi andyj,

Yes, I tried the open-vm-tools only but it didn't work. At the end of tcz installation, it raised alert: grep: /etc/fuse.conf: No such file or directory
The open-vm-tools failed to start because it can't load the shared lib: libpcre.so.0. I add the lib but the mouse still doesn't move. Maybe you can update the dependency to include it.

Thanks again for all the Heroes.

Offline curaga

  • Administrator
  • Hero Member
  • *****
  • Posts: 10701
That article is about installing the special driver, which is not what you want - that requires xorg, which is big, which you're trying to avoid. You want to change the VM settings to use the previous mouse settings.
The only barriers that can stop you are the ones you create yourself.

Offline darwinzeng

  • Newbie
  • *
  • Posts: 4
Hi curaga, thanks for pointing out. The best solution for me is a quick and small fix in TCL config if possible. Then I can just load the ISO and start doing what I like. I remastered TCL with open-vm-tools-desktop included to achieve this.