WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: xpopple-xpdf in tc12_x64 asked for new libc 2.33+ (from TC13)  (Read 1439 times)

Offline nick65go

  • Hero Member
  • *****
  • Posts: 614
xpopple-xpdf in tc12_x64 asked for new libc 2.33+ (from TC13)
« on: February 27, 2022, 03:51:47 PM »
Code: [Select]
tc@box:/tmp/tcloop/xpopple-xpdf/usr/local/bin$ ldd ./xpdf | grep not
./xpdf: /lib/libc.so.6: version `GLIBC_2.34' not found (required by ./xpdf)
./xpdf: /lib/libc.so.6: version `GLIBC_2.33' not found (required by ./xpdf)
./xpdf: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.29' not found (required by ./xpdf)
was compiled on TC13_x64, but is not suitable for TC12_x64, because the new libc in tc13  :P

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 13997
Re: xpopple-xpdf in tc12_x64 asked for new libc 2.33+ (from TC13)
« Reply #1 on: February 27, 2022, 09:32:09 PM »
xpopple-xpdf removed from 12.x repo

Offline CNK

  • Full Member
  • ***
  • Posts: 103
Re: xpopple-xpdf in tc12_x64 asked for new libc 2.33+ (from TC13)
« Reply #2 on: February 28, 2022, 01:33:44 AM »
I actually submitted two Xpdf extensions, the xpopple-xpdf one was indeed for TC 13 only. The other one was xpdf-motif, which is the original version (last before switching from Motif to the Qt toolkit) that the xpopple project forked from. That one was compiled for TC 12 (and also tested on TC 13), so maybe that's where the confusion came from (plus the Motif library that they both use was built for TC 12).

I guess the xpdf-motif extension was considered superfluous (it's actually the one I'm using because there are slightly smaller deps, but xpopple will have up-to-date PDF rendering), or maybe it's still pending. Either way it can be safely added to the TC 12 repo if desired.

By the way, the Nedit extension which is also pending was also for TC 13 only.

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 13997
Re: xpopple-xpdf in tc12_x64 asked for new libc 2.33+ (from TC13)
« Reply #3 on: February 28, 2022, 02:17:56 AM »
Neither xpdf-motif nor nedit extensions have been received..

Offline CNK

  • Full Member
  • ***
  • Posts: 103
Re: xpopple-xpdf in tc12_x64 asked for new libc 2.33+ (from TC13)
« Reply #4 on: February 28, 2022, 01:48:38 PM »
Neither xpdf-motif nor nedit extensions have been received..

Hmm, that's strange. Though it did worry me sending so many emails with large attachments to the same address in one batch, so maybe they got blocked somewhere.

Both extensions re-sent. If they still don't get through then let me know, there's another mail server that I can use.

Nedit is quite a nice lightweight text editor, also using the Motif toolkit.

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 13997
Re: xpopple-xpdf in tc12_x64 asked for new libc 2.33+ (from TC13)
« Reply #5 on: March 01, 2022, 11:54:13 PM »
Both extensions re-sent. If they still don't get through then let me know, there's another mail server that I can use.

Still nothing received and nothing in the spam folder - gmail marks your emails as "spammable" though  :(

Offline CNK

  • Full Member
  • ***
  • Posts: 103
Re: xpopple-xpdf in tc12_x64 asked for new libc 2.33+ (from TC13)
« Reply #6 on: March 02, 2022, 02:14:05 PM »
Both extensions re-sent. If they still don't get through then let me know, there's another mail server that I can use.

Still nothing received and nothing in the spam folder - gmail marks your emails as "spammable" though  :(

OK I re-sent them using a mail server that I run myself, which hasn't worked either, but because I'm the server admin I got to see the error which my ISP's mail server wasn't passing back on the previous attempt:

Code: [Select]
Subject: Postmaster Copy: Undelivered Mail
Date: Wed,  2 Mar 2022 21:40:02 +0000 (UTC)


<tcesubmit@gmail.com>: host gmail-smtp-in.l.google.com[142.250.141.27] said:
    552-5.7.0 This message was blocked because its content presents a potential
    552-5.7.0 security issue. Please visit 552-5.7.0
    https://support.google.com/mail/?p=BlockedMessage to review our 552 5.7.0
    message content and attachment content guidelines.
    85-20020a630658000000b00373e12bf544si208718pgg.136 - gsmtp (in reply to end
    of DATA command)

The link talks about blocked content in compressed files. I guess this problem is why the Wiki page suggests bcrypt-ing submission attachments, though I saw on the forum that some thought that wasn't required anymore. I guess it still is. Though maybe Gamil's block only gets triggered if lots of such attachments are sent from one address?

Code: [Select]
bcrypt extension.tar.gz
Encryption key: tinycore

No new "Undelivered Mail" messages sent to the "postmaster" account (it only took a minute last time), so I guess that did the trick. If not, I'll just upload the files to a place on my website and send you a link, so let me know.

Oh and "spamable" is actually the name of that other account I was using before. I mainly use it for buying things from online stores that are likely to spam me, and the like.

Offline Rich

  • Administrator
  • Hero Member
  • *****
  • Posts: 10363
Re: xpopple-xpdf in tc12_x64 asked for new libc 2.33+ (from TC13)
« Reply #7 on: March 02, 2022, 02:33:33 PM »
Hi CNK
... though I saw on the forum that some thought that wasn't required anymore. ...
I remember reading that a couple of years ago. I don't agree with that statement. I always used bcrypt when
submitting an extension.

Offline Juanito

  • Administrator
  • Hero Member
  • *****
  • Posts: 13997
Re: xpopple-xpdf in tc12_x64 asked for new libc 2.33+ (from TC13)
« Reply #8 on: March 02, 2022, 10:07:08 PM »
submissions received and posted - it seems bcrypt is still required in at least some cases.

Offline CNK

  • Full Member
  • ***
  • Posts: 103
Re: xpopple-xpdf in tc12_x64 asked for new libc 2.33+ (from TC13)
« Reply #9 on: March 02, 2022, 10:46:53 PM »
Quote
submissions received and posted

Great!

Quote
it seems bcrypt is still required in at least some cases.

Yep, I'll bcrypt all my future submissions.