WelcomeWelcome | FAQFAQ | DownloadsDownloads | WikiWiki

Author Topic: tce-ab  (Read 390 times)

Offline polikuo

  • Hero Member
  • *****
  • Posts: 665
tce-ab
« on: January 14, 2022, 04:19:03 AM »
Hi, all.

I just move on to the newer release. (aarch64)

Code: [Select]
tc@box:~$ uname -a
Linux box 5.10.77-piCore-v8 #1 SMP PREEMPT Sat Nov 13 16:02:16 EST 2021 aarch64 GNU/Linux
tc@box:~$ version
13.1

When I try to browse the apps, it just stops like this.

Quote
Enter starting chars of desired extension, e.g. abi: SearchPhrase
awk: cmd. line:13: 'break' not in a loop
cat: can't open '/tmp/select.ans': No such file or directory
S)earch P)rovides K)eywords or Q)uit:

I haven't found the cause yet, any ideas ?

Offline polikuo

  • Hero Member
  • *****
  • Posts: 665
Re: tce-ab
« Reply #1 on: January 14, 2022, 04:50:00 AM »
I have some new findings.
I believe it's caused by the Core-script "/usr/bin/select"
However, I'm not sure if it's related to the new beta release.
Team Tiny Core is pleased to announce that Tiny Core 13.0 Beta1 is available for public testing:
Changelog for 13.0 Beta1:
* select: require that "break" used in awk scripts
Anyway, I've attached the patch just in case.
« Last Edit: January 14, 2022, 04:52:27 AM by polikuo »

Offline Paul_123

  • Administrator
  • Hero Member
  • *****
  • Posts: 806
Re: tce-ab
« Reply #2 on: January 14, 2022, 09:20:18 AM »
I was the one who did the patch in the first place.  https://github.com/tinycorelinux/Core-scripts/commit/2fd10f8ac30b66f494f8428f477befa43dcdc260

I guess there is a possibility I forgot the put the correct version of select in the initrd.  I'll take a look